Multiserver bei Emaildomain kein Servername

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von etron770, 13. Nov. 2014.

  1. etron770

    etron770 Member

    Server 1 IspConfig und Wheezy Webserver (Master)
    Server 2 IspConfig und Wheezy Mailserver (slave)

    Eingentlich funktioniert alles außer das ich auf beiden Servern beim Anlegen einer E-Mail Domain keinen Servernamen habe.
    Beim Anlegen eines Webspace habe ich den Servernamen. Es müsste doch der Mailserver als Servername erscheinen oder?
    Dsa Anlegen und benutzen der mailboxen funktioniert auch ohne Servernamen.
     
  2. Till

    Till Administrator

    Das kann 2 Ursachen haben, entweder bei dem server ist unter System > server services kein haken bei mailserver gesetzt oder wenn es nur im Kundenlogin auftaucht, dann ist kein default mail server in den Kundenlimits gesetzt.
     
  3. etron770

    etron770 Member

    Es ist kein Haken gesetz, weil der Master kein Mailsystem hat ...dachte ich..
     
  4. Till

    Till Administrator

    Das ist ok, der haken muss nur beim mailserver gesetzts ein aber dann darf nicht "ist mirror von server" gesetzt sein. Denn wenn der slave ein mirror eines anderen server ist, dann kommt es darauf an ob Dienste auf dem master aktiv sin oder nicht.

    Wenn Du einen mail und einen webserver hast, dann darf mirroring nicht an sein.
     
  5. etron770

    etron770 Member

    Sorry ich verstehe es eintweder nicht oder ich habe falsch konfiguriert.
    Wenn ich ist Mirror von server1 ausschalte dann werden die E-mail Adressen/Konten nicht synchronisiert.
    Hab ich das als Mirror aufgesetzt anstatt das Setup für
    3.2.1.7 Adjust The Server Settings In ISPConfig?
    oder ist das grundsetup für Mirror und Master und Slave gleich?
     
  6. wotan2005

    wotan2005 Member

    was wolltest du den mit deinem Setup erreichen, Verfügbarkeit/Ausfallsicherheit oder nur verteilte Dienste?
     
  7. etron770

    etron770 Member

    Verteilte Dienste
     
  8. wotan2005

    wotan2005 Member

    dann brauchst du kein Mirror!
    Dann machst eine einfache Multiserver Installation und gibst nur den Nodes die Dienste, dies sie verwalten sollen.
    Den ersten installierst du als Master und die weiteren fügst du nur zum Master hinzu.
     

Diese Seite empfehlen