Multiserver Installation von ispconfig3, postfix/dovecot problem mit mysql

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von captivus, 24. Feb. 2011.

  1. captivus

    captivus New Member

    Hi,

    ich habe eben zum xten mal versucht, ein Multiserversetup von ispconfig durchzuführen, und mir sind ein paar Sachen aufgefallen, die a) nicht funktionieren, bzw bei denen ich mir b) unsicher bin.

    1. Werden wirklich auf allen nodes im multiserver setup lokale mysql datenbanken benötigt ?

    2. Wie soll es funktionieren, wenn ich auf dem "hauptadmin" server eine Domain + Mailbox einrichte, dass der entfernte Mailserver etwas von dieser domain + mailbox weiss !?
    Schaue ich in die Config Dateien in /etc/postfix/*.mysql*, steht dort überall "hosts = 127.0.0.1" drin, aber in der lokalen Datenbank steht keine domain oder die Mailbox drin, sondern diese sind auf dem Hauptserver angelegt. Wie soll das lokale postfix/dovecot wissen, welche mailboxen etc angelegt sind. Ist hier die Installation schiefgelaufen ?

    3. Passiert eigentlich noch etwas in den lokalen Datenbanken nachdem man den ispconfig lokal in eine bestehende Multiserversetup-Umgebung installiert hat, oder können die weg ? Es gefällt mir gar nicht, auf 8 Server 8 lokale Datenbanken zu haben ...

    Danke und Gruß,

    Oliver
     
    Zuletzt bearbeitet: 24. Feb. 2011
  2. Till

    Till Administrator

    1) Ja.
    2) Das macht die in ISPConfig eingebaute Daten und Konfigurationsreplikation.
    3) Die lokalen datenbanken werden von ISPConfig für die Replikation verwendet. Alle Dienste eines Server connecten immer nur zur lokalen Datenbank. Sonst hättest Du ja einen sigle point of failure und Dein ganzer cluster wäre offline wenn mal der master ausfällt. Also nichts an den lokalen DB's ändern!
    4) Das Handbuch enthält die Beschreibung aller Funktionen von ISPConfig. Dass dort auch das Multiserver Tutorial gelistet ist steht ja im Inhlatsverzeichnis welches Du auf der Seite findest wo man das handbuch kaufen kann.
     
  3. captivus

    captivus New Member

    ok, und was nun ;) ?

    Hi Till,

    danke für die Antwort, aber was heisst denn das nun ?

    Antwort 3 beschreibt ja, dass die lokale Datenbank verwendet wird. Wie aber kommen denn die Daten wie mailboxen und domains in die lokalen Datenbanken auf dem Mailserver ? Dort wollte ich ja gar keinen Apachen und nichts laufen haben .. ?

    Gruß, Oliver
     
  4. Till

    Till Administrator

    Siehe Antwort 2: "Das macht die in ISPConfig eingebaute Daten und Konfigurationsreplikation."

    Wofür sollte dort denn ein apache benötigt werden? Schau doch mal ins multiserver tutorial, da ist es exakt beschrievben wleche pakete für welchen Servertyp (myilserver, webserver, dns- server und db server) benötigt werden. Apacahe ist nur auf dem webserver installiert.
     
  5. captivus

    captivus New Member

    gut, ich habe eben versucht, erneut eine domain auf dem hauptserver anzulegen, und eine neue mailbox. Dort kann ich auch aus den tabellen selecten, und bekomme die mailbox in mysql angezeigt.
    Auf dem mailserver allerdings passiert nichts.

    Habe ich was vergessen ? Welche replikationsmechanismen sollen denn da zum tragen kommen, bzw die domains + mailboxen in die richtige (lokale) DB kommen ?!

    Danke, Oliver
     
  6. Till

    Till Administrator

    Dann liegt wohl ein installationsfehler bzw. Konfigurationsfehler vor.

    ISPConfig verwendet eine asynchrone Synchronistaion. Es dauert also bis zu einer Minute, bis die Konfiguration auch auf dem Slave geschrieben ist. Vorausgesetzt das setup ist korrekt. Dabei verbinden sich die slaves mit der Master DB und replizieren alle für sie bestimmten records, bevor sie die lokalen Konfigurationsdateien schreiben.

    Hast Du denn als Zielserver für die Emaildomain den richtigen Server ausgewählt bzw. wenn es sich um ein mirroe sertup handelt, das mirroring für den Zeilserver aktiviert?

    Einer der häufisgsten Fehler der gemacht wird ist dass nicht alle Hostnamen so wie in der Anleitung beschrieben in die /etc/hosts ALLER server eingetragen werden oder das jemand die IP adressen statt hostnamen bei der ISPConfig Installation auf den Slaves verwendet hat. Schau also nochmal in die Anleitung ob Du alles eaxkt wie dort beschrieben gemacht hast, und nicht irgendwo eine Ip satt des hostnamens genommen hast, wo in der Anleitung ein hostname steht. insbesondere im ispconfig installer ist das sehr wichtig, dass alle mysql Server nur über hostnamen und nicht die IP's angesprochen werden. Ansonsten geht der cluster nicht.
     
  7. captivus

    captivus New Member

    ok ..

    ah ok, das ist eine sache die ich vergessen haben könnte.

    Auf dem "admin server" der eigentlich nichts machen soll, ausser das ispconfig interface zu haben, habe ich keine einträge in die hosts gemacht, aber die namen der anderen server sind nicht im dns und auch nicht in der hosts datei.

    Es handelt sich nicht um ein mirrorsetup.

    Ich teste und sage Bescheid.

    Danke, Oliver
     

Diese Seite empfehlen