Multiservser Setup und phpmyadmin

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von planet_fox, 25. Mai 2011.

  1. planet_fox

    planet_fox Super-Moderator

    Hallo

    1.
    ich habe einen Server im Multisetup ISPConfig3 . Es gibt drei Server auf einem rennt der Webserver mit ISPConfig 3 Oberfläche. Dann ein Mailserver und ein Datenbankserver. Nun ist auf dem Webserver natürlich phpmyadmin isntalliert und greift auf den Haupt Mysql zu sprich localhost. Nun muss cih ja einstellen dass er auf den mysqlserver zu greift. Aber wenn ich phpmyadmin installiere und den phpmyadmin verbindung aufnehmen will bekomme ich keine Verbindung.

    2. Die Logfiles für die Stats werden nicht erstellt,da es sich um openvz gäste handelt kann ich quota nciht einrichten, was müsste ich tun um hier die quota zu sehen .
     
  2. planet_fox

    planet_fox Super-Moderator

    Logs von cat /var/log/ispconfig/cron.log auf dem Datenbankserver

    Code:
    PHP Warning:  mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    PHP Warning:  mysql_connect(): Lost connection to MySQL server at 'reading initial communication packet', system error: 113 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
    PHP Warning:  mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    PHP Warning:  mysql_connect(): Lost connection to MySQL server at 'reading initial communication packet', system error: 113 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
    PHP Warning:  mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    PHP Warning:  mysql_connect(): Lost connection to MySQL server at 'reading initial communication packet', system error: 113 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
    PHP Warning:  mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    PHP Warning:  mysql_connect(): Lost connection to MySQL server at 'reading initial communication packet', system error: 113 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
    PHP Warning:  mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    sh: repquota: not found
    sh: repquota: not found
    
     
  3. Till

    Till Administrator

    zu 1)

    Das cron.log ist nur für ISPConfiug, hat also nichts mit phpmyadmin zu tun. Des weiteren sind das obige nur Warnings und keine Errors, also nichts was zu einem Problem führt.

    Zu Deienm ursprünglichen Problem. Überprüfe die Firewall des slave und dass mysql auf allen IP's läuft und dass Du auch die IP Adresse des Mastres beim anlegen der Datenbanken erlaubt hast.

    zu 2) Du hast vergessen die quota tools zu installieren.
     
  4. planet_fox

    planet_fox Super-Moderator

    1)
    hm, lokal komme ich drauf. in der my.cnf bind eintrag auch raus
    Du meinst hier den Punkt ?

    Code:
    CREATE USER 'root'@'192.168.0.106' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.106' IDENTIFIED BY  'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0  MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0  ; 

    2)

    Code:
    # apt-get install quota quotatool
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    quota is already the newest version.
    quotatool is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    
     
  5. Till

    Till Administrator

    Nein, das meine ich nicht. Es geht ja hier um die logins zu den client Datenbankne und nicht den root Login. Den Login zu den client datenbanken definierst Du in den datenbankeinstellungen beim anlegen der Datenbank.

    zu 2) Laut cron.log iste s aber auf dem Server nicht installiert. Also nochmal alle Server des Clusters prüfen.
     
  6. planet_fox

    planet_fox Super-Moderator

    Meisnt du im ISPCONFIG3 Inetrface hier

    zu 2) du meintest quota muss auf allens Servern installiert sein ?
    waren auf dem db server und mailserver nciht drauf damit hattest du recht.
     
  7. planet_fox

    planet_fox Super-Moderator

    via telnet vom webserver

    Code:
     telnet 172.20.20.3 3306
    Trying 172.20.20.3...
    Connected to 172.20.20.3.
    Escape character is '^]'.
    :
    5.1.49-3-logXZ`Ug&$#zi|VvrW>m,1P
    ^CConnection closed by foreign host.
    root@bart:/#  telnet 172.20.20.3 3306
    Trying 172.20.20.3...
    Connected to 172.20.20.3.
    Escape character is '^]'.
    :
    5.1.49-3-logZm:wj/JfYubks!F|aRS.^CConnection closed by foreign host.
    
     
  8. planet_fox

    planet_fox Super-Moderator

    ok hab hier ncoh ein problem aber mit dem mailserver

    Code:
    May 26 15:28:34 marge postfix/smtp[15159]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
    May 26 15:28:35 marge postfix/error[15162]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
    May 26 16:03:34 marge amavis[14829]: (14829-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 103) line 241, <GEN32> line 4.
    May 26 16:03:34 marge postfix/smtp[15483]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
    May 26 16:03:35 marge postfix/error[15486]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
    
    Inhalt von etc/postfix/mysql-virtual_relaydomains.cf

    Code:
    user = ispconfig
    password = xxxxxxxxxxxxxxxxx
    dbname = dbispconfig
    table = mail_transport
    select_field = domain
    where_field = domain
    additional_conditions = and active = 'y' and server_id = 2
    hosts = 172.20.20.4
    
    bei host ist richtig dass dort die ip des mailsers drin is ?
     
  9. planet_fox

    planet_fox Super-Moderator

    Datenbank verbindung geht nun folgendes gemacht, mailserver muss cih mal sehn evtl des selbe Problem .

    Code:
    Ich habe das Problem gefunden. Wie ich das im Netz gesehen habe bin ich  nicht der einzige, der dieses Problem hatte, deshalb hier die Lösung:
    Auf dem Host /etc/vz/vz.conf öffnen und dem Eintrag IPTABLES folgendes hinzufügen:
    iptable_nat
    
    Danach den Dienst und alle VMs per /etc/init.d/vz restart neu starten und ende.
     
  10. planet_fox

    planet_fox Super-Moderator

    ftp geht auch da stand in der pureftp config für mysql die ip des servers. nun habe ich dies geändert auf localhost und beim postfix server auch. Postfix meldet zwar keine login fehler mehr aber andere

    Code:
    May 26 18:48:02 marge dovecot: imap-login: Disconnected (no auth attempts): rip=88.17.13.4, lip=172.20.20.4, TLS handshaking: Disconnected
    May 26 18:50:29 marge dovecot: imap-login: Disconnected (auth failed, 3 attempts): user=<adm@host.net>, method=PLAIN, rip=88.17.13.4, lip=172.20.20.4
    May 26 18:50:35 marge dovecot: imap-login: Aborted login (no auth attempts): rip=88.17.13.4, lip=172.20.20.4
    
     
  11. planet_fox

    planet_fox Super-Moderator

    So ich hab jetzt, den ISPConfig Server gewnadlet zum Singleserver. So wenn ich ein update mache dann schreibt er mir überall wieder die alte ip des datenbank servers rein. Des zweite amavisd bekommt keine verbindung zum lokalen server obwohl zugang passt. E-mail rein wie raus geht, wenn ich lokal schreibe. Wenn ich versuche via Thunderbird zu zu greifen dann kann ich empfangen aber bei versand fragt er dauernt wegen passwort.Wenn ich dieses eingebe interessiert ihn dass nicht
     
  12. Till

    Till Administrator

    Ich verstehe nicht, was Du damit meinst. Wenn Du nur noch einen Server hast, wo kommt dann ein zweites amvisd her und wie hast Du einen multiserver zum single server umgewandelt, das ist im ispconfig 3 installer und updater nicht vorgesehen. Da müsstest Du also den Code geändert haben.
     
  13. planet_fox

    planet_fox Super-Moderator

    Geht fats alles, nur woher weiß der updater von ISPConfig dass es vorher einen Dattenbank Server gab. Er schreibt in die gnazen sql verbindungen immer die IP des alten Datenbankservers rein und nicht die neuen.
     
  14. Till

    Till Administrator

    Der Installer erkennt das anhand der Einträge in der server tabelle sowie den Einträgen in den Tabellen der mysql.mysql Datenbank.
     

Diese Seite empfehlen