myDNS mit Bind kommunizieren

#1
Tasch auch :)

Wir haben gestern ein CentOs 5.3 Server mit ISPConfig 3 installiert.
Dank dem super Tutorial auch keine Sache :p

Jetzt gibt es noch ein Problem mit der DNS.
Wir haben NS2 und NS3 auf anderen - nicht unseren Servern.
Diese laufen mit BIND und wir haben ein Login um neue Zonen erstellen zu können.

Soweit passt alles - neue Seite angelegt, Zone im NS2 und NS3 angelegt und diese haben die Daten abgeglichen.

Wenn ich nun aber ein CName eintrage und warte bis NS2 und NS3 diese Änderung erhalten - verzweifle ich, respektive es funktioniert nicht.

Zeigt sich hier ganz nett: www.intodns.com

x5 master (mydns)
x9 / 1x slaves (bind)

Code:
Looks like your nameservers do not agree on the SOA serial. Ths SOA records as reported by your nameservers:
87.118.xxx.x9 ->  2009072505
94.230.xxx.x5 ->  2009072507
87.118.xxx.1x ->  2009072505
This can cause some serious problems that is why you should fix this asap.
In mydns selbst ins Notify auch enabled

Code:
[root@boss ~]# mydns -d -v
mydns[12681]: AXFR is enabled
mydns[12681]: TCP ports are enabled
mydns[12681]: DNS UPDATE is enabled
mydns[12681]: DNS NOTIFY is enabled
mydns[12681]: DNS IXFR is not enabled
mydns[12681]: optional 'xfer' column found in 'dns_soa' table
mydns[12681]: mydns 1.2.8.27 started Sat Jul 25 12:09:42 2009 (listening on 3 addresses)
und dig mit axfr funzt auch
dig with type AXFR:
Code:
 [root@boss ~]# dig @94.230.xxx.x5 axfr domain.to

; <<>> DiG 9.3.4-P1 <<>> @94.230.xxx.x5 axfr domain.to
; (1 server found)
;; global options:  printcmd
domain.to.               86400   IN      SOA     ns1.domain.to. root.domain.to. 2009072531 28800 7200 604800 86400
boss.domain.to.          86400   IN      A       94.230.xxx.x5
ftp.domain.to.           86400   IN      A       94.230.xxx.x5
mail.domain.to.          86400   IN      A       94.230.xxx.x5
ns1.domain.to.           86400   IN      A       94.230.xxx.x5
domain.to.               86400   IN      A       94.230.xxx.x5
domain.to.               86400   IN      MX      10 mail.domain.to.
domain.to.               86400   IN      NS      ns1.domain.to.
domain.to.               86400   IN      NS      ns2.wwwroot.to.
domain.to.               86400   IN      NS      ns3.wwwroot.to.
[URL="http://www.domain.to/"]www.domain.to[/URL].           86400   IN      A       94.230.xxx.x5
domain.to.               86400   IN      SOA     ns1.domain.to. root.domain.to. 2009072531 28800 7200 604800 86400
;; Query time: 7 msec
;; SERVER: 94.230.xxx.x5#53(94.230.xxx.x5)
;; WHEN: Sat Jul 25 12:28:45 2009
;; XFR size: 12 records (messages 12)

[root@boss ~]# dig @87.118.xxx.x9 axfr domain.to

; <<>> DiG 9.3.4-P1 <<>> @87.118.xxx.x9 axfr domain.to
; (1 server found)
;; global options:  printcmd
domain.to.               86400   IN      SOA     ns1.domain.to. root.domain.to. 2009072512 28800 7200 604800 86400
domain.to.               86400   IN      NS      ns1.domain.to.
domain.to.               86400   IN      NS      ns2.wwwroot.to.
domain.to.               86400   IN      NS      ns3.wwwroot.to.
domain.to.               86400   IN      A       94.230.xxx.x5
domain.to.               86400   IN      MX      10 mail.domain.to.
ftp.domain.to.           86400   IN      A       94.230.xxx.x5
mail.domain.to.          86400   IN      A       94.230.xxx.x5
ns1.domain.to.           86400   IN      A       94.230.xxx.x5
[URL="http://www.domain.to"]www.domain.to[/URL].           86400   IN      A       94.230.xxx.x5
domain.to.               86400   IN      SOA     ns1.domain.to. root.domain.to. 2009072512 28800 7200 604800 86400
;; Query time: 19 msec
;; SERVER: 87.118.xxx.x9#53(87.118.xxx.x9)
;; WHEN: Sat Jul 25 12:27:18 2009
;; XFR size: 11 records (messages 1)
Ich hoffe jemand kann mir helfen :D
Bin gerade am Ende mit meinen Latein:p

Thanks for the fish
 

Till

Administrator
#2
Versuch bitte mal einen reload oder wenn das nichts bringt einen restart auf mydns auszuführe, wird dann der bind slave aktualisiert?
 

Werbung