MyDNS Problem mit ISPConfig 3

#1
Hallo, ich hab nach der Anleitung "Perfekter Server openSuse 11.1" ein Webserver eingerichtet mit ISPConfig 3.

Soweit scheint alles zu laufen, nur ISP Config sagt das MyDNS nicht läuft.

Wenn ich "mydns start" aufrufe kommt:
mydns: Extraneous command-line arguments ignored
mydns[4076]: Error connecting to MySQL server at localhost: Unknown database 'mydns' (errno=0)
Es scheint die Datenbank "mydns" zu fehlen, allerdings wurde nirgendwo gesagt, das man die selber anlegen soll! Oder soll ich in der config die Datenbank von ipsconfig nehmen?

Was mich auch wundert unter "Tools" finde ich kein phpmysql obwohl ich das eingerichtet habe, sondern nur die Möglichkeit Passwort und Sprache zu ändern! Was hat das unter "Tools" zu suchen?

Danke
 
#2
Dauert ja ganz schön bis hier hilfe kommt ;)

Ich hab jetzt die Tabelle mydns angelegt, bekomm aber trotzdem noch den fehler:

mydns start
mydns: Extraneous command-line arguments ignored
mydns[7757]: mydns 1.2.8.27 started Wed May 5 12:17:48 2010 (listening on 4 addresses)
mydns[7757]: interrupted
mydns[7760]: interrupted
mydns[7757]: h1755662 up 1m44s (104s) 2 questions (0/s) NOERROR=1 SERVFAIL=0 NXDOMAIN=0 NOTIMP=0 REFUSED=0
mydns[7760]: h1755662 up 1m44s (104s) 6 questions (0/s) NOERROR=1 SERVFAIL=0 NXDOMAIN=0 NOTIMP=0 REFUSED=0
Kann mir jemand helfen?
 

Till

Administrator
#3
Es scheint die Datenbank "mydns" zu fehlen, allerdings wurde nirgendwo gesagt, das man die selber anlegen soll!
Du sollst ja auch keine DB mit dem Namen selbst anlegen. Wenn Du das machen würdest, erhältst Du höchstens ein nicht lauffähiges setup.

Dein Problem sieht mir eher danach aus, als ob Du mydns nach ISPConfig installiert hats bzw. nach der Installation von ISPConfig die mydnsconfig Konfigurationsdatei überschrieben wurde. Um das zu beheben, musst Du ein manuelles ispconfig update durchführen und beim update auswählen, dass die Dienste rekonfiguriert werden.

http://www.howtoforge.de/forum/showthread.php?t=2930

Was mich auch wundert unter "Tools" finde ich kein phpmysql obwohl ich das eingerichtet habe, sondern nur die Möglichkeit Passwort und Sprache zu ändern! Was hat das unter "Tools" zu suchen?
Weil diese Funktionen in ISPConfig nunmal da sind und auch da sein sollen.
 
#4
Hallo,

danke! Hab ich jetzt gemacht! Server neugestartet. Läuft trotzdem nicht!
Ich hab genau nach Anleitung gehandelt. Hab das eigentlich vorher installiert!

Der Monitor sagt: myDNS Server offline :eek:(

Was kann ich noch tun bzw. was kann die Fehlermeldung noch aussagen?
mydns start
mydns: Extraneous command-line arguments ignored
mydns[3157]: ipv4_listerner: bind on socket 6 (TCP) failed: 127.0.0.1+53: Address already in use

Zu Tools:
Gehören Passworteinstellungen nicht eher unter Einstellungen? ;O)

Wo finde ich phpmyadmin auch für root, und den webmail client, hatte ich auch alles installiert und verlinkt?

Danke!
 
#5
Also, in ISP Config steht jetzt da das der myDNS Server läuft, trotzdem Meldung oben!

Jetzt bleibt nur noch die Frage nach phpmysqladmin und dem webmail?
 

Till

Administrator
#6
Bie Dir läuft noch ein anderer dns Server, daher kann mydns nicht gestarte werden da der Port bereits in benutzung ist. Schau mal mit:

netstat -tap | grep dns

nach und entferne den anderen DNS bevor Du mydns startest.

Zu Tools:
Gehören Passworteinstellungen nicht eher unter Einstellungen? ;O)
Einstellungen ist ein Modul des System Administrators, wenn Du jedem User root Rechte geben möchtest, kannst Du das ja gerne machen. Ich bevorzuge es an sich wenn nicht jeder kunde den ganzen Server steuern kann ;)

Wo finde ich phpmyadmin auch für root, und den webmail client, hatte ich auch alles installiert und verlinkt?
http://IP/phpmyadmin und http://IP/webmail
 
#9
hm, nach dem reboot ist die ausgabe immer noch gleich! wo durch kann das noch passieren?

Ist irgendwo die Verwaltung der DNS Zonen für ISP Config dokumentiert, so richtig versteh ich das dort nicht...
 

Till

Administrator
#10
hm, nach dem reboot ist die ausgabe immer noch gleich! wo durch kann das noch passieren?
Du meinst also das ein Restart von mydns auf der Shell noch immer mit einer Fehlermeldung:

bind on socket 6 (TCP) failed: 127.0.0.1+53: Address already in use

fehlschlägt? Ansonsten ist alles OK.

Ist irgendwo die Verwaltung der DNS Zonen für ISP Config dokumentiert, so richtig versteh ich das dort nicht...
Das ist ganz einfach, Du nimmst den DNS Wizard, trägst Domain, ns1, ns2 und die IP ein und klickst auf speichern.
 
#11
Ja, die Meldung kommt immernoch...naja, hauptsache es geht erstmal so!

Wozu brauch ich die DNS Zones? Versteh ich jetzt nicht ganz. Wenn ich jetzt bei meinem Domain-Hoster meine Domain auf meine Server-IP zeigen lasse, und meine Seite in ISPConfig einrichte, zeigt die Domain dann auf mein Ordner wie sie soll? Wozu brauch ich dann die DNS Zones?

Sorry für die dumme Fragen ;O)
 

Till

Administrator
#12
Wozu brauch ich die DNS Zones? Versteh ich jetzt nicht ganz. Wenn ich jetzt bei meinem Domain-Hoster meine Domain auf meine Server-IP zeigen lasse, und meine Seite in ISPConfig einrichte, zeigt die Domain dann auf mein Ordner wie sie soll? Wozu brauch ich dann die DNS Zones?
Gernicht. ISPConfig ist ein Hosting Control panel für provider und die brauchen dann natürlich auch eigene dns zones. Wenn Du aber kein Domain Registrar bist und Deine Domains über Deinen provider verwaltest, benötigst Du garkeinen lokalen DNS.
 
#13
Okay. Ich brauch das nur um für mich schnell paar Seiten zu hosten!

Noch eine kleine Frage? Ich hab grad eine Seite hochgeladen per FTP. Ich kann die htaccess nicht ersetzen, Sie hat aber den User "web1" auch wenn ich 777 setze geht es nicht. Ich kann Dateien auch nicht ersetzen. Wenn ich die index.php hochladen will und ersetzen lassen will, ersetzt der die nicht, sondern läd diese als index.php.1 hoch? Was ist das für ein verhalten?
 

Till

Administrator
#14
Schau dir mal die pure-ftp Konfigurationsdatei der Linuxdistribution an, da ist das mit Sicherheit so eingestellt und Du kannst es dort auch ändern.
 
#15
Danke habs hinbekomm!

Ich hab bei Site -> PHP -> fast-cgi ausgewählt, und es läuft kein php!
Steht immer da : Access denied.

Was stimmt da wieder nicht?

Danke!
 
#16
außer mein post vorher das ist auch noch ein problem:

rcapache2 restart
httpd2-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.2 for ServerName
[Wed May 05 16:28:02 2010] [warn] NameVirtualHost 85.xxx.xxx.186:443 has no VirtualHosts
[Wed May 05 16:28:02 2010] [warn] NameVirtualHost 85.xxx.xxx.186:80 has no VirtualHosts
[Wed May 05 16:28:02 2010] [warn] NameVirtualHost 85.xxx.xxx.186:443 has no VirtualHosts
Syntax OK
Shutting down httpd2 (waiting for all children to terminate) done
Starting httpd2 (prefork) httpd2-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.2 for ServerName
[Wed May 05 16:28:03 2010] [warn] NameVirtualHost 85.xxx.xxx.186:443 has no VirtualHosts
[Wed May 05 16:28:03 2010] [warn] NameVirtualHost 85.xxx.xxx.186:80 has no VirtualHosts
[Wed May 05 16:28:03 2010] [warn] NameVirtualHost 85.xxx.xxx.186:443 has no VirtualHosts
Kannst du mir da helfen. Ganz schon kompliziert, das system zum laufen zu bekomm!
 

Till

Administrator
#17
außer mein post vorher das ist auch noch ein problem:

Kannst du mir da helfen. Ganz schon kompliziert, das system zum laufen zu bekomm!
Das ist ok so und kein Fehler. wen es ein Fehler wäre, würde dort [Error] in den Eckigen Klammern stehen. Die Meldung besagt lediglich, dass noch nicht für jede mögliche IP websites eingerichtet wurden.

Danke habs hinbekomm!

Ich hab bei Site -> PHP -> fast-cgi ausgewählt, und es läuft kein php!
Steht immer da : Access denied.

Was stimmt da wieder nicht?
Schau ins error.log der Webseite, da steht es dann drin.

Häufige Ursachen:

a) Suexec im Web nicht aktiviert
b) PHP Scripte gehören nicht dem Website User.
 
#18
wie suexec im web nicht verfügbar? Wie aktivier ich das denn bzw. wo?
laufen tut es auf jeden Fall!

Die PHP-Skripte laufen unter dem richtige Benutzer!
 
#20
Ich versteh die was du mit Webs meinst? Einstellung in ISPConfig? Apache?

Hier das log nach einem rcapache restart:
[Wed May 05 17:21:43 2010] [notice] caught SIGTERM, shutting down
[Wed May 05 17:21:44 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 05 17:21:44 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Wed May 05 17:21:44 2010] [notice] Apache/2.2.13 (Linux/SUSE) mod_ssl/2.2.13 OpenSSL/0.9.8k PHP/5.3.2 configured -- resuming normal operations
was hinzukommt nach dem seitenaufruf:

[Wed May 05 17:21:43 2010] [notice] mod_fcgid: process /srv/www/domain.org/web/index.php(10327) exit(shutting down), terminated by calling exit(), return code: 0
 
Zuletzt bearbeitet:

Werbung

Top