MySQL - Problem?

#1
Guten Tag zusammen

Eine etwas komische Sache:
Habe heute Morgen an/in einem Web gearbeitet das unter ISPConfig gehostet ist. Zuerst keine Probleme, alles (http, e-mail und ftp) lief.

Doch plötzlich kam ich nicht mehr per ftp auf den Server. Die Verbindungsaufname ab dem Client geht ganz normal:
Code:
USER xyz
331 User xyz OK. Password requrired
PASS ******
530 Login authentication failed
(Dabei ist das Passwort im Client gespeichert.) Zur Sicherheit habe ich einen neuen ftp-User angelegt, Passwort von Hand eingegeben, Server 2 mal neu gestartet = Gleiches Ergebnis.

Im Systemlogfile finde ich
Code:
Oct  1 07:53:28 pluto mysqld[15173]: refused connect from localhost
Oct  1 07:53:28 pluto mysqld[15173]: refused connect from localhost
Oct  1 07:53:44 pluto pure-ftpd: (?@193.247.250.21) [INFO] New connection from 193.247.250.21
Oct  1 07:53:45 pluto mysqld[15173]: refused connect from localhost
Oct  1 07:53:45 pluto pure-ftpd: (?@193.247.250.21) [ERROR] The SQL  server seems to be down [Lost connection to MySQL server at 'reading  initial communication packet', system error: 0]
Oct  1 07:53:49 pluto pure-ftpd: (?@193.247.250.21) [WARNING] Authentication failed for user [xyz]
Oct  1 07:54:01 pluto /usr/sbin/cron[17279]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Der MySQL - Server läuft, denn die Seite ist ein Shop und der ist ganz normal erreich- und sichtbar.

Ich habe keine Ahnung was da passiert ist und was mir das Logfile mit " 'reading initial communication packet' " mitteilen möchte.
Wie behebe ich den 'Fehler'?

Vielen Dank für Eure Hilfe und ein schönes Wochenende wünscht
ralf

PS
Auch Mail scheint betroffen zu sein: Im Mail-Error-Protokoll steht:
Code:
Oct  1 08:29:18 pluto postfix/trivial-rewrite[24495]: fatal:  proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix):  table lookup problem
 

nowayback

Well-Known Member
#2
Moinsen,

ist nur ne Vermutung, aber kann es sein, das der user root und/oder user ispconfig keinen localhost eintrag haben - d.h. sich nicht von localhost verbinden dürfen sondern von allen hosts (% in Liste)?

Shell Befehle:
Code:
mysql -u root -p
Enter drücken und Passwort eingeben, dann mit Enter bestätigen

Code:
SELECT User, Host FROM mysql.user;
nachschauen ob die beiden user als hosteintrag "localhost" drinstehen haben.

Sollte soähnlich aussehen:
Code:
mysql> SELECT User, Host FROM mysql.user;
+------------------+------------------+
| User             | Host             |
+------------------+------------------+
| ispconfig        | localhost        |
| root             | localhost        |
+------------------+------------------+
2 rows in set (0.00 sec)
Es können da durchaus weitere User drinstehen... das ist nur ein Beispiel.

Grüße
nwb
 
#3
Schönen guten Morgen

vielen Dank für die Idee und auch für die Bekanntgabe der benötigten Befehle. Habe ich gemacht und folgendes gesehen:
Der User root hat je einen Eintag mit: 127.0.0.1, feste externe IP (ich bei einem Kollegen), localhost und pluto (so heisst der Server).
Der User ispconfig hat nur einen Eintag mit localhost.

Daneben gibt es einen User ohne Namen mit 2 Einträgen: localhost und pluto.

Ist das so Richtig, müsste ja sein.

Auffällig an der ganzen Sache ist, dass der Shop (Zen-Card) läuft, (also somit MySQL)
jedoch:
* Piwik (Analyse-Programm, auch DB-basiert) beim Aufruf die Konfiguration bemängelt. (Liegt aber richtig vor.)
* kein ftp - Zugang möglich ist. Bei keiner Domain.

Gemacht habe ich bevor der 'Fehler' auftrat wie immer nichts. :) Ausser im Shop html - Code korrigiert.

Bin für jede Hilfe dankbar und wünsche allen einen schönen, sonnigen Sonntag.
ralf

Nachtrag:
ssh läuft wohl ebenfalls nicht. Das soeben im Log gesehen:
Oct 2 07:02:58 pluto sshd[28518]: refused connect from localhost (127.0.0.1)
Oct 2 07:02:59 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:02:59 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:02:59 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:02:59 pluto mysqld[19476]: refused connect from localhost
neben dem bekannten:
Oct 2 07:01:01 pluto pure-ftpd: (?@192.168.2.42) [INFO] New connection from 192.168.2.42
Oct 2 07:01:01 pluto /usr/sbin/cron[28367]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Oct 2 07:01:02 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:01:02 pluto pure-ftpd: (?@192.168.2.42) [ERROR] The SQL server seems to be down [Lost connection to MySQL server at 'reading initial communication packet', system error: 0]
Oct 2 07:01:07 pluto pure-ftpd: (?@192.168.2.42) [WARNING] Authentication failed for user [abc]
Oct 2 07:01:10 pluto pure-ftpd: (?@192.168.2.42) [INFO] Logout.
Oct 2 07:01:57 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:01:57 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:01:57 pluto mysqld[19476]: refused connect from localhost
Oct 2 07:01:57 pluto mysqld[19476]: refused connect from localhost
 
Zuletzt bearbeitet:

nowayback

Well-Known Member
#4
Moinsen,

Nachtrag:
ssh läuft wohl ebenfalls nicht. Das soeben im Log gesehen:
Dein SSH läuft nicht? Wie loggst du dich dann auf dem Server ein?


Oct 2 07:02:58 pluto sshd[28518]: refused connect from localhost (127.0.0.1)
Diese Meldung würde ich mal so interpretieren, das du von dem Server auf dem du arbeitest, ne ssh verbindung zu eben jenem aufbauen wolltest. Der sinn dahinter erschließt sich mir nicht ganz.


Daneben gibt es einen User ohne Namen mit 2 Einträgen: localhost und pluto.
Mir ist nicht bekannt, das man namenlose User in MySQL anlegen kann. Bitte prüfe das nochmal nach. *** Edit: Namenlose User sind schon möglich, so wird jeder Username akzeptiert, macht aber m.M. nach keinen Sinn und würde ich bei mir als Sicherheitsrisiko einstufen und schnellstens entsorgen. ***


Der User root hat je einen Eintag mit: 127.0.0.1, localhost und pluto (so heisst der Server).
Der User ispconfig hat nur einen Eintag mit localhost.
Diese Einträge sind korrekt, aber Hinweis: "feste externe IP (ich bei einem Kollegen)" überdenken, denn wenn du keine "software" bei deinem kollegen hast, die daten von dem Server abfragen können soll, dann unnötig - jedoch ist es auch kein Fehler und hat somit nichts mit deinem Problem zutun.


Welche Distribution setzt du denn ein und in welcher Version?
Welche MySQL Version setzt du ein?
Hast du schon mal versucht den Server neuzustarten, oder wenigstens den MySQL?
Hast du irgendwelche Passwörter geändert und es vergessen in den Konfigurationen einzutragen? Alternativ: Hast du versucht die Passwörter einmal neu zu setzen?
Hast du mal geschaut ob die benötigten Ports auch erreichbar sind? (nmap -sT IP-Adresse)

ISPConfig bedingt kann ich dir selbst wenig helfen, aber dein Problem scheint nicht am ISPConfig zu liegen, sondern irgendwo bei deinem System - und ich vermute stark beim mysql.

Vorsichtshalber würde ich auch rkhunter mal drüberlaufen lassen und schauen ob der was zu bemängeln hat und die iptables prüfen (iptables -L wenn ich mich nicht irre)

Grüße und schönen Feiertag
nwb
 
Zuletzt bearbeitet:
#5
Schönen guten Morgen nwb und alle ISPConf'ler

ich bin wirklich dankbar für die Hilfe, denn ich denke alleine komme ich nicht auf den grünen Zweig.
Dein SSH läuft nicht? Wie loggst du dich dann auf dem Server ein?
Gar nicht :-( -- Der Server läuft im run-level 3 und ich logge mich ein, werde root und starte bei Bedarf X. -- Also ssh ist ebenfalls gelaufen bis dieses "Theater" los ging.


Diese Meldung würde ich mal so interpretieren, das du von dem Server auf dem du arbeitest, ne ssh verbindung zu eben jenem aufbauen wolltest. Der sinn dahinter erschließt sich mir nicht ganz.
Ich meine mal gelesen zu haben, dass solche Meldungen im Logfile vom System generiert werden als Test ob der Dienst läuft. Doch die Meldung besagt doch, dass MySQL Anfrage(n) ablehnt?

Mir ist nicht bekannt, das man namenlose User in MySQL anlegen kann. Bitte prüfe das nochmal nach. *** Edit: Namenlose User sind schon möglich, so wird jeder Username akzeptiert, macht aber m.M. nach keinen Sinn und würde ich bei mir als Sicherheitsrisiko einstufen und schnellstens entsorgen. ***
Deine Einstellung passt mir, also schmeisse ich die Beiden raus.

Diese Einträge sind korrekt, aber Hinweis: "feste externe IP (ich bei einem Kollegen)" überdenken, denn wenn du keine "software" bei deinem kollegen hast, die daten von dem Server abfragen können soll, dann unnötig - jedoch ist es auch kein Fehler und hat somit nichts mit deinem Problem zutun.
Stimmt - kann ich auch raus werfen weil ich das Heute nicht mehr benötige.

Welche Distribution setzt du denn ein und in welcher Version?
openSUSE 11.2 Emerald Kernel 2.6.31.14-0.8-default
5.1.49-0.1.1 -- Yast zeigt bei einigen, dass etwas neuere Versionen erhältlich seien. Doch ein Update hab ich gestern abgebrochen weil Yast moserte wegen Abhängigkeiten, resp. das noch Anderes geändert werden müsse. Also hab ich mal die Finger davon gelassen.
Hast du schon mal versucht den Server neuzustarten, oder wenigstens den MySQL?
Ja, MySQL genauso wie auch das System. Keine Änderung .... leider.
Hast du irgendwelche Passwörter geändert und es vergessen in den Konfigurationen einzutragen?
Ganz klar Nein.
Alternativ: Hast du versucht die Passwörter einmal neu zu setzen?
Nein (könnte ich mal versuchen und schauen was dann passiert. Doch siehe bitte weiter unten.) Ich habe einen neuen ftp - User angelegt und getestet. Gleiches Ergebnis.
Hast du mal geschaut ob die benötigten Ports auch erreichbar sind? (nmap -sT IP-Adresse)
pluto (also der Server) steht hinter einer starken Firewall (IPCop), die Firewall leitet nur die benötigten Port an Pluto weiter. nmap -sT zeigt:
Code:
PORT      STATE SERVICE
21/tcp    open  ftp
22/tcp    open  ssh
25/tcp    open  smtp
53/tcp    open  domain
80/tcp    open  http
110/tcp   open  pop3
111/tcp   open  rpcbind
143/tcp   open  imap
631/tcp   open  ipp
783/tcp   open  spamassassin
993/tcp   open  imaps
995/tcp   open  pop3s
3306/tcp  open  mysql
5666/tcp  open  nrpe
8080/tcp  open  http-proxy
8081/tcp  open  blackice-icecap
10000/tcp open  snet-sensor-mgmt
10024/tcp open  unknown
10025/tcp open  unknown
ISPConfig bedingt kann ich dir selbst wenig helfen, aber dein Problem scheint nicht am ISPConfig zu liegen, sondern irgendwo bei deinem System - und ich vermute stark beim mysql.
Ich bedanke mich bei Dir herzlich für Deine Hilfe, Geduld und mitüberlegen bei der Fehlersuche/-lösung. Ich denke nicht, dass es ein ISPConfig - Fehler/Problem ist sondern tippe ebenfalls auf MySQL-

Vorsichtshalber würde ich auch rkhunter mal drüberlaufen lassen und schauen ob der was zu bemängeln hat
rkhunter läuft mit, findet keine rootkit's oder sowas.
und die iptables prüfen (iptables -L wenn ich mich nicht irre)der Befehl zeigt:
Code:
iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
fail2ban-sasl  tcp  --  anywhere             anywhere            tcp dpt:smtp 
fail2ban-BadBots  tcp  --  anywhere             anywhere            multiport dports http,https 
fail2ban-Named-tcp  tcp  --  anywhere             anywhere            multiport dports domain,domain 
fail2ban-Named-udp  udp  --  anywhere             anywhere            multiport dports domain,domain 

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain fail2ban-BadBots (1 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere            

Chain fail2ban-Named-tcp (1 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere            

Chain fail2ban-Named-udp (1 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere            

Chain fail2ban-ProFTPD (0 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere            

Chain fail2ban-SSH (0 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere            

Chain fail2ban-pure-ftp (0 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere            

Chain fail2ban-sasl (1 references)
target     prot opt source               destination         
RETURN     all  --  anywhere             anywhere
neben fail2ban ist auch denyhosts am arbeiten (meine Sicherheits - Paranoia).
Auch wenn ich die beiden Dienste herunterfahre und das File hosts.deny wegstelle: keine Änderung.

Ich wünsche allen einen schönen Feiertag .... unserer war am 1. August :)

Was mich echt erstaunt ist, dass MySQL alle Abfragen von Diensten wie ftp, ssh und Mail ablehnt, jedoch die Domain mit dem Zen-Cart - Shop läuft. Also die Shop-Software muss ja die Artikel-Daten (z.Z. >2'600) aus der Datenbank holen. Und dies funktioniert.

Beim hochfahren des Systems werden keine Fehlermeldungen angezeigt, also alle Dienste (inkl MySQL) werden gestartet.
Und doch denke ich, dass MySQL von Anfang an alle Anfragen ablehnt.

Im Log habe ich noch das gefunden:
Code:
Oct  2 17:18:55 pluto saslauthd[3270]: do_auth         : auth failure: [user=name@domain.ch] [service=smtp] [real
m=domain.ch] [mech=pam] [reason=PAM auth error]
Oct  2 17:18:56 pluto mysqld[19476]: refused connect from localhost
Oct  2 17:18:56 pluto saslauthd[3271]: pam_mysql - MySQL error (Lost connection to MySQL server at 'reading initial commu
nication packet', system error: 0)
Oct  2 17:18:56 pluto saslauthd[3271]: DEBUG: auth_pam: pam_authenticate failed: Authentication service cannot retrieve a
uthentication info
hilft das weiter auch wenn es um Mail geht? (Der Account hat letzte Woche noch funktioniert.)

Nochmals Danke für jede Hilfe.
ralf
 
#6
Nachtrag

Kann den vorigen Beitrag nicht ändern ... er wird zu lang.

Nachtrag:
Ich habe die beiden Namenlosen - User gelöscht und MySQL neu gestartet - keine Besserung. :( (Aber wohl was für die Sicherheit gemacht!)

Vieleicht hilft es weiter ... hier das Log von mysql:
tail -f mysqld.log
111003 06:18:48 mysqld_safe mysqld from pid file /var/run/mysql/mysqld.pid ended
111003 06:19:55 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
111003 6:19:55 [Warning] '--skip-locking' is deprecated and will be removed in a future release. Please use '--skip-external-locking' instead.
111003 6:19:56 [Note] Plugin 'ndbcluster' is disabled.
111003 6:19:56 [Note] Plugin 'FEDERATED' is disabled.
111003 6:20:00 InnoDB: Started; log sequence number 0 10990730
111003 6:20:01 [Note] Event Scheduler: Loaded 0 events
111003 6:20:01 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-log' socket: '/var/run/mysql/mysql.sock' port: 3306 SUSE MySQL RPM
111003 7:46:54 [Note] /usr/sbin/mysqld: Normal shutdown

111003 7:46:54 [Note] Event Scheduler: Purging the queue. 0 events
111003 7:46:55 InnoDB: Starting shutdown...
111003 7:46:58 InnoDB: Shutdown completed; log sequence number 0 10995692
111003 7:46:58 [Note] /usr/sbin/mysqld: Shutdown complete

111003 07:46:58 mysqld_safe mysqld from pid file /var/run/mysql/mysqld.pid ended
111003 07:47:04 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
111003 7:47:04 [Warning] '--skip-locking' is deprecated and will be removed in a future release. Please use '--skip-external-locking' instead.
111003 7:47:04 [Note] Plugin 'ndbcluster' is disabled.
111003 7:47:04 [Note] Plugin 'FEDERATED' is disabled.
111003 7:47:04 InnoDB: Started; log sequence number 0 10995692
111003 7:47:05 [Note] Event Scheduler: Loaded 0 events
111003 7:47:05 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-log' socket: '/var/run/mysql/mysql.sock' port: 3306 SUSE MySQL RPM
111003 8:52:11 [Note] /usr/sbin/mysqld: Normal shutdown

111003 8:52:11 [Note] Event Scheduler: Purging the queue. 0 events
111003 8:52:11 InnoDB: Starting shutdown...
111003 8:52:13 InnoDB: Shutdown completed; log sequence number 0 11023192
111003 8:52:13 [Note] /usr/sbin/mysqld: Shutdown complete

111003 08:52:13 mysqld_safe mysqld from pid file /var/run/mysql/mysqld.pid ended
111003 08:52:16 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
111003 8:52:16 [Warning] '--skip-locking' is deprecated and will be removed in a future release. Please use '--skip-external-locking' instead.
111003 8:52:16 [Note] Plugin 'ndbcluster' is disabled.
111003 8:52:16 [Note] Plugin 'FEDERATED' is disabled.
111003 8:52:16 InnoDB: Started; log sequence number 0 11023192
111003 8:52:16 [Note] Event Scheduler: Loaded 0 events
111003 8:52:16 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.49-log' socket: '/var/run/mysql/mysql.sock' port: 3306 SUSE MySQL RPM
Hat/kann das "skip-locking" den Fehler verursachen? Wohl kaum oder .... aber wo finde ich das? Im Start-Skript von mysql unter /etc/init.d nicht.
 

nowayback

Well-Known Member
#7
Moinsen ralf


so langsam aber sicher komm ich auch ans Ende... meine derzeit einzige Vermutung die ich noch hab, wäre das du deinen localhost Eintrag gelöscht hast. Bitte prüfe das mal nach (ifconfig)

Dann solltest du etwas ähnliches wie folgendes finden:
Code:
lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:128281 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128281 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:9801528 (9.3 MiB)  TX bytes:9801528 (9.3 MiB)
Falls nicht überprüfe deine interfaces - müssten bei Suse auch unter /etc/network/interfaces sein und dort dann prüfen ob folgende einträge vorhanden sind:
Code:
# The loopback network interface
auto lo
iface lo inet loopback
Prüfe bitte auch deine hosts.deny/hosts.allow ob localhost/127.0.0.1 erlaubt bzw. nicht verboten sind sowie pluto.

Kurz zur Begründung wie ich darauf komme:
Du hast ein Problem geschildert mit deiner Datenbank sowie FTP und E-Mail zugang. Die FTP und E-Mail Daten liegen in der Datenbank, deswegen gehe ich davon aus, dass diese Dienste wieder funktionieren werden, wenn die Datenbank läuft.

- An dieser Stelle behalten wir im Hinterkopf das dein Shop funktioniert -

Dann war auch dein SSH betroffen und scheinbar nicht erreichbar. Die benötigten Ports für SSH und MySQL sind aber offen und auf Listen.

- An dieser Stelle behalten wir im Hinterkopf das du per Shell an die Datenbank kommst -

Nun schauen wir uns die Logfiles, die du gepostet hast, nochmal genauer an:
Oct 1 07:53:28 pluto mysqld[15173]: refused connect from localhost
Oct 2 07:02:58 pluto sshd[28518]: refused connect from localhost (127.0.0.1)
Nun kommen wir zu den Sachen die wir im Hinterkopf behalten haben. Ist es möglich das der Shop die Datenbankverbindung nicht zum localhost aufbaut, sondern zum fqdn oder zur IP Adresse? Wenn ja, würde es erklären warum der Shop funktioniert.
Ähnlich verhält es sich mit der Shell MySQL Verbindung, denn diese nutzt, wenn ich mich recht erinnere, den hostnamen (in deinem Fall "pluto").

Sollte es das nun auch nicht sein, dann bin ich, wie oben geschrieben, auch langsam am Ende meines Wissens angekommen.

*** Edit ***
Hat/kann das "skip-locking" den Fehler verursachen? Wohl kaum oder .... aber wo finde ich das? Im Start-Skript von mysql unter /etc/init.d nicht.
Nein das sollte ncihts mit deinem Fehler zutun haben. Du kannst es aber beheben indem du die my.cnf editierst (vi /etc/mysql/my.cnf - evtl. anderer Pfad bei dir) und im Bereich [mysqld] den Eintrag skip-locking änderst in skip-external-logging
Dann noch speichern und dann MySQL neustarten und der Fehler sollte weg sein.
**********
Grüsse
nwb
 
Zuletzt bearbeitet:
#8
Gelöst: Lost connection to MySQL server at 'reading initial communication packet'

Guten Morgen nwb und alle anderen auch

am Ende (mit meinem Latein) war ich schon und nun sind wir es! Meinen herzlichsten Dank an Dich!!

Als ich Deinen Beitrag gelesen habe, ist es mir förmlich in die Augen gesprungen:
Nun schauen wir uns die Logfiles, die du gepostet hast, nochmal genauer an:
localhost ... das war es!

Erklärung (sollte das noch mal jemandem passieren):
Zum Schutz des Servers läuft fail2ban und denyhosts mit. denyhosts habe ich so eingestellt, dass es sich mit dem 'Heimat-Server' austauscht (wer Andere angreift hat bei mir (auch) nichts zu suchen).
dnyhosts sendet mir jeweils eine Mail welche IP gebannt wurde. Nur nicht am vergangenen Samstagmorgen als 2 IP gebannt wurden (Mail läuft dann auch nicht mehr) wovon die eine 127.0.0.1 also localhost war.
Auch wenn denyhosts gestoppt wird, sind die IP's gebannt!
Gebannte IP entfernen:

  1. denyhosts stoppen mit:
    Code:
    /etc/init.d/denyhosts stop
  2. IP aus /etc/hosts.deny entfernen.
    Code:
    vi /etc/hosts.deny
  3. IP aus den anderen Files von denyhots entfernen:
    Code:
    sed -i.old /aaa.bbb.ccc.ddd/d /var/lib/denyhosts/*
    aaa.bbb.ccc.ddd durch die zu löschende IP ersetzen.
  4. denyhosts starten mit:
    Code:
    /etc/init.d/denyhosts start
Und FREUDE haben.

@nwb ganz vielen Dank für Deine Überlegungen und tatkräftige Hilfe, Du glaubst nicht was für ein Stein mir vom Herzen gefallen ist!! Eigentlich sollten wir mal zum Bier. :)

Und das mit dem skip-locking mach ich auch noch .... aber erst noch ein wenig die Freude geniessen.

Viele Grüsse aus der Schweiz
ralf
 
#10
Hallo - Halli
freut mich für dich, das du so nun deine Probleme beheben konntest.
Und wie es mich freut, dass das Ganze wieder Rund läuft!!! - Die Bauarbeiter sind noch beschäftigt mit "Loch im Boden flicken". :) :)

Und genau das ist der springende Punkt weshalb ich Foren so mag. Geben und nehmen .... aber ein grooooooooooooooooosses Bier hast Du alle Weile zu gute.
Ich hoffe sehr, ich kann Dir auch mal einen grossen Stein in den Garten werfen. Wie auch immer.

Viele Grüsse
ralf
 

Werbung