mysql update failed

#1
Hi!
Ich habe mal wieder ein Problem.
Seit dem Wochenende gibts ja das große Update auf debian 5.0.4
Pflichtbewusst habe ich selbiges natürlich aufgespielt.
Nur brach die Installation des neuen mysql (5.0.51a-24+lenny2+spu1) leider ab.
Er konfiguriert sich nen heissen, dann stoppt er den dienst und beim starten gibt er mir dann in einem sagenhaften rot ein "failed" aus.

Was kann das sein, wie kann ich das ändern?

Grüße
Laubie

Ach ja: in der var/log/mysql mysql.err mysql.log steht nix.
In der SSH verbindung lese ich dann:
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
^Cdpkg: Fehler beim Bearbeiten von mysql-server-5.0 (--configure):
Unterprozess post-installation script mit Signal (Unterbrechung) getötet
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mysql-server:
mysql-server hängt ab von mysql-server-5.0; aber:
Paket mysql-server-5.0 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von mysql-server (--configure):
Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
mysql-server-5.0
mysql-server
 
Zuletzt bearbeitet:

Till

Administrator
#2
Bei mir lief das Update problemlos durch. hast Du vielleicht noch andere repositories neben den debian Standard repos in der sources.list? Z.B. welche von dotdeb?
 
#3
ne, nix dergleichen.
Nur die standard von security.debian.org

Aber mir ist grad aufgefallen - wollte ein Test-tool installieren, dass apt mich nicht lässt.

Code:
E: Konnte Lock /var/lib/dpkg/lock nicht bekommen - open (11 Die Ressource ist zur Zeit nicht verfügbar)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
 
#4
sehr komisch.
Jetzt kommt der lock-Fehler nicht mehr. Habe mir in der shell neu root-Rechte geholt...

Vielleicht läuft nu ja auch das Update. Werde es gleich noch mal probieren, wenn nicht grad so viele User auf die Seite zugreifen.
Da ist ein Datenbankausfall immer gemein ;)

Grüße
Laubie
 

Till

Administrator
#5
Wenn es nicht geht, könntest Du versuchen es mit dem Parameter -f die Installation trotz Abhängigkeitsproblemen zu erzwingen.
 
#6
Wenn es nicht geht, könntest Du versuchen es mit dem Parameter -f die Installation trotz Abhängigkeitsproblemen zu erzwingen.
hmm... meinst du das Problem oben ist ein Abhängigkeitsproblem?
sicher wird er dann das paket mysql-server installieren, aber das ändert ja nichts daran, dass dann immer noch mysql-server-5.0 noch fehlt :(

würde ein Neustart wohl was bringen?

Grüße
Laubie
 

Till

Administrator
#7
Ist ein Abhängigkeitsproblem, steht ja in der einen Fehlermeldung, die Du gepostet hast. Mit neu starten hat das nicht szu tun, da apt kein daemon ist.

Versuch doch mal ein:

aptitude -s dist-upgrade

das simuliert nur ein update durch aptitude und ändert erstmal nichts. was schlägt Dir aptitude da als Problemlösung vor?
 
#8
Ist ein Abhängigkeitsproblem, steht ja in der einen Fehlermeldung, die Du gepostet hast. Mit neu starten hat das nicht szu tun, da apt kein daemon ist.

Versuch doch mal ein:

aptitude -s dist-upgrade

das simuliert nur ein update durch aptitude und ändert erstmal nichts. was schlägt Dir aptitude da als Problemlösung vor?
ich hatte es so verstanden, dass er das zweite mysql-Paket nicht installiert, da ihm das erste fehlt.

Ich probiere grad mal deinen Vorschlag... melde dann gleich das Ergebnis ;)

sooo:
Code:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Lese erweiterte Statusinformationen
Initialisiere Paketstatus... Fertig
Die folgenden teilweise installierten Pakete werden konfiguriert:
  mysql-server mysql-server-5.0
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 0B an Archiven herunterladen. Nach dem Entpacken werden 0B zusätzlich belegt sein.
Würde Pakete herunterladen/installieren/entfernen.
 
#9
Ich hab das Rätsel gelöst :)
Ich habe einfach mal aus allen entsprechenden verzeichnissen die lock-Dateien gelöscht und dann noch mal neu ein aptitude upgrade gestartet.

Diesmal rannte er durch.

Danke für die Hilfe.

Laubie
 

Werbung

Top