Mysqli Problem

#1
Hallo zusammen,

ich habe ein Problem mit meinem Webserver, den ich mit ISPConfig verwalte.
Der Server ist nach dem "Perfekten Installationstutorial" für Squeezy aufgesetzt.

Ich möchte nun gerne die MySQLi Function "store_result" benutzen. Das funktioniert auf dem aktuellen Server leider nicht. Ich habe auch schon den Grund hierfür gefunden: mysqli - PHP mysqli_stmt::get_result() is undefined method - Stack Overflow

Der Lösungsvorschlag hier ist einen neuen Apache2-Build zu machen mittels EasyApache. Ich frage mich nur ob das auch das Mittel der Wahl bezüglich ISPConfig ist.

Für einen Rat wäre ich sehr dankbar. Habe schon das halbe Internet durchforstet. Falls es dazu schon einen Thread gibt, dann habe ich das übersehen und bitte das bereits jetzt zu entschuldigen.

Danke im Vorraus!
 

Till

Administrator
#2
Der Lösungsvorschlag hier ist einen neuen Apache2-Build zu machen mittels EasyApache. Ich frage mich nur ob das auch das Mittel der Wahl bezüglich ISPConfig ist.
das würde ich auf keinen fall machen.

Wenn Du einen speziellen php Buld brauchst, dann installiere einfach ein Zusatz PHP mit den entsprechenden compile options, nicht umsonst untertsützt ISPConfig mehrere parallele PHP Versionen.

How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (Debian Wheezy) | HowtoForge - Linux Howtos and Tutorials

anleitung ist für Wheezy, sollte aber auch für squeeze gehen. Du musst halt die speziell benötigte Compile Option beim configure mit angeben.
 
#3
Okay, Danke soweit schon einmal.

Ich sehe jetzt gerade, dass ab PHP Version 5.4 mysqlnd standartmäßig aktiviert ist (PHP: Installation - Manual).

Kann ich nicht irgendwie den gesamten Server auf PHP 5.4 updaten, ich brauche eigentlich kein PHP 5.3.

apt-get und aptitude zeigen mir keine Updates.

Lohnt es allgemein auf Wheezy umzusteigen?
 
#5
Also langsam schnalle ich es nicht mehr.

Update auf Wheezy gemacht, läuft auch alles super.

PHP Version ist jetzt: 5.4.4-14+deb7u12

Aber der mysqli native driver (mysqlnd) ist dennoch nicht installiert....


Ich werde mal eine weitere PHP Version installieren und Update hier dann entsprechend, falls noch jemand das Problem haben sollte.

Gruß

//EDIT:

Die Lösung war doch einfach, einfach das Paket php5-mysqlnd installieren:

"apt-get install php5-mysqlnd" und alles funktioniert.


Danke für die Hilfe!
 
Zuletzt bearbeitet:
#6
Die Lösung war doch einfach, einfach das Paket php5-mysqlnd installieren: "apt-get install php5-mysqlnd" und alles funktioniert.
Eine Webanwendung bemängel "Function mysqli_fetch_all is not available". Bei der erforderlichen Installation des Pakets php5-mysqlnd wird aber php5-mysql automatisch vom System entfernt.

Gibt es hierbei ein Problem mit ISPConfig? (Installiert nach dem Perfect-Server Tutorial für Debian Wheezy Apache2, Multiserver)
 

Werbung