Nach aktivierung von SSL, Phpmyadmin wird zum Download angeboten

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Deex, 2. Okt. 2014.

  1. Deex

    Deex Member

    Ich hatte vorhin SSL für eine Seite Aktiviert, das resultat ist das ich jetzt Phpmyadmin nicht mehr aufrufen kann, er wird mir nun zum Download angeboten mit dem Hinweis
    Application/x-httpd-php

    Okay also habe ich gedacht hmm da wird wohl etwas die Konfiguration verschossen haben und habe mir diese angesehen
    Code:
    # phpMyAdmin default Apache configuration
    
    Alias /teamdb135 /usr/share/phpmyadmin
    
    <Directory /usr/share/phpmyadmin>
        Options FollowSymLinks
        DirectoryIndex index.php
    
        <IfModule mod_php5.c>
            AddType application/x-httpd-php .php .php3 .php4
            AddType application/x-httpd-php-source .phps
            php_flag magic_quotes_gpc Off
            php_flag track_vars On
            php_flag register_globals Off
            php_value include_path .
        </IfModule>
    
    </Directory>
    
    # Authorize for setup
    <Directory /usr/share/phpmyadmin/setup>
        <IfModule mod_authn_file.c>
        AuthType Basic
        AuthName "phpMyAdmin Setup"
        AuthUserFile /etc/phpmyadmin/htpasswd.setup
        </IfModule>
        Require valid-user
    </Directory>
    
    # Disallow web access to directories that don't need it
    <Directory /usr/share/phpmyadmin/libraries>
        Order Deny,Allow
        Deny from All
    </Directory>
    <Directory /usr/share/phpmyadmin/setup/lib>
        Order Deny,Allow
        Deny from All
    </Directory>
    
    
    Dann nochmal hier und dort den Addtype geändert, machte keinen unterschied er will es einfach nicht als php ausführen. Was kann das schief gelaufen sein? Heute morgen funktionierte das ganze noch >.<

    Update: Ich bin der spur näher gekommen, es scheint mit SPDY und SSL zu tun zu haben. Wenn ich keinen Reroute mit SSL mache kann ich es aufrufen.

    Oder kurz gesagt, es wird als PHP ausgeführt auf allen Seiten die keine SSL unterstützung haben.
    Sollte SSL für eine Seite aktiv sein so wird mir es als Download angeboten Oo mist..war ja klar das mir das jetzt auch noch passieren muss...
     
    Zuletzt bearbeitet: 2. Okt. 2014
  2. Deex

    Deex Member

    Kleines Update dazu,
    das problem tritt auf sowie ich über ISPConfig SSL aktiviere und ein Zertifikat hinzufüge auch wenn die anfrage über HTTP läuft.
    Was kann ich denn da machen <.<
     
  3. Till

    Till Administrator

    Iste denn mod_php in Deinem apache aktiviert? das wird von phpmyadmin benötigt.
     
  4. Deex

    Deex Member

    Hallo Till,

    Bin grade etwas verwundert,- normal sollte alles laufen, für die Seite ist FastCGI aktiviert, erst nach der aktivierung von SSL wird es mir als Download angeboten *kopfkratz*
    Über ISPConfig kann ich auf Mod_php umstellen, änderte auch nichts. Vor SSL Aktivierung funktionierte es wunderbar, danach nicht mehr auf jeder seite die SSL verwendet.

    Das hier sind die laufenden Module.

    Loaded Modules:
    core_module (static)
    log_config_module (static)
    logio_module (static)
    version_module (static)
    mpm_prefork_module (static)
    http_module (static)
    so_module (static)
    actions_module (shared)
    alias_module (shared)
    auth_basic_module (shared)
    auth_digest_module (shared)
    authn_file_module (shared)
    authz_default_module (shared)
    authz_groupfile_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    autoindex_module (shared)
    cache_module (shared)
    cgi_module (shared)
    cloudflare_module (shared)
    dav_module (shared)
    dav_fs_module (shared)
    deflate_module (shared)
    dir_module (shared)
    env_module (shared)
    fcgid_module (shared)
    headers_module (shared)
    include_module (shared)
    mime_module (shared)
    negotiation_module (shared)
    pagespeed_module (shared)
    perl_module (shared)
    php5_module (shared)
    python_module (shared)
    reqtimeout_module (shared)
    rewrite_module (shared)
    ruby_module (shared)
    setenvif_module (shared)
    spdy_module (shared)
    ssl_module (shared)
    status_module (shared)
    suexec_module (shared)
    suphp_module (shared)
    unique_id_module (shared)
    Syntax OK
     
    Zuletzt bearbeitet: 7. Okt. 2014
  5. Till

    Till Administrator

    Was in der Webseite verwendet wird spielt keine Rolle. Denn Du hast ja für phpmyadmin in der phpmyadmin.conf definiert dass es immer mit mod_php läuft.
     
  6. Deex

    Deex Member

    Das Modul müsste verfügbar sein, mir wurde ausgegeben.
    libapache2-mod-php5 ist schon die neueste Version
    Aktiviert ist es auch (Module php5 already enabled). Ich hab keine ahnung wie viele versionen ich mittlerweile dieser Config hatte aber wenn es über mod php läuft und ssl aktiv ist auf der domäne von der ich es aufrufen will gibt es immer einen Download.


    Was ich probierte war die config umzuschreiben auf fast CGI, was mir allerdings nun einen Internen Serverfehler einbringt beim aufrufen..

    Config 1 - Standard
    Code:
    Alias /teamdb135 /usr/share/phpmyadmin
    
    <Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php
    
    
    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
    </IfModule>
    
    </Directory>
    # Authorize for setup
    <Directory /usr/share/phpmyadmin/setup>
        <IfModule mod_authn_file.c>
        AuthType Basic
        AuthName "phpMyAdmin Setup"
        AuthUserFile /etc/phpmyadmin/htpasswd.setup
        </IfModule>
        Require valid-user
    </Directory>
    
    # Disallow web access to directories that don't need it
    <Directory /usr/share/phpmyadmin/libraries>
        Order Deny,Allow
        Deny from All
    </Directory>
    <Directory /usr/share/phpmyadmin/setup/lib>
        Order Deny,Allow
        Deny from All
    </Directory>
    
    Config 2 - Fast CGI
    Code:
    # phpMyAdmin default Apache configuration
    
    Alias /teamdb135 /usr/share/phpmyadmin
    
    <Directory /usr/share/phpmyadmin>
      Options FollowSymLinks
      DirectoryIndex index.php
    
    
      AddType application/x-httpd-php .php .php3 .php4
      AddType application/x-httpd-php-source .phps
      php_flag magic_quotes_gpc Off
      php_flag track_vars On
      php_flag register_globals Off
      php_value include_path .
    
    
    </Directory>
    
    # Authorize for setup
    <Directory /usr/share/phpmyadmin/setup>
      <IfModule mod_authn_file.c>
      AuthType Basic
      AuthName "phpMyAdmin Setup"
      AuthUserFile /etc/phpmyadmin/htpasswd.setup
      </IfModule>
      Require valid-user
    </Directory>
    
    # Disallow web access to directories that don't need it
    <Directory /usr/share/phpmyadmin/libraries>
      Order Deny,Allow
      Deny from All
    </Directory>
    <Directory /usr/share/phpmyadmin/setup/lib>
      Order Deny,Allow
      Deny from All
    </Directory>
    
    
      <Directory /usr/share/phpmyadmin>
      # Clear PHP settings of this website
      <FilesMatch ".+\.ph(p[345]?|t|tml)$">
      SetHandler None
      </FilesMatch>
      Options +FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
      </Directory>
    
    
      # php as fast-cgi enabled
      # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
      <IfModule mod_fcgid.c>
      FcgidIdleTimeout 300
      FcgidProcessLifeTime 3600
      # FcgidMaxProcesses 1000
      FcgidMaxRequestsPerProcess 5000
      FcgidMinProcessesPerClass 0
      FcgidMaxProcessesPerClass 10
      FcgidConnectTimeout 3
      FcgidIOTimeout 600
      FcgidBusyTimeout 3600
      FcgidMaxRequestLen 1073741824
      </IfModule>
    
    
      <Directory /usr/share/phpmyadmin>
      <FilesMatch "\.php[345]?$">
      SetHandler fcgid-script
      </FilesMatch>
      FCGIWrapper /var/www/php-fcgi-scripts/phpmyadmin/.php-fcgi-starter .php
      FCGIWrapper /var/www/php-fcgi-scripts/phpmyadmin/.php-fcgi-starter .php3
      FCGIWrapper /var/www/php-fcgi-scripts/phpmyadmin/.php-fcgi-starter .php4
      FCGIWrapper /var/www/php-fcgi-scripts/phpmyadmin/.php-fcgi-starter .php5
      Options +ExecCGI
      AllowOverride All
      Order allow,deny
      Allow from all
      </Directory>
    
    Config 3
    Code:
    # phpMyAdmin default Apache configuration
    
    Alias /teamdb135 /usr/share/phpmyadmin
    
    <Directory /usr/share/phpmyadmin>
        Options FollowSymLinks
        DirectoryIndex index.php
    
    
            AddType application/x-httpd-php .php .php3 .php4
            AddType application/x-httpd-php-source .phps
            php_flag magic_quotes_gpc Off
            php_flag track_vars On
            php_flag register_globals Off
            php_value include_path .
    
    
    </Directory>
    
    # Authorize for setup
    <Directory /usr/share/phpmyadmin/setup>
        <IfModule mod_authn_file.c>
        AuthType Basic
        AuthName "phpMyAdmin Setup"
        AuthUserFile /etc/phpmyadmin/htpasswd.setup
        </IfModule>
        Require valid-user
    </Directory>
    
    # Disallow web access to directories that don't need it
    <Directory /usr/share/phpmyadmin/libraries>
        Order Deny,Allow
        Deny from All
    </Directory>
    <Directory /usr/share/phpmyadmin/setup/lib>
        Order Deny,Allow
        Deny from All
    </Directory>
    Config 4

    Code:
    <Directory /usr/share/phpmyadmin>
            Options FollowSymLinks
            DirectoryIndex index.php
            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_admin_flag allow_url_fopen Off
                    php_value include_path .
                    php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
                    php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/php$
            </IfModule>
    </Directory>
     
    Zuletzt bearbeitet: 7. Okt. 2014
  7. Deex

    Deex Member

    Keiner einen Ansatzpunkt? Ich bekomme den Ursprung des problems nicht auf die Spur.
     
  8. Till

    Till Administrator

    füge mal ein vor der ezile:

    <IfModule mod_php5.c>
    und vor
    </IfModule>
    ein und starte apache neu. mal sehen ob Du einen Fehler bekommst dass mod_php nicht geladen ist.
     
  9. wotan2005

    wotan2005 Member

    zeig mal deine /etc/apache2/conf.d/phpmyadmin.conf
     
  10. Deex

    Deex Member

    Das setzen von if module php5 ist drinne, es ändert leider nichts da drann, es ist immer noch ein Download unter aktiviertem ssl (Auch wenn der request http ist).

    Hi, momentan ist das hier meine Configuraiton

    Code:
    # phpMyAdmin default Apache configuration
    
    Alias /teamdb135 /usr/share/phpmyadmin
    SpdyEnabled off
    ModPagespeed off
    
    <Directory /usr/share/phpmyadmin>
            Options FollowSymLinks
            DirectoryIndex index.php
    
            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    php_admin_flag allow_url_fopen Off
                    php_value include_path .
                    php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
                    php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/php$
            </IfModule>
    </Directory>
    
    # Authorize for setup
    <Directory /usr/share/phpmyadmin/setup>
        <IfModule mod_authn_file.c>
        AuthType Basic
        AuthName "phpMyAdmin Setup"
        AuthUserFile /etc/phpmyadmin/htpasswd.setup
        </IfModule>
        Require valid-user
    </Directory>
    
    # Disallow web access to directories that don't need it
    <Directory /usr/share/phpmyadmin/libraries>
        Order Deny,Allow
        Deny from All
    </Directory>
    <Directory /usr/share/phpmyadmin/setup/lib>
        Order Deny,Allow
        Deny from All
    </Directory>
    
     
  11. wotan2005

    wotan2005 Member

    hast du die Änderung an der suphp.conf laut Howto gemacht?
     
  12. Deex

    Deex Member

    Welche meinst du?

    Derzeit sieht diese so aus

    Code:
    <IfModule mod_suphp.c>
      <FilesMatch "\.ph(p3?|tml)$">
      SetHandler application/x-httpd-suphp
      </FilesMatch>
       suPHP_AddHandler application/x-httpd-suphp
      <Directory />
      suPHP_Engine on
      </Directory>
      # By default, disable suPHP for debian packaged web applications as files
      # are owned by root and cannot be executed by suPHP because of min_uid.
      <Directory /usr/share>
      suPHP_Engine off
      </Directory>
    # # Use a specific php config file (a dir which contains a php.ini file)
    #   suPHP_ConfigPath /etc/php5/cgi/suphp/
    # # Tells mod_suphp NOT to handle requests with the type <mime-type>.
    #   suPHP_RemoveHandler <mime-type>
    </IfModule>
    
     
  13. wotan2005

    wotan2005 Member

    Code:
    <IfModule mod_suphp.c>
      #<FilesMatch "\.ph(p3?|tml)$">
      #  SetHandler application/x-httpd-suphp
      #</FilesMatch>
      AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
      suPHP_AddHandler application/x-httpd-suphp
    
      <Directory />
      suPHP_Engine on
      </Directory>
    
      # By default, disable suPHP for debian packaged web applications as files
      # are owned by root and cannot be executed by suPHP because of min_uid.
      <Directory /usr/share>
      suPHP_Engine off
      </Directory>
    
      # # Use a specific php config file (a dir which contains a php.ini file)
      #  suPHP_ConfigPath /etc/php5/cgi/suphp/
      # # Tells mod_suphp NOT to handle requests with the type <mime-type>.
      #  suPHP_RemoveHandler <mime-type>
    
    
    Und so sollte Sie aussehen.
     
  14. nowayback

    nowayback Well-Known Member

    fehlt doch nicht viel ;)
     
  15. Deex

    Deex Member

    Ohne witz.. das war der Fehler Oo,
    vielen vielen Dank das habe ich nicht gesehen.
    Aber wie kann das sein? Ich habe dort nichts geändert, habe ich damals bei der einrichtung irgend etwas vergessen und das war Nie dort drinne und der Fehler ist nie aufgefallen? Normal kann sich eine Config ja nicht selbst verändern.. es ging alles bisher nur bei der Aktivierung von SSL machte auf einmal phpmyadmin probleme. Ich verstehe das noch nicht..

    Tausend dank tausend dank es geht wieder *hurra*
     
  16. nowayback

    nowayback Well-Known Member

    es gibt perfect server tutorials auf howtoforge.de und howtoforge.com. wenn man sich daran hält sollte das eig. nicht passieren.
     
  17. Deex

    Deex Member

    Ich weiß das es die Tutorials gibt ich habe vieles darauf baisierend. In der IT kann immer etwas passieren! Der Fehler steckt meistens im Detail.
     
  18. nowayback

    nowayback Well-Known Member

    Naja aber nix passiert im IT Bereich einfach so von alleine... es gibt immer jemanden vor dem Bildschirm der die Anweisung in irgendeiner Art und Weise gegeben hat.
    In deinem Fall wäre es interessant rauszufinden, wie es passieren konnte, dass solch essentielle Teile in einer Config fehlen.
     
  19. Muellerman

    Muellerman New Member

    Vielen Dank ans Forum. Nach über 20 Stunden Internetsuche bin ich hier auf die Lösung gestoßen. Ich möchte hier dennoch gern einige Erkenntnisse loswerden die vielleicht im Zusammenhang damit stehen das die index.php Datei heruntergeladen und phpmyadmin nicht ausgefühert wird. Ich betreibe seit einigen Jahren einen Web- und einen Mailserver mit jetzt aktuellen Stand ISPConfig 3.0.5.4p3. Ich bin erst vor ein paar Monaten beim Webserver von Debian 6 zu Debian 7 umgestiegen. Ein Test ob phpmyadmin ging war "erfolgreich". Dann hatte ich für einen Kunden ein erstes Zertifikat über ISPConfig eingebunden. Wochen nach der Einbindung habe ich gemerkt das phpmyadmin nicht mehr korrekt auf allen vhost funktioniert. Bei mir liefen die vhosts mit phpmyadmin bei denen in der vhost-Konfiguration die "#Clear PHP settings of this" nicht in der "<Directory /var/www/domain.de/web"> Einstellungen standen. Wahrscheinlich löscht dies die php Handler für die Ausführung von phpmyadmin.
     

Diese Seite empfehlen