Nach anlegen einer Website Server nicht mehr erreichbar

Dieses Thema im Forum "Allgemein" wurde erstellt von Germanius, 5. Jan. 2011.

  1. Germanius

    Germanius New Member

    Ich musste nun zweimal feststellen, dass die Internetseiten vom betreffenden Server nicht mehr erreichbar waren, nachdem ich eine Website angelegt habe. Das passiert nicht jedes Mal, aber zweimal ist es schon passiert.
    Momentan nutze ich Ispconfig 3.0.3.

    Jemand eine Idee woran das liegen könnte?

    Wo kann ich ansetzen um rauszufinden, was es war? Welche Logs, wo einsehen?
     
  2. Moestchen

    Moestchen New Member

    Wie hast du diese Webseite denn angelegt, stimmen die DNS-Einträge überein?
    Verwaltest du mehrere IPs und hast der Webseite die korrekte IP zugewiesen?
    Was sagt das error-Log der Webseite? Was genau heißt "nicht erreichbar", welche Fehlermeldung erscheint.

    Wenn die Domain nicht geheim ist könntest du uns den entsprechenden Namen zur Fehlerkontrolle auch mitteilen?
     
  3. Germanius

    Germanius New Member

    Mit den DNS-Einträgen hat es nichts zu tun.

    Es sind nach der Erstellung einer Website über den admin Account ALLE Domains auf dem Server nicht mehr erreichbar, inkl. Ispconfig. Es scheint so, als hätte sich der Apache komplett aufgehängt.
    Erst nach einem Restart der VM lief alles wieder so wie vorher.
     
  4. Moestchen

    Moestchen New Member

    War dann vielleicht einfach die Jobqueue von ISP noch nicht vollständig abgearbeitet?
    Aber dann muss ja zumindest im syslog ein Eintrag der Ursache auftreten? Das würde mich sehr interessieren.
     
  5. Germanius

    Germanius New Member

    In welchem Log soll ich genau schauen?

    Im /var/log/apache2/error.log steht zu dem Zeitpunkt nichts brauchbares drin.
     
  6. Moestchen

    Moestchen New Member

    Das error-Log für die einzelnen Webseiten liegt unter '/var/log/ispconfig/httpd/DEINEDOMAIN' .
     
  7. Moestchen

    Moestchen New Member

    Noch eine andere Sache die mir einfällt, deine VM hat aber genug Ressourcen?
    Kontrolliere doch mal die Ausgabe der User_beancounter, ob der failcnt überall auf 0 steht, oder Handlungs-/Anpassungsbedarf besteht.
     
  8. Till

    Till Administrator

    Hast Du in ispconfig unter system > server config > web die option "test apache config on restart" aktiviert?
     
  9. Germanius

    Germanius New Member

    Ja, dort ist ein Häckchen. Hab ich aber nicht gesetzt, scheint standardmäßig gesetzt zu sein.
    Ich sehe gerade, dass bei der betreffenden Website auch ein 403 Forbidden Fehler angezeigt wird, wenn ich versuche die Seite aufzurufen.
     
  10. Germanius

    Germanius New Member

    Habe die Website nochmal gelöscht und neu angelegt, aber geht immer noch nicht. Immer ein 403 Forbidden. Was tun?
    Im Errorlog der Website:
    [Wed Jan 05 18:18:34 2011] [crit] [client xx.xx.xx.xx] (13)Permission denied: /var/www/clients/client46/web97/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    Aber welche .htaccess? Es existiert gar keine.
     
    Zuletzt bearbeitet: 5. Jan. 2011
  11. Germanius

    Germanius New Member

    Sieht so aus als wenn der "web" Ordner falsche Rechte hätte. Normalerweise gehört der doch nicht root oder?

    Hab gerad versucht über die Shell die Rechte zu ändern, kommt aber die Fehlermeldung:
    changing ownership of `index.html': Disk quota exceeded

    Und nun hab ich mal nach dem Quota geschaut:
    Was ist da los?
     
    Zuletzt bearbeitet: 5. Jan. 2011
  12. Moestchen

    Moestchen New Member

    Genau, außer dem Ordner 'stats' gehören die Sachen dem User 'webXY' und der Gruppe 'clientYZ'.
     
  13. Till

    Till Administrator

    Was ist bei Dir unter System > Server config > web > security level ausgewählt?
     
  14. Germanius

    Germanius New Member

    High, so wie es auch sein sollte.

    Ich hab in der VM das quotaugidlimit hochgesetzt. Ich glaube das war vorher nur auf 100. Kann das die Abstürze erklären? Zumindest scheints im Moment zu laufen.
     
  15. Till

    Till Administrator

    Das kann schon sein, wenn der apache oder ein anderer Dienst z.b. nicht mehr in sein log schreiben kann oder aber er seine .lock dateien nicht setzen kann, dann stürzt er ab bzw. startet nicht mehr.
     
  16. Germanius

    Germanius New Member

    Das Problem besteht scheinbar immer noch. Inzwischen habe ich wieder einige Seiten angelegt, ohne Probleme, zumindest bis eben. Wieder eine angelegt, alles gut soweit, doch dann wieder der Absturz.

    Kann ich irgendwie rausfinden was genau das verursacht?
     
  17. Till

    Till Administrator

    Schau mal ins globale apache error.log und ins syslog. Ist das ein virtueller Server? wenn ja, dann schau Dir die /proc/user_beancounters an, ob da irgend ein Limit überschritten wurde.
     

Diese Seite empfehlen