Nach apt-get upgrade und sendmail scheint kein Emailversand mehr zu gehen

#1
Auf meinem Debian habe ich in alter Routine ein Update des Systems angestoßen.

Dabei wurde ich gefragt, ob ich auch sendmail mit aktualisieren möchte.

Ich dachte mir zuerst, geht ja mal gar nicht, da ISPConfig ja mit Postfix alles erledigt, aber sendmail ist ja letzten Endes auch im Postfix-Paket dabei...

So dachte ich...

Seit dem Update geht leider kein Emailversand mehr raus.

Any clues, wie ich das wieder strammziehen kann?
 
#3
Die aktuellste 2er.

Doof is, daß in keinem Logfile was drin steht...

Normalerweise sollte es ja nicht gehen, postfix und sendmail simultan installiert zu haben.
Ich habe mittlerweile festgestellt, daß ich Postfix über init.d stop und wieder start zum Laufen bewegen kann, und er auch artig alle Settings frißt, die ISPConfig in die Dateien schreibt...

Wie heißt es so schön bei MS:
Neuinstallation könnte das Problem beheben :eek:
 

Till

Administrator
#4
Führe am besten nochmal alle schritte des email kapitels des perfect server guide für die von Dir verwendete debian / ubuntu Version aus. Das sollte das Problem beheben.

Wichtig ist, überprüf vorher, welche Debian Version Du hast. Es lief vor ein paar tagen der Support für Debian 4 aus, vielleicht hast Du asu Versehen auf debian 5 upgedatet. Das würde die Probleme erklären und Du müsstest dann nach dem perfect setup für debian 5 vorgehen.
 
#5
Hi Till,

nee, keine Sorge, aus Versehen würde ich da nicht upgraden, eher aus Wollen.
(war aber nicht der Fall ;) )

Irgendeine Library hat eine sendmail-Abhängigkeit gehabt, welches dann wohl Sendmail pseudomäßig mitinstalliert hat...?
Ich frage mich allerdings, wie das passieren konnte, denn mein apt ist sonst SEHR zuverlässig, was Abhängigkeitsauflösungen angeht...:D

Anyway, Server lüppt nu wieder, und Mails schnurren auch...
Jetzt heißts erst ma mit dpkg alle Päckchen auslesen, und gucken, wo denn der Sendmail-Mist passiert ist...
 

Werbung