Nach Installation Probleme mit anderen Scripts

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von SilverXX, 17. Jan. 2012.

  1. SilverXX

    SilverXX Member

    Hallo,

    ich habe noch nicht so lange ISPConfig aber bin bis jetzt recht zufrieden...
    Ein Script habe ich schon installiert bekommen und läuft perfekt.

    Jetzt wollte ich unter anderem Joomla und noch ein anderes PHP Script installieren.
    Ich habe einen neuen Kunden mit FTP und MySQL angelegt.

    Wenn ich jetzt auf den FTP das Script lade stoße ich immer auf eine weiße Seite.

    Was kann das sein ?
     
  2. Till

    Till Administrator

    Poste mal die Fehlermeldung aus dem error.log der Webseite.
     
  3. SilverXX

    SilverXX Member

    Ich glaub die gibt´s bei mir nicht ?

    Laut phpinfo:
    error_log - no valueno
     
  4. Till

    Till Administrator

    Das Log gibt es auf jeden Fall wenn Du ISPConfig installiert hast, es ist vom apache und nicht php, steht aöso nicht im phpinfo. Schau Dir mal das Webseiten verzeichnis /var/www/deinedomain.tld/ an, da gibt es ein log Verzeichnis und da liegt das error.log drin.
     
  5. SilverXX

    SilverXX Member

    Stimmt ! Hier die Error Log...

     
    Zuletzt bearbeitet: 17. Jan. 2012
  6. Till

    Till Administrator

    Du versuchst eine Datei zu laden die laut open_baasedir für das web nicht erlaubt ist. Füge:

    :/usr/share/php

    zum open_basedir Pfad des webs hinzu und klicke auf speichern.
     
  7. SilverXX

    SilverXX Member

    Also unter System/Serverkonfiguration --> Web

    [website_path]/web:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin

    muss dann so aussehen ?

    [website_path]/web:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php
     
  8. Till

    Till Administrator

    Das kannst Du zusätzlich machen, das ändert den Default für neue Websites. Ich habe vom Optionen Tag der Webseite gesprochen.
     
  9. SilverXX

    SilverXX Member

    :confused: hm... wo finde ich den denn jetzt ? :rolleyes:

    Edit: Okay, hab ihn gefunden: Mit dem Admin einloggen, auf die angelegte Domain klicken, Optionen.


    Wenn ich das jetzt unter serverkonfiguration mache, dann muss ich das bei keinem anderen Kunden so mehr machen, sehe ich das richtig ?
     
    Zuletzt bearbeitet: 17. Jan. 2012
  10. SilverXX

    SilverXX Member

    Okay, also bei neuen Domains wird der Pfad dann übernommen. Habe ich gerade getestet.

    Das eine Script funktioniert nun seitdem :/usr/share/php zum open_basedir Pfad hinzugefügt habe...

    Jetzt habe ich aber noch ein Problem mit Joomla!

    Hab jetzt das CMS Joomla gerade mal hochgeladen, aber es hängt immer bei der Installation direkt bei der Sprachauswahl/Schritt 1. - Wenn ich auf den "Weiter" Button klicke ändert sich die Adresse im Browser von http://domain.de/installation/index.php nach http://domain.de/installation/index.php#. Das Bild bleibt gleich. Schon komisch... ich denke das stimmt sonst noch was mit der Konfiguration nicht...
     
  11. Till

    Till Administrator

    Dann schau nochmal ins error.log.
     
  12. SilverXX

    SilverXX Member

    Das habe ich natürlich diesmal direkt gemacht, steht leider nichts drin :(
     
  13. Till

    Till Administrator

    Hast Du denn den richtigen PHP-Mode und Dateiberechtigungen eingestellt?


    Für CMS Systeme ist der empfohlene PHP-Mode: php-fcgi, Suexec muss an sein und alle Dateien im web Verzeichnis müssen dem web user und der client Gruppe des webs gehören.
     
  14. SilverXX

    SilverXX Member

    Hey Till !

    Habe das jetzt so gemacht, dass ich das komplette RAR Archiv auf den Server geladen und mit dem Programm "extplorer" direkt auf dem Server entpackt habe.

    Danach hat sich die Installation immer noch nicht weiter klicken gelassen. Das Problem lag jetzt wohl am Firefox. Mit dem IE hat nun alles problemlos funktioniert. Echt komisch...

    php-fcgi ist vorhanden und die Dateien liegen auch alle im richtigen Web.

    Wo kann ich kontrollieren ob "Suexec" an ist ?
     
  15. Till

    Till Administrator

    Checkbox "Suexec" in den Einstellunegn der Webseite, angehakt = ein, nicht angehakt = aus.
     
  16. SilverXX

    SilverXX Member

    Danke für die Antwort !

    Ja, dass war angehakt. Ist es eigentlich eine Sicherheitslücke wenn ich immer alles eingeschaltet habe ?

    Sprich
    CGI
    SSI
    Ruby
    Python
    SuEXEC
    Eigene Fehlerseiten
     
  17. Till

    Till Administrator

    Es ist auf jeden fall unsicherer als es nicht zu aktivieren. Man sollte immer nur die notwendigen Features anschalten. Z.B. für ein php basiertes CMS können CGI,SSI,Ruby und Python deaktiviert werden.
     

Diese Seite empfehlen