nach update auf **p5 vhost`s weg :/

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von spencky88, 28. Jan. 2015.

  1. spencky88

    spencky88 Member

    servus ihr lieben,
    seit gestern plagt mich mal wieder ein unlösbares problem.
    nachdem ich gestern mein isp auf die p5 gebracht habe läuft mein apache2 nicht mehr richtig, irgendwie sind alle vhost dateien verschwunden und dementsprechend ist keine seite mehr erreichbar
    auch die isp oberfläche leider nicht.
    gibt es eine möglichkeit wie ich die automatisch wieder anlegen lassen kann? ein reconfig und reinstall von apache brachte leider keinen erfolg ..... bin etwas am verzweifeln :/

    Danke schonmal für die hilfe :)
    mfg

    *Edit*
    Alle log daten bezgl. apache2 sind leer.
     
    Zuletzt bearbeitet: 28. Jan. 2015
  2. Till

    Till Administrator

    Hi,

    das ists ehr merkwürdig, da ein ISPConfig Update nichts an den vhost dateien macht, außer den ispconfig.vhost und den apps.vhost neu zu schreiben. Webseiten werden dabei nicht geändert. Also Du meinst dass die Verzeichnisse /etc/apache2/sites-enabled/ und /etc/apache2/sites-available/ jetzt beide leer sind?
     
  3. spencky88

    spencky88 Member

    hi,
    ne das ist ja das komische. sites-available ist da und voll, nur sites enabled ist leer, dort befindet sich nurnoch die 000-default ....

    ich kann den fehler selbst kein stück nachvollziehen
     
  4. Till

    Till Administrator

    erstell mal einen symlink:

    000-ispconfig.conf

    und

    000-ispconfig.vhost

    dort die auf die passenden dateien in sites-available zeigen. dann restarte apache und logge Dich in ispconfig ein. Dort kannst Du unter einstellungen > resync einen resync auf die websites machen, das erstellt alle symlinks neu.
     
  5. spencky88

    spencky88 Member

    habe ich gemacht mit
    ln -s /etc/apache2/sites-available/ispconfig.vhost /etc/apache2/sites-enabled/000-ispconfig.vhost

    natürlich für beide dateien. jedoch sagt er mir jetzt
    Forbidden
    You don't have permission to access / on this server.
     
  6. Till

    Till Administrator

    poste mal die ausgabe von:

    ls -la /var/www/ispconfig
     
  7. spencky88

    spencky88 Member

    ausgabe ist

    root@server1:~# ls -la /var/www/ispconfig
    lrwxrwxrwx 1 root root 34 20. Apr 2011 /var/www/ispconfig -> /usr/local/ispconfig/interface/web
     
  8. Till

    Till Administrator

    Das ist ok. Und:

    ls -la /usr/local/ispconfig/interface/web
     
  9. spencky88

    spencky88 Member

    das wäre dann:

    root@server1:~# ls -la /usr/local/ispconfig/interface/web
    insgesamt 124
    drwxr-s--- 19 ispconfig ispconfig 4096 27. Jan 18:30 .
    drwxr-s--- 8 ispconfig ispconfig 4096 27. Jan 18:29 ..
    drwxr-s--- 6 ispconfig ispconfig 4096 7. Sep 2013 admin
    -rwxr-x--- 1 ispconfig ispconfig 3050 27. Jan 18:29 capp.php
    drwxr-s--- 6 ispconfig ispconfig 4096 2. Mai 2014 client
    -rwxr-x--- 1 ispconfig ispconfig 2962 27. Jan 18:30 content.php
    drwxr-s--- 7 ispconfig ispconfig 4096 11. Nov 2012 dashboard
    drwxr-s--- 6 ispconfig ispconfig 4096 11. Nov 2012 dns
    -rwxr-x--- 1 ispconfig ispconfig 0 27. Jan 18:30 dummy_login.html
    -rwxr-x--- 1 ispconfig ispconfig 18478 27. Jan 18:29 favicon.ico
    drwxr-s--- 6 ispconfig ispconfig 4096 12. Okt 2011 help
    -rwxr-x--- 1 ispconfig ispconfig 3176 27. Jan 18:30 index.php
    drwxr-s--- 5 ispconfig ispconfig 4096 2. Mai 2014 js
    -rwxr-x--- 1 ispconfig ispconfig 1649 27. Jan 18:29 keepalive.php
    drwxr-s--- 4 ispconfig ispconfig 4096 2. Mai 2014 login
    drwxr-s--- 6 ispconfig ispconfig 4096 12. Okt 2011 mail
    drwxr-s--- 6 ispconfig ispconfig 4096 11. Nov 2012 mailuser
    drwxr-s--- 6 ispconfig ispconfig 4096 7. Sep 2013 monitor
    -rwxr-x--- 1 ispconfig ispconfig 4237 27. Jan 18:30 nav.php
    drwxr-s--- 2 ispconfig ispconfig 4096 20. Apr 2011 remote
    -rwxr-x--- 1 ispconfig ispconfig 25 27. Jan 18:30 robots.txt
    drwxr-s--- 7 ispconfig ispconfig 4096 17. Sep 2013 sites
    drwxr-s--- 3 ispconfig ispconfig 4096 20. Apr 2011 strengthmeter
    drwxrws--- 2 ispconfig ispconfig 4096 2. Mai 2014 temp
    drwxr-s--- 7 ispconfig ispconfig 4096 27. Jan 18:30 themes
    drwxr-s--- 6 ispconfig ispconfig 4096 11. Nov 2012 tools
    drwxr-s--- 6 ispconfig ispconfig 4096 18. Jun 2012 vm
     
  10. Till

    Till Administrator

    Das ist auch ok.

    Welches OS und welche ispconfig version hattest Du vorher= Hast Du nur ispconfig oder auch das OS aktualisiert?
     
  11. spencky88

    spencky88 Member

    Ich hab Debian squeezy , die alte ISP Version war **p4 und nur ISP hat ein update bekommen. Dadurch ist das alles für mich völlig unverständlich
     
    Zuletzt bearbeitet: 29. Jan. 2015
  12. Till

    Till Administrator

    Durch das ispconfig update kann das an sich nicht gekommen sein, denn der updater kann z.B. garnicht die vhost dateien löscgeb. Ich denke mal dass da noch was anderes mit rein gesielt hat, vielleicht wurde etwas vorher gelöscht und es ist erst jetzt aufgefallen weil das update die dienste wie apache neu gestartet hat, denn solange man apache nicht neu startet merkt man nicht, wenn seine Config gelöscht wurde da er die nur beim restart / reload neu läd.

    Schau mal bitte in /var/backu, da müssten für die letzten ispconfig updates jeweils backups liegen die auch ein etc.tar.gz enthalten. Entpacke mal das letzte etc.tar.gz und schau dann in die entpackten Verzeichnisse, ob dort die symlinks in der apache config noch da sind.
     
  13. spencky88

    spencky88 Member

    das backup war vorhanden zum glück, jedoch bleibt es beim
    Forbidden
    You don't have permission to access /index.php on this server.

    und in der konsole bekomme ich beim apache restart versuch gesagt

    root@server1:~# /etc/init.d/apache2 restart
    Syntax error on line 124 of /etc/apache2/sites-enabled/100-MySite.de.vhost:
    Invalid command 'FCGIWrapper', perhaps misspelled or defined by a module not included in the server configuration
    Action 'configtest' failed.
    The Apache error log may have more information.

    wenn ich es mal auskommentiere fängt er an über die rewrite engine zu mosern ....... bis ich letztlich fast die ganze datei auskommentiert habe. ändert jedoch leider nichts daran das mir der zugriff auf isp versagt wird.

    es klappt nicht als mysite.de:8080 noch server1.mysite.de:8080 und schon garnicht ip:8080 ....

    größer kann die verzweiflung kaum werden -.-

    **********Nachtrag**********
    Die Logs sind noch immer leer
     
    Zuletzt bearbeitet: 29. Jan. 2015
  14. Till

    Till Administrator

    mod_fcgi ist entseder nicht installiert oder nicht aktiviert im apache.
     
  15. spencky88

    spencky88 Member

    war installiert und aktiviert, die konfigwurde nur nicht geladen. habe alles disabled und neu enabled, nun laufen die subdomains wieder, jedoch wird mir auf dem isp port nun eine völlig leere seite angezeigt :S
     
  16. spencky88

    spencky88 Member

    Habe den fehler gefunden, der apache2-suexec war beschädigt, nach reinstall läuft nun alles wieder :D danke till ;)

    nun noch eine frage, ich hab das problem das im webdav die meisten user (vorallem die apfel-nutzer) in den ordnern keine umlaute (äöü) interpretiert bekommen, das ist mist, dadurch können sie die wichtigsten ordner garnicht erst öffnen. liegt das am charset? und wie änder ich das dann ohne das ich alles umbenennen muss? (knapp 1700 dateien mit umlaute) :oops:
     
  17. Till

    Till Administrator

  18. spencky88

    spencky88 Member

    hey =) jetzt habe ich das nächste problem, es scheint immernoch nicht alles behoben zu sein, wenn ich in phpmyadmin möchte soll ich eine x-httpd-php herunterladen anstatt das er mir die login seite zeit, im php open base dir ist ist alles richtig :S ..... eine idee?
     
  19. Till

    Till Administrator

    Ist mod_php installiert und aktiviert? Hast Du die suphp config datei so geändert, wie es in der perfect server anleitung steht?
     

Diese Seite empfehlen