Nach Update keine Webseiten mehr da.

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Equalitymind, 6. Jan. 2010.

  1. Equalitymind

    Equalitymind New Member

    Hallo nachdem ich gestern IspConfig auf die Aktuelle Version Geupdatet habe funktionieren keine Webseiten mehr werder die bereits erstellten noch die ispconfig Seite.

    Ftp und Mail Acounts laufen einwandfrei.

    Das Problem habe ich soweit eingegrenzt das ich der meinung bin der Apache startet nicht richtig.

    Also habe ich über console versucht den apache wieder zu starten und bekomme folgende fehlermeldeung:

    Code:
    Restarting web server: apache2Syntax error on line 7 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    Port must be specified
     failed!
    
    Die Datei die bemängelt wird sieht so aus

    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    Listen yes
    NameVirtualHost *:8080
    <VirtualHost _default_:yes>
    ServerAdmin webmaster@localhost
    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>
    <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    php_value magic_quotes_gpc 0
    </Directory>
    </IfModule>
    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off
    </VirtualHost>
     
    
    So jetzt meine Große frage wo liegt der Fehler habe den ganzen Abend in irgendwelchen Suchmaschienen verbracht und nichts gefunden .

    Wäre super wenn mir wer helfen könnte.

    Danke im Voraus .

    Mfg Stefan
     
    Zuletzt bearbeitet: 6. Jan. 2010
  2. Till

    Till Administrator

    Ändere die Zeilen:

    Listen yes
    NameVirtualHost *:8080
    <VirtualHost _default_:yes>

    in:

    Listen 8080
    NameVirtualHost *:8080
    <VirtualHost _default_:8080>

    Der Fehler ist, dass Du während des updates bei der Frage nach dem Port anstatt 8080 das Wort yes eingegeben hast.
     
  3. Equalitymind

    Equalitymind New Member

    Super Vielen dank hat Funktioniert

    zu den eingeben mit den yes .... wenn ich so genau darüber nachdenke könnte das wohl sein -_-
     

Diese Seite empfehlen