Nach Upgrade Ubuntu 14.10 -> 15.04 Probleme

#1
Nabend,

seit einigen Wochen habe ich folgendes Problem:
Code:
root@s1:/# apt-get upgrade
Reading package lists... Done
Building dependency tree   
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
linux-image-extra-3.16.0-41-generic : Depends: linux-image-3.16.0-41-generic but it is not installable
linux-image-extra-3.19.0-28-generic : Depends: linux-image-3.19.0-28-generic but it is not installed
linux-image-extra-3.19.0-30-generic : Depends: linux-image-3.19.0-30-generic but it is not installed
sensible-mda : Depends: sendmail-bin but it is not installed or
                         mail-transport-agent
E: Unmet dependencies. Try using -f.
Auch "apt-get autoremove" und "apt-get -f install" funktionieren nicht.
Auch Pakete, die man installieren oder entfernen möchte, werden abgebrochen wg. des o.g. Grundes.
Leider habe ich im Internet nichts gefunden und eine reinstallation oder --purge Entfernung des Kernels (oder Kernel) ist nicht möglich.

Hat jemand eine Idee? :/

Grund war eigentlich ein Mailproblem eines Kunden. Dort kamen Mails immer zurück mit der Info "[(0) -domain.de-. [x.xxx.xxx.xxx]:25: socket error]", obwohl alles angelegt ist. Mails gehen raus, aber nichts geht zum Server (Postfach o. Weiterleitung), bzw. ich denke es ist der MTA, aber der lässt sich nicht ändern/neuinstallieren oder rekonfigurieren wegen des Kernel-Fehlers.

Gruß
Julian
 
#3
Der MTA ist bei ISPConfig postfix. Hast Du mal versucht, sensible-mda zu deinstallieren?
Hier der Versuch:

Code:
apt-get remove sensible-mda
Reading package lists... Done
Building dependency tree 
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-image-3.19.0-26-generic linux-image-extra-3.19.0-26-generic procmail
  sendmail-base sendmail-cf
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  linux-image-extra-3.16.0-41-generic linux-image-extra-3.19.0-28-generic
  linux-image-extra-3.19.0-30-generic sensible-mda
0 upgraded, 0 newly installed, 4 to remove and 15 not upgraded.
3 not fully installed or removed.
After this operation, 479 MB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 66457 files and directories currently installed.)
Removing linux-image-extra-3.16.0-41-generic (3.16.0-41.57) ...
depmod: FATAL: could not load /boot/System.map-3.16.0-41-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.16.0-41-generic /boot/vmlinuz-3.16.0-41-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.16.0-41-generic /boot/vmlinuz-3.16.0-41-generic
update-initramfs: Generating /boot/initrd.img-3.16.0-41-generic
grep: /boot/config-3.16.0-41-generic: No such file or directory
WARNING: missing /lib/modules/3.16.0-41-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/3.16.0-41-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
mktemp: failed to create file via template ‘/var/tmp/mkinitramfs-FW_XXXXXX’: No such file or directory
update-initramfs: failed for /boot/initrd.img-3.16.0-41-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.16.0-41-generic (--remove):
subprocess installed post-removal script returned error exit status 1
Removing linux-image-extra-3.19.0-28-generic (3.19.0-28.30) ...
depmod: FATAL: could not load /boot/System.map-3.19.0-28-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.19.0-28-generic /boot/vmlinuz-3.19.0-28-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.19.0-28-generic /boot/vmlinuz-3.19.0-28-generic
update-initramfs: Generating /boot/initrd.img-3.19.0-28-generic
grep: /boot/config-3.19.0-28-generic: No such file or directory
WARNING: missing /lib/modules/3.19.0-28-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/3.19.0-28-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
mktemp: failed to create file via template ‘/var/tmp/mkinitramfs-FW_XXXXXX’: No such file or directory
update-initramfs: failed for /boot/initrd.img-3.19.0-28-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.19.0-28-generic (--remove):
subprocess installed post-removal script returned error exit status 1
Removing linux-image-extra-3.19.0-30-generic (3.19.0-30.34) ...
depmod: FATAL: could not load /boot/System.map-3.19.0-30-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.19.0-30-generic /boot/vmlinuz-3.19.0-30-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.19.0-30-generic /boot/vmlinuz-3.19.0-30-generic
update-initramfs: Generating /boot/initrd.img-3.19.0-30-generic
grep: /boot/config-3.19.0-30-generic: No such file or directory
WARNING: missing /lib/modules/3.19.0-30-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/3.19.0-30-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
mktemp: failed to create file via template ‘/var/tmp/mkinitramfs-FW_XXXXXX’: No such file or directory
update-initramfs: failed for /boot/initrd.img-3.19.0-30-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.19.0-30-generic (--remove):
subprocess installed post-removal script returned error exit status 1
Removing sensible-mda (8.14.4-8) ...
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
linux-image-extra-3.16.0-41-generic
linux-image-extra-3.19.0-28-generic
linux-image-extra-3.19.0-30-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Auch hier lässt sich mit autoremove oder install -f oder gar upgrade nichts mehr machen (bricht immer beim linux-image ab).
Code:
Errors were encountered while processing:
linux-image-extra-3.16.0-41-generic
linux-image-extra-3.19.0-26-generic
linux-image-extra-3.19.0-28-generic
linux-image-extra-3.19.0-30-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
Neugestartet - muss ich gestehen - habe ich ihn seit dem nicht mehr, da ich Angst habe, dass dann gar nichts mehr geht (fehlender Kernel oder kaputte Pakete).

Speicherplatz ist aber vorhanden (bei google gibts diesen Fehler nur bei voller Festplatte):
Code:
df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            7.8G     0  7.8G   0% /dev
tmpfs           1.6G  153M  1.5G  10% /run
/dev/sda2        22G  1.7G   19G   9% /
tmpfs           7.8G     0  7.8G   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           7.8G     0  7.8G   0% /sys/fs/cgroup
/dev/sda3       1.8T   15G  1.7T   1% /var
tmpfs           1.6G     0  1.6G   0% /run/user/0
Auch ein Smarttest brachte, dass die HDDs in Ordnung sind (inkl. RAID).
 
Zuletzt bearbeitet:
#4
Bei Dir schlägt der eine oder andere remove (z.B. Removing linux-image-extra-3.16.0-41-generic) fehl. Entweder ist ein Entfernen früher fehlgeschlagen, oder Du hast manuell Dateien gelöscht. Du kannst mal apt-get install --reinstall linux-image-extra-3.13.0-45-generic versuchen.
 
#5
Bei Dir schlägt der eine oder andere remove (z.B. Removing linux-image-extra-3.16.0-41-generic) fehl. Entweder ist ein Entfernen früher fehlgeschlagen, oder Du hast manuell Dateien gelöscht. Du kannst mal apt-get install --reinstall linux-image-extra-3.13.0-45-generic versuchen.
Hatte ich glaube ich schon mal versucht, aber hier das Ergebnis:
Code:
apt-get install --reinstall linux-image-extra-3.13.0-45-generic
Reading package lists... Done
Building dependency tree    
Reading state information... Done
E: Unable to locate package linux-image-extra-3.13.0-45-generic
E: Couldn't find any package by regex 'linux-image-extra-3.13.0-45-generic'
Code:
uname -r
3.19.0-31-generic
Achso: Manuell hatte ich nie was entfernt, immer nur vom System aus die Updates einspielen lassen ohne Abbruch.
 
Zuletzt bearbeitet:

Werbung