Nach Wechsel des SSL-Zertifikats: Apache startet nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Paul, 9. Dez. 2014.

  1. Paul

    Paul Member

    Hallo.
    Beim Einbau eines neuen SSL-Zertifikats habe ich mich irgendwie verstrickt. Jedenfalls startet jetzt der Apache nicht mehr. So bin ich vorgegangen:
    In ISPConfig 3 habe ich das SSL-Zertifikat gelöscht.
    Beim Eintragen des neuen, verlängerten Zertifikats muss dann etwas schief gelaufen sein. Nach dem Abspeichern startet der Apache nicht mehr.
    Zwischenzeitlich habe ich die alten Zertifikats-Dateien wieder in den SSL-Ordner des Vhost kopiert. Das hat aber auch nicht geholfen.
    Hat jemand einen Tipp wie ich den Apachen wieder anschiebe?
    Das error.log zeigt:
    [Tue Dec 09 13:28:30 2014] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Tue Dec 09 13:28:30 2014] [warn] RSA server certificate CommonName (CN) `Vorname Name' does NOT match server name!?
    [Tue Dec 09 13:28:30 2014] [error] Unable to configure RSA server private key
    [Tue Dec 09 13:28:30 2014] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
     
  2. Till

    Till Administrator

    Lösche den Symlink der betroffenen Seite in /etc/apache2/sites-enabled/, dann starte apache neu und Du kannst Dich in ISPConfig wieder einloggen. Wenn Du kein aktuelles ISPConfig installiert hast (3.0.5.4p5) solltest u mal updaten, in einer alten Version gab es mal Probleme mit dem Löschen von ssl certs.
     
  3. Paul

    Paul Member

    Schade, das war's leider noch nicht.
    Die Verknüpfung habe ich aus /sites-enabled rausgelöscht. Auch nach dem Reboot startet apache noch nicht. Selber Fehler in error.log.
    Vorher hatte ich ISPConfig 3 auf das neueste Release upgedatet. Dabei hatte ich diesmal auch ein neues Zertifikat erstellen lassen. Evtl. liegt es auch an diesem Zertifikat, dass der Apache nicht startet. Falls es an dem Zertifikat liegt, gibt's dann auch einen Kniff dieses Zertifikat zu umschiffen?
     
  4. Till

    Till Administrator

    Du kannst es nochmal neu erstellen indem Du das update nochmal ausführst:
    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
     
  5. Paul

    Paul Member

    Für ISPConfig hatte ich schon ein neues Zertifikat erstellt.
    cd /usr/local/ispconfig/interface/ssl/
    openssl req -new -newkey rsa:4096 -days 3650 -nodes -keyout ispserver.key -out ispserver.csr
    Das hat aber auch nicht den gewünschten Erfolg gebracht. - Apache hängt beim Hochfahren.
    Auf der Console ist zu lesen:
    [....] Starting web server: apache2[Tue Dec 09 16:26:42 2014] [warn] NameVirtualHost ersteIP:443 has no VirtualHosts
    [Tue Dec 09 16:26:42 2014] [warn] NameVirtualHost zweiteIP:80 has no VirtualHosts
    [Tue Dec 09 16:26:42 2014] [warn] NameVirtualHost dritteIP:443 has no VirtualHosts
    [Tue Dec 09 16:26:42 2014] [warn] NameVirtualHost vierteIP:443 has no VirtualHosts
    [Tue Dec 09 16:26:42 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    Action 'start' failed.
     
  6. Paul

    Paul Member

    Nach stundenlangem Herumprobieren habe ich jetzt schließlich aufgegeben und ein Sicherungsimage der root-Partition eingespielt. Alles läuft wieder. Vor dem nächsten Herumfummeln an Zertifikaten werde ich auf jeden Fall die betreffenden Ordner zusätzlich noch zippen.
    Diesen Fall wollte ich schließen, finde aber nicht, wo man das macht. - Also der Fall ist erledigt.
    Danke.
     

Diese Seite empfehlen