Neu angelegte ftp user können sich nicht einloggen. (530)

Dieses Thema im Forum "Allgemein" wurde erstellt von Wh1sper, 9. Juni 2015.

  1. Wh1sper

    Wh1sper Member

    Hi,
    Beim Einrichten eines neuen ftp users ist mir leider aufgefallen, dass das passwort angeblich ungültig ist.
    Wenn ich den Hash in der DB von einem alten ftp user auf den neuen User kopiere klappt es ebenfalls nicht.
    Kopiere ich denselben hash auf einen anderen älteren ftp user, klappt das sehr wohl.
    Ich habe auch das Login in phpmyadmin geprüft, gleiches Ergebnis.
    DEBUG für pure-ftp habe ich eingeschaltet, bringt aber nichts an neuen Erkentnissen.
    Die pure ftp mysql config ist seit Jahren unverändert.
    In der ftp-user DB sehen die Einträge vollkommen normal aus, finde da nicht, was ein Login verhindern sollte.

    ISPConfig ist auf den aktuellen patch 8, ging vorher aber auch nicht.
    Debian Wheezy

    Hat einer noch einen Tip?
    Evtl.
    "echo no > /etc/pure-ftpd/conf/PAMAuthentication", habe ich erst jetzt dran gedacht ?
     
  2. Wh1sper

    Wh1sper Member

    PAMAuthentication auf no hilft auch nicht o_O
     
  3. reSh

    reSh Member

    Hallo,

    steht denn irgendwas in den Logs?
     
  4. Wh1sper

    Wh1sper Member

    Nix, was hilft
    [INFO] New connection from 77.21.x.x
    Jun 9 19:00:18 rootgemeinschaft pure-ftpd: (?@77.21.x.x) [DEBUG] Command [user] [xx_ftp]
    Jun 9 19:00:22 rootgemeinschaft pure-ftpd: (?@77.21.x.x) [DEBUG] Command [pass] [<*>]
    Jun 9 19:00:26 rootgemeinschaft pure-ftpd: (?@77.21.x.x) [WARNING] Authentication failed for user [xx_ftp]
    Jun 9 19:00:26 rootgemeinschaft pure-ftpd: (?@77.21.x.x) [DEBUG] Command [syst] []
     
  5. reSh

    reSh Member

    Das ist wirklich sehr dürftig. Ist denn irgendwas nennenswertes in der Zeit zwischen dem letzten Funktionieren und dem "Nicht-Funktionieren" am Server gemacht worden? Updates/Konfigurationen vielleicht auch ein dist-upgrade?
     
  6. Till

    Till Administrator

    Gibt es einen shell user mit dem selben namen? Stimmt das mysql passwort in der pure-ftpd config datei?
     
  7. Wh1sper

    Wh1sper Member

    Nein, kein shellbenutzer gleichen Namens, obwohl ich das mal probiert hatte.
    DB Passwort ist korrekt.
    ftp geht ja, solange man die vor langer Zeit eingerichteten ftp user nimmt.
    Nur neue gehen nicht, obwohl sie scheinbar korrekt in ftp_user eingetragen werden
     
  8. Till

    Till Administrator

    Schau mal bitte welches verzeichnis für den ftp user in der ftp_user tabelle in ispconfig gibt und ob dieses verzeichnis auch wirklich existiert.
     
  9. die-andis

    die-andis Member

    ich hänge mich hier mal dran. Hab genau das gleiche Problem

    Log:

    Jun 13 14:34:01 zebraxx.server4you.de proftpd[5004] zebraxx.server4you.de.server4you.de :):ffff:87.129.30.30[::ffff:87.129.30.30]): FTP session opened.

    Jun 13 14:34:02 zebraxx.server4you.de.server4you.de proftpd[5004] zebraxx.server4you.de.server4you.de :):ffff:87.129.30.30[::ffff:87.129.30.30]): USER test: no such user found from ::ffff:87.129.30.30 [::ffff:87.129.30.30] to ::ffff:188.xxx.113.63:21

    Jun 13 14:34:03 zebraxx.server4you.de.server4you.de proftpd[5004] zebraxx.server4you.de.server4you.de :):ffff:87.129.30.30[::ffff:87.129.30.30]): FTP session closed.

    bei mir trifft es auch auf FTP-user zu, bei denen ich seit dem letzten Update (p7/p8) etwas geändert habe.
     
  10. Till

    Till Administrator

    Prüfe bitte mal den Pfad und vergleiche einen eintrag in der datenbank eines funktionierendem mit einem nicht funktionierendem User, da muss es ja einen Unterschied geben.
     
  11. die-andis

    die-andis Member

    wie komme ich auf die ISPCONFIG-Tabellen (hab ich bisher noch nicht gebraucht)?
     
  12. Till

    Till Administrator

    Logge dich in phpmyadmin als root user ein, gehe dort zur dbispconfig datenbank. darin findest du die Tabelle ftp_user mit allen FTP benutzern drin.
     
  13. die-andis

    die-andis Member

    ok, bin drin. sieht alles gut mit dem Pfaden. ID´s etc.

    Mittlerweile geht gar kein FTP-User mehr :-(

    Ich habe vor ein paar Wochen mein Linux root Passwort geändert. Könnte es etwas damit zu tun haben?
     
  14. Till

    Till Administrator

  15. die-andis

    die-andis Member

    jetzt gehts! irgendwie hab ich wohl versehentlich einen proftp gestartet und der hat pureftp "überlagert". Danke für deine schnelle Hilfe
     
  16. Wh1sper

    Wh1sper Member

    Ich habe gerade nochmal einen neuen ftp benutzer für meine alte domain eingerichtet: geht einwandfrei, muss also irgendie doch mit der speziellen domain zusammenhängen.
    Ich werde mir die DB einträge noch mal genau ansehen.
    Werde schon finden.
    Das betroffene Web ist schon häufig umgezogen, vielleicht ist dabei mal was schief gelaufen...
     
  17. Wh1sper

    Wh1sper Member

    Der Webuser war nicht in der passwd.
    Keine Ahnung wie das passiert ist.
    Scheinbar geht nun alles
     
  18. Till

    Till Administrator

    Achte mal drauf ob beim anlegen des nächsten webs der web[ID] user in der passwd steht, wenn nicht dann kontrollier mal ob die sshusers group existiert und teste mal passwd und group Datei mit:

    pwck

    und

    grpck

    Befehl.
     
    Wh1sper gefällt das.
  19. Wh1sper

    Wh1sper Member

    Sorry, ich vergass:
    Ursache war ein verhaspelter pure-ftp Prozess, Neustart des Dienstes half.
     

Diese Seite empfehlen