Neue Domain angelegt > Error 403

Dieses Thema im Forum "Allgemein" wurde erstellt von stefanw, 9. Aug. 2010.

  1. stefanw

    stefanw New Member

    Hallo,

    ich hab gerade eine neue Domain angelegt. Wenn man die aufrufen will passiert folgendes: Im Browser sehe ich einen 403, aber nicht den von ISPConfig sondern einen vom Apache und im error.log der Domain steht: Symbolic link not allowed or link target not accessible: /var/www/domain.tld

    Es geht um ISPConfig 3

    Was ist das denn?
     
    Zuletzt bearbeitet: 9. Aug. 2010
  2. Till

    Till Administrator

    Poste mal die vhost Datei der Domain. Der Ordner /var/www/domain.tld darf auch nicht accessible sein, das Web root Directory ist ja immer /var/www/domain.tld/web

    Hast Du irgendwelche Änderungen an den vhost templates, den pfaden in ispconfig system config tec vorgenommen?
     
  3. stefanw

    stefanw New Member

    Hallo,

    an den Templates habe ich nichts geändert. Hier der vhost:

    Code:
    <Directory /var/www/domain.tld>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost *:80>
          DocumentRoot /var/www/domain.tld/web
      
        ServerName domain.tld
        ServerAlias www.domain.tld
        ServerAdmin webmaster@domain.tld
    
        ErrorLog /var/log/ispconfig/httpd/domain.tld/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
        
        <Directory /var/www/domain.tld/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client46/web117/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # suexec enabled
        SuexecUserGroup web117 client46
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # php as fast-cgi enabled
        <IfModule mod_fcgid.c>
          # SocketPath /tmp/fcgid_sock/
          IdleTimeout 3600
          ProcessLifeTime 7200
          # MaxProcessCount 1000
          DefaultMinClassProcessCount 3
          DefaultMaxClassProcessCount 100
          IPCConnectTimeout 8
          IPCCommTimeout 360
          BusyTimeout 300
        </IfModule>
        <Directory /var/www/domain.tld/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web117/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client46/web117/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web117/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web117 client46
        </IfModule>
    
    
    </VirtualHost>
    
    
    
    
     

Diese Seite empfehlen