nginx als Proxy für Apache mit SVN

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von robotto7831a, 17. Feb. 2014.

  1. robotto7831a

    robotto7831a Member

    Hallo,

    ich habe als Frontendserver nginx am laufen und dahinter einen Apache mit DAV Modul um auf Subversion zuzugreifen.

    Wenn ich den Apache über Port 81 anspreche, dann klappt das browsen im SVN Repository perfekt.

    Wenn ich allerdings über Port 80 über den nginx komme, dann kommt bei jedem Zugriff erst einmal 404. Wenn ich dann die Taste F5 drücke, dann kommt die angeforderte Seite aus dem SVN Repository.

    Was habe ich in meiner Konfiguration noch vergessen?

    Code:
     location / {
             access_log off;
              set $dest $http_destination; 
             if ($http_destination ~ "^http://svn.meinedomain/(.+)") { 
                 set $dest [URL]http://svn2.meinedomain:81/$1[/URL];
             } 
              proxy_set_header Destination $dest;
              proxy_pass   [URL]http://svn2.meinedomain:81/[/URL];
          }
    
     
  2. robotto7831a

    robotto7831a Member

    Hier mein Zwischenstand.

    Bis auf PHP Dateien und .htaccess Dateien kann ich auf alle Dateien zugreifen. Nur bei PHP und der .htaccess Datei bekommt ich einen 403. Das nginx Errorlog sagt folgendes.

    Meine Konfiguration sieht aktuell so aus.
    Code:
    location / {
    proxy_pass  https://meinedomain.tld:444;
    proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;
    proxy_set_header  Accept-Encoding  "";
    proxy_set_header  Host  $host;
    proxy_set_header  X-Real-IP  $remote_addr;
    proxy_set_header  X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header  X-Forwarded-Proto $scheme;
    add_header  Front-End-Https  on;
    proxy_redirect  off;
    }
    
    Woran könnte es liegen, dass ich auf PHP Dateien nicht zugreifen kann? In ISPConfig VHost steht PHP auf disabled.
     

Diese Seite empfehlen