Owncloud sync-Problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ereuter, 21. Aug. 2015.

  1. ereuter

    ereuter Member

    Hallo,
    ich befürchte zwar, dass ich hier nicht ganz richtig bin, aber vielleicht hat ja doch jemand einen guten Tipp für mich.
    Ich habe konkret eine owncloud-Installation gemacht, was auch grundsätzlich funktioniert, aber die Synchronisierung mit CalDAV Synch Free Beta (Android) funktioniert nicht - mit der Meldung: "Ungültige Server Antwort, URL überprüfen".

    Die URL habe ich mit copy u. paste eingefügt - sollte also stimmen. Das CalDAV Synch Free kann mit einer anderen owncloud-Instanz auch tadellos synchronisieren. Andererseits kann ich mit dem Problemserver mit dem Kontact-Plugin auch synchronisieren.

    Jetzt habe ich mir die /var/log/apache2/other_vhosts_access.log angesehen:

    Wenn ich mit kde syncronisere gibt der Server folgendes aus:
    "REPORT /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 401 5179 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) akonadi_davgroupware_resource_2/4.14.2 Safari/534.34"
    "REPORT /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 401 5179 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) akonadi_davgroupware_resource_2/4.14.2 Safari/534.34"
    "REPORT /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 401 5179 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) akonadi_davgroupware_resource_2/4.14.2 Safari/534.34"
    "REPORT /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 207 9105 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) akonadi_davgroupware_resource_2/4.14.2 Safari/534.34"
    "REPORT /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 207 5084 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) akonadi_davgroupware_resource_2/4.14.2 Safari/534.34"
    "REPORT /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 207 5084 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) akonadi_davgroupware_resource_2/4.14.2 Safari/534.34"

    Und beim Synchen mit Android:

    "PROPFIND /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 301 875 "-" "CalDAV Sync Adapter (Android) https://github.com/gggard/AndroidCaldavSyncAdapater Version:1.8.1"
    "GET /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 301 875 "-" "CalDAV Sync Adapter (Android) https://github.com/gggard/AndroidCaldavSyncAdapater Version:1.8.1"
    "PROPFIND /owncloud/remote.php/caldav/calendars/er/defaultcalendar/ HTTP/1.1" 301 737 "-" "CalDAV Sync Adapter (Android) https://github.com/gggard/AndroidCaldavSyncAdapater Version:1.8.1"

    Es wird also einmal REPORT übermittelt und einmal PROPFIND und beim PROPFIND kommt eine 301-Meldung was wohl so viel wie parmanently moved heißen soll.

    Kann ich da beim Server etwas entsprechend einstellen, dass es auch mit dem Android synch-Adapter funktioniert?
     
  2. rolapp

    rolapp New Member

    Scheint ein Bug in Owncloud 8.1.1 zu sein, habe bei mir wieder 8.0.4 installiert. Da funktioniert alles wie gewollt.
    Schau mal bitte hier im Owncloud Forum,
    https://forum.owncloud.org
     
  3. ereuter

    ereuter Member

    Danke für die Info - aber auch mit einer niedrigeren 8.0er Versionsnummer hat es nicht funktioniert. Interessanterweise geht es aber bei einem Server mit dem fast gleichen Grundsystem Debian 3.2.68-1+deb7u3 ohne ispconfig auch mit der aktuellen owncloud-Version. Der ispconfig-Server zeigt Debian 3.2.60-1+deb7u3 und damit funktioniert es nur mit einer 7er-Version von owncloud. Ich schätze, ich werde einfach auf ein owncloud-Update warten und bis dahin vielleicht den anderen Server hernehmen.
     

Diese Seite empfehlen