pam_mysql - SELECT returned no result.

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von Kartze, 22. Juli 2011.

  1. Kartze

    Kartze New Member

    Hallo,

    ich bekomme diese Fehlermeldungen:
    Problem ist wohl dass er beim senden von E-Mails nicht support@XXXXX.de abfragt sondern nur nach support. Ich habe aber mehrere Domains und muss somit support@XXXX.de in die Datenbank eintragen. Wie lässt sich das lösen?

    E-Mails Abfragen läuft Problemlos. Wenn ich in der Datenbank die E-Mail-Adresse auf "support" ändere funktioniert das senden, allerdings nicht das Empfangen :D

    Habe nach dem Howto auf eurer Seite gearbeitet. Also einen Mailserver mit MySQL anbindung.


    Viele Grüße und Danke für Eure Antworten!
     
    Zuletzt bearbeitet: 5. Aug. 2011
  2. Till

    Till Administrator

    Kannst Du bitte mal den Link des verwendeten Tutorials posten.
     
  3. Kartze

    Kartze New Member

  4. Till

    Till Administrator

    Ok. Und Du verwendest wirklich ein Ubuntu 7.10 und keine neuere Version? Die Tutorials funktionieren meistens nur mit genau der Ubuntu Version, für die sie geschrieben wurden, da sich häufig Parameter in den Dateien ändern. Für neuere Ubuntu Versionen gibt es z.B. auf howtoforge.com entsprechend angepasste Tutorials.
     
  5. Kartze

    Kartze New Member

    Ich verwende Ubuntu 11.04
    Und leider gibt es kein Tutorial dass mit diesen Komponenten arbeitet. Also mit MySQL-Verwendung ist mir hier kein anderes bekannt.
    Ich habe einfach nur die Pakete installiert die dafür nötig sind und schritte übersprungen die so nicht möglich sind.

    Dieses Tutorial habe ich schon einmal verwendet und es hat geklappt. Diesmal jedoch zeigt sich dieser Fehler der Falschen Verwendung von Benutzernamen.
     
  6. Till

    Till Administrator

  7. Kartze

    Kartze New Member

    Habe ich durchgearbeitet. Immernoch das selbe Problem.
    Edit: Habe jetzt beim Postausgang die Anmeldedaten auf support+XXXXX.de geändert. Jetzt geht es... Das ist echt komisch. Kann man das nicht ändern, sodass ich fürs empfangen und senden die gleich Addy benutzen kann?
     
    Zuletzt bearbeitet: 26. Juli 2011
  8. Till

    Till Administrator

    Poste bitte mal den Inhalt der Datei /etc/default/saslauthd. Ich vermute mal adss in der Zeil:

    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"

    am Ende das -r fehlt.
     
  9. Kartze

    Kartze New Member

    vi /etc/default:
     
  10. Kartze

    Kartze New Member

    Noch ein Update.
    Ich muss folgende Schritte unternehmen damit das senden und Empfangen funktioniert:
    1. Konto auf dem z.B. Windows Live Messenger anlegen
    2. Benutzername support@XXXX.de dann Ordnerstruktur des Kontos aktualisieren
    3. In PHPmyadmin den benutzernamen auf support+XXXX.de ändern
    4. Postausgangsbenutzername auf support+XXXX.de ändern
    5. Email mit diesem Benutzernamen senden
    6. In PHPmyadmin den benutzernamen auf support@XXXX.de ändern

    Dann funktioniert senden und empfangen. Leider kann das ja wohl unmöglich die lösung sein.
     
  11. Till

    Till Administrator

    Und warum änderst Du den Benutzernamen? Die Dateisztruktur des Kontos wird automatisch bei Eingang der ersten Email angelegt, unabhängig vom smtp-auth. Du musst also nur eine Email an das konto senden, das ist alles. das ist aber bei jedem Dieser setups so.

    Wenn Du das umgehen möchtest, dann nimm lieber eine richtige Email managent Lösung wie ISPConfig 3, das ist deutlich einfacher zu handhaben und bietet umfangreichere Funktionen.
     
  12. Kartze

    Kartze New Member

    Hätte ich das nur vorher gewusst dass es etwas wie ISPConfig 3 gibt :D
    Danke!
     

Diese Seite empfehlen