Passwort für Webstatistik nicht gesetzt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Christian, 24. Aug. 2010.

  1. Christian

    Christian New Member

    Moin,

    ich habe hier ISPC-3 am laufen (aktuelle Version) und bereits mehrere Sites eingerichtet - alles super!
    Nur das Passwort für die Webstatistiken wird nicht angelegt. Das error.log meldet z.B.
    Code:
    No such file or directory: Could not open password file: /var/www/clients/client4/web4/.htpasswd_stats
    Im ISPC-Logfile habe ich keine Fehlermeldung diesbzgl. gefunden.

    Kann ich noch irgendwo Info's herbekommen, warum es nicht funktioniert?
     
  2. Till

    Till Administrator

    Du musst ein passwort auf dem Statistik Tab in den Einstellungen der jeweiligen Webseite eingeben. Nachdem Du das gemacht hast, wird die Datei
    /var/www/clients/client4/web4/.htpasswd_stats ein paar Minuten später erstellt.
     
  3. Christian

    Christian New Member

    Tja, leider passiert das wohl nicht. Kann ich das nur als Admin oder reicht auch der Reseller- und Kundenlogin?
     
  4. Till

    Till Administrator

    - Stehen irgendwelche Fehlermeldungen im system log im ispconfig monitor?
    - Sind irgendwelche Jobs gelistet in der jobqueue im monitor?
     
  5. Christian

    Christian New Member

    Leider nein. Auch im "normalen" Syslog kann ich nichts finden.

    Nein.

    Die Zugriffsrechte habe ich auch schon kontrolliert - passt alles.

    Kann man die Erzeugung des files manuell anstossen? Dann könnte ich die Ausgabe direkt auf der Shell beobachten.
     
  6. Till

    Till Administrator

    1) server.sh cronjob in der root crontab auskommentieren.
    2) Debugging unter system > server settings für den server aktivieren.
    3) Passwort über das Interface neu setzen.
    4) Folgenden Befehl als root aufrufen:

    /usr/local/ispconfig/server/server.sh
     
  7. Christian

    Christian New Member

    So, ich habe die Einstellungen soweit durchgeführt und das Script per Hand aufgerufen. Die Ausgabe hänge ich hier mal an. Ich kann dabei nichts außergewöhnliches finden aber ich Programmiere das ja auch nicht :)

    Code:
    24.08.2010-20:30 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    24.08.2010-20:30 - DEBUG - Found 4 changes, starting update process.
    /usr/bin/fail2ban-client
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'apps_vhost_plugin' raised by event 'server_update'.
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'network_settings_plugin' raised by event 'server_update'.
    24.08.2010-20:30 - WARNING - Network configuration disabled in server settings.
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'postfix_server_plugin' raised by event 'server_update'.
    24.08.2010-20:30 - DEBUG - Processed datalog_id 545
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'apps_vhost_plugin' raised by event 'server_update'.
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'network_settings_plugin' raised by event 'server_update'.
    24.08.2010-20:30 - WARNING - Network configuration disabled in server settings.
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'postfix_server_plugin' raised by event 'server_update'.
    24.08.2010-20:30 - DEBUG - Processed datalog_id 546
    24.08.2010-20:30 - DEBUG - Call function 'ssl' in plugin 'apache2_plugin' raised by event 'web_domain_update'.
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'apache2_plugin' raised by event 'web_domain_update'.
    24.08.2010-20:30 - DEBUG - exec: chmod 751 /var/www/clients/client4/web4/
    24.08.2010-20:30 - DEBUG - exec: chmod 751 /var/www/clients/client4/web4/*
    24.08.2010-20:30 - DEBUG - exec: chmod 710 /var/www/clients/client4/web4/web
    24.08.2010-20:30 - DEBUG - exec: chmod 777 /var/www/clients/client4/web4/tmp
    24.08.2010-20:30 - DEBUG - exec: usermod --groups sshusers web4
    24.08.2010-20:30 - DEBUG - exec: chown web4:client4 /var/www/clients/client4/web4
    24.08.2010-20:30 - DEBUG - exec: chown web4:client4 /var/www/clients/client4/web4/log/error.log
    24.08.2010-20:30 - DEBUG - Disable SSL for: eas-logistics.de
    24.08.2010-20:30 - DEBUG - Add server alias: eas-logistik.de
    24.08.2010-20:30 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/eas-logistics.de.vhost
    24.08.2010-20:30 - DEBUG - Processed datalog_id 547
    24.08.2010-20:30 - DEBUG - Call function 'ssl' in plugin 'apache2_plugin' raised by event 'web_domain_update'.
    24.08.2010-20:30 - DEBUG - Call function 'update' in plugin 'apache2_plugin' raised by event 'web_domain_update'.
    24.08.2010-20:30 - DEBUG - exec: chmod 751 /var/www/clients/client4/web4/
    24.08.2010-20:30 - DEBUG - exec: chmod 751 /var/www/clients/client4/web4/*
    24.08.2010-20:30 - DEBUG - exec: chmod 710 /var/www/clients/client4/web4/web
    24.08.2010-20:30 - DEBUG - exec: chmod 777 /var/www/clients/client4/web4/tmp
    24.08.2010-20:30 - DEBUG - exec: usermod --groups sshusers web4
    24.08.2010-20:30 - DEBUG - exec: chown web4:client4 /var/www/clients/client4/web4
    24.08.2010-20:30 - DEBUG - exec: chown web4:client4 /var/www/clients/client4/web4/log/error.log
    24.08.2010-20:30 - DEBUG - Disable SSL for: eas-logistics.de
    24.08.2010-20:30 - DEBUG - Add server alias: eas-logistik.de
    24.08.2010-20:30 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/eas-logistics.de.vhost
    24.08.2010-20:30 - DEBUG - Processed datalog_id 548
    24.08.2010-20:30 - DEBUG - Call function 'restartHttpd' in module 'web_module'.
    24.08.2010-20:30 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    
    
     
  8. Till

    Till Administrator

    Das ist alles korrekt. Welche ISPConfig Version hast Du denn installiert?
     
  9. Christian

    Christian New Member

    ISPConfig Version: 3.0.2.2
     
  10. Christian

    Christian New Member

    Till, ich habe den Cronjob wieder aktiviert. Vorher habe ich die datei .htpasswd_stats in dem Verzeichnis "getouched". Was soll ich sagen - nachdem ich dann das PWD per ISPC neu gesetzt habe funktioniert es jetzt!

    Kann es daran liegen, das die Datei evtl. zwischenzeitlich gelöscht wurde und dann während eines PWD-Updates nicht vorhanden war?

    Ich wüsste sonst keine Erklärung...
     
  11. Rupertt

    Rupertt New Member

    Hallo,

    ich habe genau das gleiche Problem.
    Die Datei habe ich getouched, aber es wird kein Eintrag erstellt.

    ein "htpasswd2 .htpasswd_stats blabla" hilft auch nicht.
    Wie ist den der standard nutzername für die stats und wie kriege ich ISPCONFIG dazu dies automatisch zu machen, in den logfiles konnte ich keine fehler dazu finden
     
  12. Till

    Till Administrator

    Die Datei sowie der User und das Passwort werden durch ispconfig erstellt, also bitte nichts manuell ändern, führt eh nur zu Fehlern! Der Username für die Statistiken ist immer "admin". Wenn mal was nicht geht, dann steht der Grund normalerweise im ispconfig system log im ispconfig Monitor oder aber in der jobqueue wurden aus Sicherheitsgründen nach einem Fehler die Abarbeitung angehalten. Dann musst Du in der Jobqueue bei dem Fehler einfach auf löschen klicken.
     

Diese Seite empfehlen