PHP 5.3 und MYSQL 5.1 möglich ?

Dieses Thema im Forum "Allgemein" wurde erstellt von nightshift, 9. Dez. 2009.

  1. nightshift

    nightshift New Member

    Hallo,

    habe bevor ich mich gerade hier angemeldet habe mit der Suchefunktion nach PHP 5.3 gersucht aber keine Ergebnisse bekommen die passen, so verzeiht mir bitte wenn es schonmal gefragt wurde.

    Die Frage ist ganz einfach:

    Kann ich ein vorhandenes ispconfig 3 auf Debian Lenny mit Standard Webserver Paketen auf PHP 5.3 und MYSQL 5.1 updaten, oder streikt da dann ispconfig 3 ?

    Es handelt sich dabei um die Dotdeb Pakete: http://www.dotdeb.org/2009/04/07/php-530-rc1-packages-for-lenny/

    Habe bereits die Einträge unter etc/apt/ sourcelist eingetragen und Putty würde mir auch etsprechende Update bzw neu installtionen anbieten.

    Bisher ging dies Problemlos...das waren allerdings Updates der Standard PHP und SQL Version die derzeit angeboten werden für Lenny.

    Update: Habe leider noch vergessen zu erwähnen das ich dann auch gerne phpmyadmin 3.2.X einsetzen möchte, dieses unterstützt ja kein PHP 4 mehr, an sich brauche ich auch kein PHP4 mehr (alle Anwendungen sind PHP5 Anwendungen). Ist nur auch da die Frage wie sich das mit dem ispconfig 3 dann verhält...
     
    Zuletzt bearbeitet: 9. Dez. 2009
  2. Quest

    Quest Member

    Dotdeb hat ja in seinem normalen Repository auch nur PHP 5.2.x drin.
    Für 5.3 haben die ein eigenes Repo eingerichtet.
    Aus diesem hab ich auch gerade 5.3 installiert, die Updates aus dem normalen Dotdeb (mysql, ...) hab ich erst mal bleiben lassen.
    Mit PHP 5.3 läuft auf meinem Server jedenfalls noch alles.
     
  3. nightshift

    nightshift New Member

    So ich habe mir nun von Dotdeb die neuen Pakete organisiert und installiert.

    PHP 5.3.1 dotdeb und MYSQL 5.1.41-1.dotdeb.1

    MySQL-Client-Version: mysqlnd 5.0.5-dev - 081106 - $Revision: 289630 $

    Jetzt bekomme ich in phpmyadmin folgendes Meldungen....

    PHP myadmin liegt noch in folgender Version vor. phpMyAdmin - 2.11.8.1deb5+lenny3

    Ich würde dies gerne wie oben bereits geschrieben auf die aktuelle Version phpmyadmin 3.2.X aktualisieren, da ich persönlich kein php4 mehr brauche.

    Jedoch wäre es ja doof wenn dann nachher ispconfig nicht mehr richtig arbeitet. Daher bräuchte ich dahingend nochmal Feedback. Auch dahingehend wo ich eine aktuelle phpmyadmin Version her bekommen kann (dotdeb hat scheinbar keine)....

    falls ich die manuell über die andere drüber installieren muss wäre es nett wenn ihr mir eine Anleitung geben könnt.


    Zum Abschluss noch die Frage ob die Fehlermeldungen eine Bedeutung haben.

    Zur ersten habe ich bereits gelesen das dies einfach an dem Nummerunterschied 5.0.X -> 5.1.XX liegt und keine Bedeutung hat, korrekt ?
     
  4. nightshift

    nightshift New Member

    Kann mir zu phpmyadmin 3.2 noch jemand etwas sagen...ob das jetzt wie oben genannt funktioniert und...wenn ja wie ich das installieren / updaten kann (z.B. über welche Paketserver)
     
  5. nightshift

    nightshift New Member

    Ich muss leider nochmal Fragen wie das mit der neusten phpmyadmin Version aussieht ?
     
  6. Till

    Till Administrator

    Kann ich leider nichts zu sagen, da ich kein so neues phpmyadmin einsetze.
     
  7. nightshift

    nightshift New Member

    Schade....über andere Meinungen würde ich mich auch freuen...

    Werde das ganze dann villeicht mal die Tage testen...
     

Diese Seite empfehlen