PHP-Dateien werden auf dem Server nicht angezeigt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von rawe28, 7. Dez. 2008.

  1. rawe28

    rawe28 New Member

    Hallo Till,

    ich hab dieses Problem:

    Beim Versuch Tomcat zum laufen zu bringen, bin ich jämmerlich gescheitert und hab alles wieder deinstalliert, auch Java. Danach lief die Kiste nicht mehr richtig rund und anstatt gleich wieder den ganzen Server neu aufzusetzen, hab ich mal versucht, es so hinzukriegen. Hab also den Apache deinstalliert und neu aufgesetzt. Da Postfix, Courier und webalizer bei der Deinstallation mit rausgeflogen waren, hab ich die auch neu aufgesetzt und konfiguriert.
    der Server läuft auch wieder ohne zu stottern.

    Jetzt kann ich aber keine php-Datei mehr aufrufen, egal welche. Sie werden mir nur noch zum Download angeboten, auch wenn ich die Berechtigung auf 777 setze.
    Bei der Fehlersuche hab ich festgestellt, das? Saslauth plötzlich mit CRAM-MD5 authentifiziert. Hab die entsprechenden libs aus /usr/lib/sasl2 dann gelöscht, hat aber nichts gebracht.

    Weißt Du, wo der Fehler liegt?
    Ich würde ungern den ganzen Server neu aufsetzen, da schon viel installiert ist.

    Danke schon mal im Voraus.

    Gruß

    Ralph
     
  2. Till

    Till Administrator

    Am Besten fürst Du einfach nochmal alle Schritte aus dem Bereich der apache Installation des perfect setups aus.
     
  3. rawe28

    rawe28 New Member

    Hab ich gemacht.Für PhP5 auch.Es war als Modul nicht enabled. Hab ich nachgeholt, es geht aber trotzdem noch nichts, bekomme weiterhin nur das PopUpfenster mit dem Hinweis, "Sie möchten folgende datei herunterladen:

    Vom Typ: application/x-http-php ..........."

    Selsamerweise wird der sShop von Xt-commerce aber angezeigt, auch in php und mit Datenbank.

    Woran könnte es jetzt noch liegen?

    Gruß

    Ralph
     
  4. Till

    Till Administrator

    Es muss disabled sein wenn Du ISPConfig einsetzt! Deshalb steht es auch im perfects etup, dass Du es deaktivieren musst.

    das hat mit php nichts zu tun sondern mit apache. Du hast die sharedIP Konfiguration wohl auds Deiner apache Konfihguration gelöscht, die ISPConfig bei der Installation eingetragen hat und die musst Du jetzt wierder einfügen.
     
  5. rawe28

    rawe28 New Member

    Hi,
    Code:
    Es muss disabled sein wenn Du ISPConfig einsetzt! Deshalb steht es auch im perfects etup, dass Du es deaktivieren musst.
    Wie bescheuert von mir! Hab es anschließend natürlich gemäß dem Perfect Setup deaktiviert.:rolleyes:


    Code:
    das hat mit php nichts zu tun sondern mit apache. Du hast die sharedIP Konfiguration wohl auds Deiner apache Konfihguration gelöscht, die ISPConfig bei der Installation eingetragen hat und die musst Du jetzt wierder einfügen.
    Okay, aber mir ist nicht klar, wie ich das machen kann.Die Vhosts_ispconfig.conf sind vorhanden.
    Kann st du mir einen Tip geben?

    Gruß

    Ralph
     
    Zuletzt bearbeitet: 7. Dez. 2008
  6. Till

    Till Administrator

    Hast Du Kopien der datei Vhosts_ispconfig.conf mit angehängtem Datum im gleichen Verzeichnis?
     
  7. rawe28

    rawe28 New Member

    Ja, und ich hab es auch schon erledigt. Shop und Forum laufen, citrusdb und wordpress nicht. Hab die beiden schon deinstalliert, da ich keinen Fehler finden konnte und werde sie neu aufspielen. Danke dir für Deinen Tip, damit war der Schaden ja zu beheben.
    Würde mich aber doch interessieren, warum die beiden Sacdhen nicht liefen, sondern sich nur zum Download anboten. Hast Du eine Ahnung?

    Gruß

    Ralph
     
  8. Till

    Till Administrator

    Dazu kann man so schwer etwas sagen, müsste man alle apache Config Dateien und .htaccess Dateien der entsprechenden Webs durchgehen.
     
  9. rawe28

    rawe28 New Member

    Ich habe immer noch ein PHP-Problem, manche Sachen laufen nicht.

    Frage:

    Mit welchem Befehl kann ich PhP updaten?

    Die Installationsschritte aus dem Perfect Setup nochmals durchgehen , geht ja nicht, weil apt-get mir dann sagt, daß PHP schon die neueste Version ist.
     
  10. Till

    Till Administrator

    Du kannst Pakete mit der --reinstall Option von apt-get neu installieren. Ich denke aber nicht, dass das was bringt. Du muss versuchen rauszufinden was bei den nicht funktionierenden Seiten anders ist, z.B. ob sie ein anderes php open tag benutzen etc.
     
  11. rawe28

    rawe28 New Member


    Danke für den Tip

    Gruß

    Ralph
     

Diese Seite empfehlen