PHP-FPM Problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von logifech, 4. Dez. 2012.

  1. logifech

    logifech Member

    Hallo,
    und zwarhabe ich grade ISPCOnfig 3.0.5 Installiert, funktioniert soweit super aber um das PHP-FPM feature zu tetsen woltte ich PHP-FPM etc. halt nach Installieren und da bekomme ich folgendes Problem.

    hat jemand einen Rat für mich?? System ist Debian 6 (32bit)
     
  2. logifech

    logifech Member

    Push... hat keiner einen rat?
     
  3. nowayback

    nowayback Well-Known Member

    Hi,

    Paket libapache2-mod-fastcgi ist im non-free Pfad verfügbar... bearbeite einfach deine /etc/apt/sources.list und füge an die zeile mit deb Index of / (oder welchen mirror du auch immer nimmst) hinten noch non-free an.

    php5-fpm ist, soweit ich weiß, nicht in der stable Version verfügbar... in testing und unstable jedoch schon. Hab da aber schon lange nicht mehr nachgeschaut.

    Grüße
    nwb
     
  4. logifech

    logifech Member

    Hi,
    also erstmal danke für deine Antwort! Die non free Repos und das paket von da ist aber auch Kompatibel mit den Dotdeb Repos?? hab PHP etc. alles von dotdeb bezogen
     
  5. F4RR3LL

    F4RR3LL Member

    Das verspricht eher lustig zu werden..... ich hab für obige Tests ne Debian Wheezy Kiste aufgesetzt. Hier gibts diese Probleme nicht. Da braucht man dann auch erstmal kein Dotdeb.

    Gruß Sven
     
  6. logifech

    logifech Member

    mhm Installation hat Prima funktioniert! Aber irgendwie funktioniert es nicht, wenn ich meien seite Aufrufe bekomme ich nen Server 500 Error. Wie muss ich PHP-FPM Konfigurieren?
     
  7. logifech

    logifech Member

    Ok hab es gefixt, man soltte natürlich auch php5-fpm Installiert haben ;) aber jetzt habe ich noch eine andere frage (ICh werde si ehie rPosten dmait ich nicht schon wieder nen neues Thema auf machen muss und mein Forum mit meinem müll zu Spamme) und zwar steht ja Hier in dem Tutorial beschrieben The Perfect Server - Ubuntu 12.10 (Apache2, BIND, Dovecot, ISPConfig 3) - Page 4 | HowtoForge - Linux Howtos and Tutorials das man verschiedene php versionen benutzen kann dazu Kompilliert man ja die version die man ahben möchte, ist es möglich das ich diese version die in dem Howto benutzt wird für PHP-FPM und PHP FastCGI kompillieren kann also das man beides nutzen kann?
     
  8. Till

    Till Administrator

    In PHP ist das FPM Interface ein Ersatz für das Fastcgi Interface, in einem PHP Binary kann meines Wissens nach entweder FPM oder Fastcgi aktiv sein aber nicht beides zur gleichen Zeit.
     
  9. logifech

    logifech Member

    Also würdes du mir empfhelen PHP für PHP-FPM zu Kompillieren?
     
  10. Till

    Till Administrator

    Ich würde Dir empfehlen PHP für das zu kompilieren was Du nutzen möchtest oder eben 2 PHP Binaries zu kompilieren, eines für FPM und eines für fastcgi.
     
  11. logifech

    logifech Member

    ok, danke dir:)
     

Diese Seite empfehlen