PHP funktioniert einfach nicht?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von flaggschiff, 14. Apr. 2008.

  1. flaggschiff

    flaggschiff New Member

    Hallo, ich ein Server genau auf diesem Tutorial aufgesetzt.
    Hab mich an jeden Schritt gehalten!
    Soweit funktioniert alles, außer PHP. PHP ansich läuft, aber wenn ich ein Kunde angelegt habe und ein PHP-SKript von da aufrufe, bekomm ich immer nur das PHP-Skript als Download bereitgestellt.

    Gibt es da ein bekannte Ursachen dafür?

    Wäre für schnelle Hilfe dankbar...

    So sieht der vHost des Benutzers aus:
    Code:
    <VirtualHost XX.19.215.85:80>
    ServerName paperdesign.XXXX.org:80
    ServerAdmin webmaster@XXXX.org
    DocumentRoot /srv/www/web1/web
    ServerAlias XXXX.org
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /srv/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/srv/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
    </VirtualHost>
    
    und mal das apache-error-log:
    Code:
    [Mon Apr 14 16:29:30 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon Apr 14 16:29:31 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Mon Apr 14 15:43:44 2008] [error] [client 84.19.187.129] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
    [Mon Apr 14 15:59:24 2008] [notice] SIGHUP received.  Attempting to restart
    [Mon Apr 14 15:59:26 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Mon Apr 14 15:59:35 2008] [notice] caught SIGTERM, shutting down
    [Mon Apr 14 15:59:36 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon Apr 14 15:59:36 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Mon Apr 14 16:04:31 2008] [error] [client 80.88.84.210] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
    [Mon Apr 14 16:49:51 2008] [notice] Graceful restart requested, doing restart
    [Mon Apr 14 16:49:52 2008] [warn] NameVirtualHost s10l.ibes.int:80 has no VirtualHosts
    [Mon Apr 14 16:49:52 2008] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Mon Apr 14 16:49:52 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Mon Apr 14 16:49:52 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Mon Apr 14 16:49:52 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Mon Apr 14 16:49:52 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Mon Apr 14 16:49:52 2008] [warn] long lost child came home! (pid 29232)
    [Mon Apr 14 16:49:52 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Mon Apr 14 16:49:52 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Mon Apr 14 16:52:46 2008] [error] an unknown filter was not added: PHP
    [Mon Apr 14 16:52:46 2008] [error] an unknown filter was not added: PHP
    [Mon Apr 14 16:52:58 2008] [notice] caught SIGTERM, shutting down
    [Mon Apr 14 16:52:58 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon Apr 14 16:52:58 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Mon Apr 14 16:53:07 2008] [notice] caught SIGTERM, shutting down
    [Mon Apr 14 16:53:08 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon Apr 14 16:53:08 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    
     
  2. Till

    Till Administrator

  3. flaggschiff

    flaggschiff New Member

    Danke! Hab ich gemacht. Aber geändert hat sich nix. Die PHP-Skripte gehen immernoch nicht! Woran kann es noch liegen??? Warum geht das bei allen, nur bei mir nicht? :confused:

    Hier das aktuelle error.log nach dem Neustart:
    Code:
    [Tue Apr 15 05:15:52 2008] [notice] Graceful restart requested, doing restart
    [Tue Apr 15 05:15:52 2008] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Tue Apr 15 05:15:53 2008] [notice] Apache/2.2.3 (Linux/SUSE) configured -- resuming normal operations
    [Tue Apr 15 05:15:53 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Tue Apr 15 05:15:53 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Tue Apr 15 05:15:53 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Tue Apr 15 05:15:53 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Tue Apr 15 05:15:53 2008] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Tue Apr 15 05:15:54 2008] [warn] long lost child came home! (pid 3064)
    
    
     
  4. flaggschiff

    flaggschiff New Member

    Hey. Danke! ;O) Hab die Einstellungen in IPSConfig nochmal geändert, und zack nun geht es! Danke!
     
  5. brave_snoopy

    brave_snoopy New Member

    mh welche Einstellungen hast du geändert? Ich habe das gleiche Problem.
    Obwohl beim Web php angehakt ist, geht es nicht.
     
  6. Till

    Till Administrator

    Es ist egal, welche Einstellung Du änderst. Ändere z.B. das Website quota und klick auf speichern, damit die Konfigurationsdateien neu geschrieben werden.
     
  7. flaggschiff

    flaggschiff New Member

    Einfach Punkt 2.4.3 von obrigen Post durchführen! Dann klappts! ;O)
     
  8. brave_snoopy

    brave_snoopy New Member

    habe es gemacht. nun steht bei mir addhandler. habe es auch mit addtype versucht.
    nun kommen keine fehlermeldungen mehr in der error_log. Allerdings wenn ich eine php seite aufrufe erscheint nur eine leere weiße seite. kein inhalt nichts.

    selbst wenn meine index.php nur folgendes enthält.

    Code:
    <?
    echo "hallo";
    ?>
    
    es taucht nix auf.

    Wie lässt sich dies nun erklären?
     
  9. flaggschiff

    flaggschiff New Member

    das ist komisch! addtype geht nicht. Muss auf jeden Fall addhandler dastehen! Solange wie dein php-skript nicht zum download angeboten wird, läuft php schon richtig!

    schreib mal:

    PHP:
    <?php
    echo "hallo";
    ?>
    ich glaube "short_open_tag" in der php.ini ist standardmäßig auf "Off". Stells mal auf "On" oder nutze mein Code! Sollte das das Problem sein, gewönn dich schonmal langsam an "<?php"!
     
  10. brave_snoopy

    brave_snoopy New Member

    stimmt, damit nun geht es.

    welche php.ini ist denn die richtige?

    /etc/apache2/php.ini ?

    oder eine andere?
     
  11. Till

    Till Administrator

    /etc/php5/apache2/php.ini
     
  12. flaggschiff

    flaggschiff New Member

    /etc/php5/apache2/php.ini ist die richtige!

    ups, zu spät! ;O)
     

Diese Seite empfehlen