php.ini Einstellungen gehen verloren zlib.output_compression

Dieses Thema im Forum "Server Administration" wurde erstellt von isp_geek, 4. Sep. 2015.

  1. isp_geek

    isp_geek Member

    Hi Leute,

    ich hab ein modified shop, der beim Backup und gzip mit einem Content Encoding Error den Dienst quittiert. Es gibt einen Fix der mit "zlib.output_compression = On" in der php.ini das Problem behebt. Die Änderungen in der php.ini gehen aber verloren beim speichern der Webseitenkonfiguration in ISPConfig. Habe natürlich auch das Feld php.ini befüllt, leider ohne Erfolg. Die Anweisung ist dann eben doppelt drin einmal mit Off und mit On und das geht natürlich nicht. Auch nicht, wenn ich die "Original-" Anweisung aus der php.ini auskommentiere und nur den Eintrag aus dem php.ini Feld verwende ist der gleiche Fehler drin. Es geht nur, wenn ich die Anweisung aus dem php.ini Feld rausnehme und die php.ini der Webseite direkt bearbeite und natürlich auch apache reloade ..

    Weiß jemand wie ich das hinbekomme diese Option über ISPConfig einzustellen, sodass diese funktioniert und auch permanent drin bleibt?
    Welche ist die Vorlagendatei der php.ini an die das php.ini-Feld angehängt wird?
     
  2. Till

    Till Administrator

    Einfach nur die Zeile in das php.ini Feld in isp config einfügen, funktioniert immer bei mir. Natürlich musst du den richtigen php Mode nehmen, fcgi oder fpm. Anweisungen können beliebig oft in der php.ini stehen, php verwendet immer die letzte Version, daher ist es kein Problem wenn etwas doppelt drin steht. Die Vorlage der php.ini ist die php.ini Datei des Systems.
     
  3. isp_geek

    isp_geek Member

    Hi Till, ich verwende Fast-CGI für diese Website. Anscheinend mag php genau diese Option nicht am Ende der Datei, denn wie gesagt, genau das hatte ich schon eingestellt, also Option nur einmal und am Ende der Datei und genau das ging auch nicht - echt seltsam! Noch ne Idee?


    :::
    Das ist schon echt zum Mäuse melken o_O*!('#''%=!§ ... blöder Tippfehler!
    Jetzt gehts natürlich und die Schriftart für das Feld im Admin habe ich auch umgestellt .. danke für die Hilfe!
     
    Zuletzt bearbeitet: 5. Sep. 2015

Diese Seite empfehlen