PHP.INI - upload_max_filesize wird ignoriert

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Feanwulf, 20. Sep. 2009.

  1. Feanwulf

    Feanwulf Member

    Hallo,

    hier die phpinfo.php von einem meiner Webs:
    http://www.utopic.de/phpinfo.php

    dort ist upload_max_filesize mit 2M angegeben.

    Ind er PHP.INI Datei steht aber upload_max_filesize = 8M

    Warum wird der Wert nicht übernommen? Müssen andere Vorraussetzungen esetzt sein? Ich benutze den PHP-Wrapper!
     
  2. fuxifux

    fuxifux Member

    Hallo,

    Hast du auch die php.ini im Verzeichnis: /etc/php5/cgi
    editiert? Es gibt of mehrere php.ini im System...
     
  3. Feanwulf

    Feanwulf Member

    Ja in der (wie auch in der phinfo.php) angegebenen php.ini - wie auch in der unter /cli/ und /apache2/

    Wundert mich halt - ist mir beim Upload über meine Gallery aufgefallen und war dann etwas irritiert - finde aber den Fehler nicht oder wo das begrenzt wird!
     
  4. JeGr

    JeGr Member

    Ist der Pfad, den die phpinfo ausgibt identisch mit dem, den du verändert hast (also in dem die modifizierte php.ini liegt)?
    Welche Art PHP setzt du ein?
    Kann es sein, dass du suPHP einsetzt?
     
  5. Feanwulf

    Feanwulf Member

    Da ich ja den php-wrapper nutze - ist es korrekt, dass ich suPHP verwende. Das war aber ansonsten kein Problem - Mit der Anpassung der php-wrapper Datei konnte ich aber auch kein gewünschtes Ergebnis erzielen.

    Und ist identisch ;)
     
  6. fuxifux

    fuxifux Member

    kann es sein, dass du die Parameter: post_max_size und upload_max_filesize verwechselt hast?

    post_max_size steht nämlich in der info.php auf 8M ...
     
  7. Feanwulf

    Feanwulf Member

    Nope hab ich nicht -:

    Code:
    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 8M
    
    ; Maximum size of POST data that PHP will accept.
    post_max_size = 8M
    
    so stehts in der php.ini ;) das ist ja das dilemma! Es steht drin aber will nicht!
     
  8. Feanwulf

    Feanwulf Member

    Habe mir jetzt mit ner eigenen PHP.INI Datei in dem Web geholfen:

    IM Webinterface eingetragen:

    suPHP_ConfigPath /var/www/web90/phpini/php.ini

    Und einfach die alte PHP.INI Datei rüberkopiert!

    Et Voila - funktioniert (bzw wird angezeigt) ;)
     
  9. fuxifux

    fuxifux Member

    Hast du etwas im Apache-direktiven-Feld des WEB1 von ISPConfig stehen, und wenn ja was?
     
  10. Feanwulf

    Feanwulf Member

    ja im web1 (also für die Website utopic.de) habe ich

    SetEnv Memory64 On

    stehen, damit das memoryLimit auf 64M gesetzt wird.

    Für das Wbehosting http://bilder.joerges.info habe ich nun die eigene PHP.INI verwendet und auch das SetEnv Memory64 On.
     
  11. JeGr

    JeGr Member

    Das wäre auch der Weg gewesen, den ich dir vorgeschlagen hätte. Es ist zwar keinesfalls schön, denn Änderungen an PHP musst du jetzt in den Web-spezifischen INIs immer mit berücksichtigen, aber es funktioniert. Ich hatte das Problem auch schon mit suPHP, dass INI Änderungen an der Hauptkonfiguration nicht berücksichtigt werden - warum auch immer. Eine Custom-INI hat da Abhilfe geschaffen. Noch besser hat für mich aber der Weg funktioniert, den Apachen mit dem Worker Modul MPM-ITK laufen zu lassen und statt suPHP dann wieder Mod-PHP einzusetzen :)
     

Diese Seite empfehlen