PHP Mail() funktioniert nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Huflatisch, 8. März 2013.

  1. Huflatisch

    Huflatisch Member

    Hallo

    Habe nach dieser Anleitung installiert
    Der Perfekte Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)

    Was muss ich jetzt noch unter postfix einstellen das die php mail() Funktion funktioniert.


    Fehlermeldung im syslog wäre folgende:


    Code:
    relay=mx00.gmx.net[213.165.67.114]:25, delay=0.24, delays=0.14/0.02/0.08/0.01, dsn=5.0.0, status=bounced (host mx00.gmx.net[213.165.67.114] said: 501 Syntax error in parameters or arguments (in reply to MAIL FROM command))
    

    Auf meinen alten Server funktionierten die mail Scripte problemlos





    cu
    Huflatisch
     
  2. Huflatisch

    Huflatisch Member

    Hey

    ISPconfig scheint nicht mit cannonical zu arbeiten.

    Problem ist das in der Ubuntu Postfix Standartkonfiguration an einen lokalen Absender bei php mail() , z.B. root, nicht die @domain.de rangehangen wird und deshab die Annahme bei (fast) allen Mailprovidern verweigert wird.

    Durch auskommentieren von "append_at_myorigin = no" (standart ist yes) funktioniert auch das versenden über php mail().

    Mich wundert nur das ich der einzige bin dem das aufgefallen ist. Es sollte eigendlich bei allen ISPConfig Anwendern die nach "perfekt Server" installiert haben die Einstellung unter Site/Konfiguration/systerm, die php Mail Einstellung nicht funktionieren !!!

    Kann natürlich sein das bei mir noch irgendwelche Einstellung etwas anders sind.

    cu Huflatisch
     

Diese Seite empfehlen