PHP trotz Haken nicht aktiv (ISPConfig 2)

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hahni, 5. Juni 2012.

  1. hahni

    hahni Active Member

    Obwohl der Haken für PHP aktiviert ist, wird offensichtlich der Quelltext nicht interpretiert. Woran könnte dies liegen?
     
  2. Till

    Till Administrator

    Starte mal ispconfig neu und wenn das nichts hilft dann schau nach ob es vhost dateien mit angehängtem datum gibt. das tritt dann auf wenn apache mit der neuen config nicht starten würde. Und checke auch mal ob die richtigen php open tags verwendet werden (<?php und nicht nur <?, denn die short tags sind in aktuellen php Versionen deaktiviert in der php.ini.
     
  3. hahni

    hahni Active Member

    Hallo Till,

    ISPConfig 2 habe ich neu gestartet. Das hat leider nicht den gewünschten Effekt gebracht. Im Quelltext ist zu lesen:

    --
    <?php echo "test"; ?>
    --

    Demnach sollte dies auch nicht das Problem sein. Die Konfigurationsdateien werde ich mir eben mal ansehen.

    Im Übrigen läuft folgende Konfiguration derzeit auf dem Server:

    --
    Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.24 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.6(2007-09-24) mod_ssl/2.2.8 OpenSSL/0.9.8g
    --

    In den VHosts kann ich auch keine Unregelmäßigkeiten finden. Dort finden sich folgende Einträge:

    --
    -rw-r--r-- 1 root root 60868 2012-06-04 14:29 Vhosts_ispconfig.conf
    -rw-r--r-- 1 root root 60868 2012-06-04 14:29 Vhosts_ispconfig.conf~
    --

    Viele Grüße

    Hahni
     

Diese Seite empfehlen