php Version downgrade

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Sigix, 29. Aug. 2013.

  1. Sigix

    Sigix Member

    Hallo,
    ich benötige eure Hilfe!

    Ich habe auf einem Debian wheezy system Apache (2.2.25) und php (5.4.18) händisch installiert!

    Jetzt habe ich enorme Probleme mit dieser PHP-Version und muss auf Version 5.3.xx downgraden!
    Ich habe jedoch keine Ahnung wie ich das machen muss,...... Kann mir hier wer helfen ????

    Danke im Voraus!
     
  2. Till

    Till Administrator

    Ist dass ein ispconfig server? Dann kannst Du mehrer php versionen parallel installieren und in den webseiteneinstellungen auswählen.
     
  3. Sigix

    Sigix Member

    Nein ist keiner!
    Aber mit dem parallel installieren, ist ein guter Tipp!

    Was ich bisher gemacht habe:
    ich habe folgendes umbenannt
    /usr/local/lib/php
    /usr/local/bin/php
    /usr/local/include/php
    /usr/share/php
    /usr/bin/php
    /usr/local/apache/modules/libphp5.so

    in

    /usr/local/lib/BACKUP_php
    /usr/local/bin/BACKUP_php
    /usr/local/include/BACKUP_php
    /usr/share/BACKUP_php
    /usr/bin/BACKUP_php
    /usr/local/apache/modules/BACKUP_libphp5.so


    meine binaries liegen unter
    /usr/src/php-5-4-18
    /usr/src/php-5-3-27

    nach dem umbennen, wurde die Konfiguration gestartet:
    './configure' '--with-mysql' '--enable-trans-sid' '--with-mcrypt' '--with-zlib' '--with-curl' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--enable-mbstring=all' '--enable-wddx' '--with-bz2' '--enable-soap' '--with-openssl' '--with-dom' '--enable-zip' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-imap' '--with-kerberos' '--with-imap-ssl' '--with-freetype-dir' '--with-gettext' '--with-pdo-mysql' '--enable-mbregex' '--with-gd' '--with-tidy' '--enable-intl'

    make
    make install

    Die php-version ist jetzt Version 5.3.27, jedoch habe ich folgende Fehler:

    Cannot redeclare class Date in /usr/local/lib/php/Date.php on line 124, referer: http://ph.example.com/menu/menu.php

    An was könnte dieser Fehler liegen ?

    Info: Auf einem Server wo von Anfang an php-Version 5.3.27 installiert wurde kommt dieser Fehler nicht!

    Server sind identisch, (abgesehen von der installation der php-Version)

    Was kann ich machen ???

    Danke im Voraus!
     
  4. mrairbrush

    mrairbrush Member

    Gibt es eine Anleitung zur Installation unter isp? PHP Version kleiner als 5.4?
     
  5. robotto7831a

    robotto7831a Member

  6. mrairbrush

    mrairbrush Member

    Weil ich gerade das problem habe, ich nach eine Lösung gesucht habe und das hier fand. Warum also einen neuen Thread aufmachen?
    Die Anleitung habe ich schon gefunden, sind aber mittlerweile zwecklos weil das File wget http://de.php.net/get/php-5.3.22.tar.bz2/from/this/mirror -O php-5.3.22.tar.bz2 nicht mehr existiert.
    Bekomme not found.
     
  7. robotto7831a

    robotto7831a Member

    Was hat die Installation von PHP 5.3 mit der Ursprungsfrage wie man ein Downgrade macht zu tun?

    3 Sekunden googeln und man bekommt den Link zum Download von PHP 5.3.27 als Top 1 gelistet.
     

Diese Seite empfehlen