PHP Version wechseln - Springt immer auf 5.4 zurück

Dieses Thema im Forum "Allgemein" wurde erstellt von bobbybackblech, 25. Dez. 2014.

  1. Hallo und schöne Weinachten :)
    folgendes: Ich habe PHP 5.4, 5.5 und 5.6 installiert. Die Version 5.5 ist bei mir die default Version.
    Wenn ich mich nun als Kunde einlogge und hier von 5.4 auf die Default Version ( 5.5 ) wechseln möchte klappt dies nicht. ISPConfig springt immer wieder auf 5.4 zurück, obwohl ich die default ausgewählt habe.

    Woran kann das liegen ?
     
  2. Till

    Till Administrator

    Wahrscheinlich hast Du das web as admin angelegt. Webs ide als admin un d nicht als Kunde (oder mittels "login as" ) Funktion erstellt wurden haben einen Schutz gegen Änderungen, so dass nur der admin die php version ändern kann.
     
  3. Das web habe ich als Admin angelegt ja.
    Das heisst ich muss praktisch das web als Kunde anlegen, damit die Version nicht zurück springt ?

    Kann ich das noch fixen, sodass ich die Seite nicht komplett löschen und neu anlegen muss ?

    Generell lege ich eine Seite als Admin rein, gehe dann per SSH rein und kopiere die Dateien in das Verzeichnis per wget.
    Danach gebe ich den Dateien mittels chown -R webxx:client:: * die Verzeichnisrechte.
     
    Zuletzt bearbeitet: 27. Dez. 2014

Diese Seite empfehlen