php wird nur teilweise ausgeführt

#1
hallo leute, und frohe ostern

ich habe mich nun 2 tage lang hier im forum durchgewühlt und viel nützliches gefunden was meine probleme löste, jedoch bin ich jetzt an einem punkt wo ich nichts finde, aber kann auch gut sein das ich es einfach nicht mehr peile, 2 tage, fast tag und nacht am rechner merkt man schon ;)

also, ich hab mein ispconfig soweit installiert, und hier und da noch kleine problemchen

hier geht es erstmals darum, das ich ein komisches phänomen mit php habe, und ich blick einfach nicht mehr durch woran es liegt (apache conf, suphp oder was auch immer)

also erstmal, wenn ich http://server1.meinedomain.com eingebe lande ich immer auf http://server1.meinedomain.com/apache2-default/ - weiss jetzt nicht ob das so gewünscht ist oder gut, oder wie ich das handhaben soll - frage ist, kann ich irgendwie ein host in isp config für den domain aufruf anlegen? oder wie kann ich das "am schönsten" lösen?

dann, das gröbere problem... und zwar hatte ich beim einrichten der domain vorher in ISPConfig -> Sites -> Domain -> IP-Adresse die IP meines servers vergeben, dann funktionierte alles AUSSER zugriff auf die ordner /webmail, /phpmyadmin etc
jetzt hab ich mal da statt die IP * ausgewählt, sofern habe ich nun zugriff auf /webmail /phpmyadmin etc, nur werden 0 php scripte auf meinem server ausgeführt, also ich sehe den quellcode vom script.

wie kriege ich das nun hin das beides funktioniert? also php läuft und ich zugriff auf /webmail & phpmyadmin & server1.meinedomain.com nicht auf apache2-default läuft...

bin um jeden input dankbar

apropos: debian 4.0 etch und das neuste 3.x.x ispconfig gemäss dem dafür vorgesehenen howto installiert

ps: wenn ich jetzt eine weitere domain einrichte sehe ich gerade das wenn ich auf domain2.com gehe ich immer den content von domain1.com sehe, also als ob das standart wäre.

hier die apache conf von domain2.com
<Directory /var/www/domain2.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 80.74.155.111:80>
DocumentRoot /var/www/clients/client2/web3/web

ServerName domain2.com
ServerAdmin webmaster@domain2.com

ErrorLog /var/log/ispconfig/httpd/domain2.com/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/domain2.com/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client2/web3/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>

# suphp enabled
<Directory /var/www/clients/client2/web3/web>
suPHP_Engine on
# suPHP_UserGroup web3 client2
AddHandler x-httpd-suphp .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-suphp
</Directory>
000-default conf von apache
NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>
 
Zuletzt bearbeitet:

Till

Administrator
#2
also erstmal, wenn ich http://server1.meinedomain.com eingebe lande ich immer auf http://server1.meinedomain.com/apache2-default/ - weiss jetzt nicht ob das so gewünscht ist oder gut, oder wie ich das handhaben soll - frage ist, kann ich irgendwie ein host in isp config für den domain aufruf anlegen? oder wie kann ich das "am schönsten" lösen?
das ist normal und auch korrekt so. Wenn Du über eine URL auf apache zugreifst für die keine website angelegt wurde, kommst Du auf die default Seite.

dann, das gröbere problem... und zwar hatte ich beim einrichten der domain vorher in ISPConfig -> Sites -> Domain -> IP-Adresse die IP meines servers vergeben, dann funktionierte alles AUSSER zugriff auf die ordner /webmail, /phpmyadmin etc
jetzt hab ich mal da statt die IP * ausgewählt, sofern habe ich nun zugriff auf /webmail /phpmyadmin etc, nur werden 0 php scripte auf meinem server ausgeführt, also ich sehe den quellcode vom script.

wie kriege ich das nun hin das beides funktioniert? also php läuft und ich zugriff auf /webmail & phpmyadmin & server1.meinedomain.com nicht auf apache2-default läuft...
Wenn Du mit * konfigurierst, dann musst Du auch über den Domainnamen und nicht übder die IP auf die Website zugreifen, dann geht auch PHP. da für die IP das Web ja garnicht konfiguriert ist. Wenn Du die IP Adressen für die Websites nimmst, dann musst Du Dir halt noch eine Website für phpmyadmin und webmail anlgeen und halt darüber zugreifen, da Du ja dann nicht mehr übder den Default vhost gehen kannst. Das alles ist unabhängig von ISPConfig immer so beim apache webserver.
 
#3
okay,
nun die frage, wie ist es am sinnvollsten? also ich habe das ja gemäss howto installiert und so richtig hat es bisher nicht funktioniert, bin daher ein wenig skeptisch zum ganzen und weiss jetzt nicht wie der optimale setup wäre.

überlege gerade ob ich nochmals alles von vorne machen soll

wie wären die besten schritte nochmals alles von vorne zu machen? isp deinstallieren, und ganz normal alle installierten debian packages deinstallieren und frisch anfangen?

also im prinzip den howto rückwärts?
 

Till

Administrator
#4
Das bringt nichts und soweit ich sehen kann funktioniert bei Dir auch alles korreckt. Du hast nur noch nicht verstanden das Webmail und phpmyadmin bei Debian generell über den default vhost eingebunden sindwenn Du kein eigenes web für sie anlegst. Der default vhots wird aber vom apache nur verwendet, wenn kein besserer vhost mit einer spezifischeren Konfiguration für die aktuell ankommende Anfrage existiert.

Mach einfach mal eine der optionen die ich Dir vorgeschlagen habe, dann wird es auch gehen.
 
#5
hallo

sorry für die verstpätete antwort.

grundsätzlich dachte ich das es so konfiguriert sei egal über welche domain /webmail zbsp immer aufrufbar ist.
wenn du schreibst, web für die anlegen -> also mache ich einen user, mit pfad zu diesen betroffenen ordnern und dann?

also bis jetzt hab ich das immer noch nicht zum laufen gebracht. muss ich sonst noch was beachten?
 
Zuletzt bearbeitet:

Till

Administrator
#6
grundsätzlich dachte ich das es so konfiguriert sei egal über welche domain /webmail zbsp immer aufrufbar ist.
Nein, das ist bei den Paketen der Linuxdistributionen nie der Fall.

wenn du schreibst, web für die anlegen -> also mache ich einen user, mit pfad zu diesen betroffenen ordnern und dann?
Ein Web anlegen, keinen user. Du legst ein Web an und in dieses Web kannst Du beliebige Scripte installieren. Ein Webmail Programm oder phpmyadmin sind auch nur ein script. das kopiert man da einfach rein und passt ggf. noch dessen Konfigurationsdatei an.
 
#7
okay. danke till, ich werds gleichmal probieren.

aber da sehe ich gerade das das nächste problem auftaucht. und zwar sagen wir mal wir haben 3 domains eingerichtet (ps: nur das du es weisst, hab alles nochmal frisch installiert, schritt für schritt nach der anleitung und ohne fehler)

ip server und server1.domain.com

domain1.com
domain2.com
domain3.com

ich hab als allererstes die domain1.com eingerichtet, da normale html dateien drin und das läuft per aufruf www.domain1.com
richte ich jetzt domain2.com und domain3.com ein dann wird mir immer das von domain1.com angezeigt, auch wenn ich jetzt die server ip oder server1.domain.com eingebe.

also alle neuen sites die ich einrichte zeigen immer auf domain1.com und nicht auf die eigentlich eigenen.

apache log sagt:
Code:
_default_ VirtualHost overlap on port 80, the first has precedence
ich hab auch schon das mit dem *:80 angepasst

aldo die "default" in /etc/apache2/sites-available sieht so aus
Code:
NameVirtualHost *:80
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
                # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
meine domain1.com.vhost sieht so aus

Code:
<Directory /var/www/domain1.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
    DocumentRoot /var/www/clients/client1/web1/web

    ServerName domain1.com
    ServerAdmin webmaster@domain1.com

    ErrorLog /var/log/ispconfig/httpd/domain1.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/domain1.com/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
    </Directory>

    # suphp enabled
    <Directory /var/www/clients/client1/web1/web>
        suPHP_Engine on
        # suPHP_UserGroup web1 client1
        AddHandler x-httpd-suphp .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-suphp
    </Directory>
domain2.com.vhost sieht so aus

Code:
<Directory /var/www/domain2.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/domain2.com/web

    ServerName domain2.com
    ServerAdmin webmaster@domain2.com

    ErrorLog /var/log/ispconfig/httpd/domain2.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/domain2.com/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all
            Allow from none
        </Files>
    </Directory>
    <Directory /var/www/clients/client1/web3/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all
            Allow from none
        </Files>
    </Directory>
</VirtualHost>
wie krieg ich das hin das jede domain wirklich in ihr eigenes verzeichnis schaut??? ich blick echt nicht mehr durch...
 

Till

Administrator
#8
Du musst ja auch den Domainnamen eines Webs eingeben und nicht dessen IP wenn Du es aufrufen willst. Das ist immer so bei einem apache webserver und hat mit ispconfig nichts zu tun.
 
#9
ok. vergessen wir das mit der IP....

was aber wenn ich domain2.com eingebe und der inhalt von domain1.com angezeigt wird?
domain3.com eingebe und inhalt von domain1.com angezeigt wird?

wie gesagt, es ist eine frische neue installation
 
#11
beides ausprobiert, mit oder ohne www, rechtschreibung, alles getestet. bin wie gesagt schon eien weile da dran, ging schon bei der alten installation nicht, und jetzt alles neu frisch installiert und genau das gleiche wieder

server1:/var/www# ls -al
total 24
drwxr-xr-x 6 root root 4096 Apr 15 11:03 .
drwxr-xr-x 17 root root 4096 Apr 15 11:15 ..
drwxr-xr-x 2 root root 4096 Apr 14 16:33 apache2-default
lrwxrwxrwx 1 root root 30 Apr 14 17:14 domain1.com -> /var/www/clients/client1/web1/
drwxr-xr-x 3 root root 4096 Apr 14 17:14 clients
lrwxrwxrwx 1 root root 34 Apr 14 17:04 ispconfig -> /usr/local/ispconfig/interface/web
lrwxrwxrwx 1 root root 30 Apr 15 11:03 domain2.com -> /var/www/clients/client1/web3/
drwxr-xr-x 3 root root 4096 Apr 14 17:04 php-fcgi-scripts
lrwxrwxrwx 1 root root 21 Apr 14 16:33 phpmyadmin -> /usr/share/phpmyadmin
lrwxrwxrwx 1 root root 30 Apr 14 18:48 domain3.com -> /var/www/clients/client1/web2/
drwxr-xr-x 2 root root 4096 Apr 14 16:42 webalizer
lrwxrwxrwx 1 root root 24 Apr 14 17:07 webmail -> /usr/share/squirrelmail/
 
#12
soooooo.
soweit hab ich nun einige sachen gut hinbekommen und das läuft soweit.

jetzt hab ich noch eine frage, wurde auch hier schon erwähnt. und zwar hab ich squirremail wie im howto installiert
und das liegt in /var/www/webmail/

wenn ich jetzt die server IP/webmail oder server1.example.com/webmail eingebe sehe ich den code von squirremail, also es wird nicht ausgeführt.
woran liegt das?

und kann ich über ispconfig irgendwie einrichten das ich subdomains habe wie webmail.domain1.com und das auf /var/www/webmail zugreift, also sozusagen ein zentrales webmail für alle hosts oder wie kann ich das lösen?

// Edit: kann allg. keine phpscripts ausführen. kriege diese fehlermeldung
Code:
[Thu Apr 16 10:56:09 2009] [error] [client 144.85.140.119] SecurityException in Application.cpp:440: Handler not found in configuration
[Thu Apr 16 10:56:09 2009] [error] [client 144.85.140.119] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-suphp" not found
[Thu Apr 16 10:56:09 2009] [error] [client 144.85.140.119] Premature end of script headers: phpinfo.php
[Thu Apr 16 10:56:09 2009] [error] [client 144.85.140.119] File does not exist: /var/www/clients/client1/web1/web/error/500.html
 
Zuletzt bearbeitet:

Till

Administrator
#13
und kann ich über ispconfig irgendwie einrichten das ich subdomains habe wie webmail.domain1.com und das auf /var/www/webmail zugreift, also sozusagen ein zentrales webmail für alle hosts oder wie kann ich das lösen?
Das kann prinzipiell beim apache nicht gehen, da solch ein alias immer unter den Rechten des webs ausgeführt wird und Du dann solche Probleme bekommst wie dass der php quelltext angezeigt wird.

Die einzig wirklich stabile Lösung für so etwas ist dass Du ein eigenes Web für das webmail anlegst, dort rein das squirrelmail installierst und dann für jede Deiner Domains eine subdomain webmail.domainxyz.de als aliasdomain hinzufügst.
 
#14
okay. danke till

kann ich das dann mit dem webmail den ich unter /var/www/webmail drin habe machen oder squirremail komplett neu runterladen und über diese variante machen?

dann, ist jetzt natürlich das problem das ich php ja gar nicht ausführen kann --> 500 internal server error und obige fehlermeldung im logfile.

kannst du dazu was sagen?

// Edit: obiges problem mit php gelöst. hab statt suPHP modPHP aktiviert in isp bei Sites bei der jeweiligen domain.


// Nächstes problem:
squirrelmail runtergeladen, config.pl ausgeführt, --> D --> courier --> Save --> Quit
zugriff funktioniert, aber kann mich nicht einloggen
Code:
Apr 16 13:41:17 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Apr 16 13:41:17 server1 imapd: LOGIN FAILED, user=user@domain.com, ip=[::ffff:127.0.0.1]
Apr 16 13:41:22 server1 imapd: LOGOUT, ip=[::ffff:127.0.0.1], rcvd=64, sent=332
benutze ja ISPconfig 3.x.x
wie werden die logins da gemacht?

zbsp email name@domain.com --> web1_name fürs email login?
oder nur name oder name@domain.com & passwort?
hab alle schon durchprobiert, bringt nichts

gleiche frage gilt für ftp zugang
 
Zuletzt bearbeitet:

planet_fox

Super-Moderator
#15
zbsp email name@domain.com --> web1_name fürs email login?
oder nur name oder name@domain.com & passwort?
hab alle schon durchprobiert, bringt nichts

gleiche frage gilt für ftp zugang
Bei den mails erfolgt der Login über me@howtoforge.de zBsp.

bei ftp sollte es so sein ClientnameCwebuser, ich bin mir grad nicht sicher da ich was als standard bei c ist. Da ich dies geändert habe in FTP daher ists
bei mir ClientnameFTPhowtoforge .

Kannst du emails über einen emailclient wie Thunderbird Kmail oder Outloock abrufen ?
 
#16
also so wie ich das verstanden habe, und hab auch in der ispconfig DB die emailadresse gefunden, also müsste das ja korrekt sein mit name@email.com
aber leider funktioniert es nicht, wie gesagt, kriege immer obigen fehler.

auch der abruf per outlook, thunderbird oder was auch immer funktioniert nicht.
hab alles, mit/ohne SSL, port wechseln etc probiert.
mail server läuft.

komisch ist auch das bei ispconfig -> mail -> statistics -> mailtraffic alle mailboxen 0 kb anzeigen. diese sollten ja gefüllt werden (war bei mir bei einer früheren installation zumindest so)

beim ftp muss ich gucken, hab da noch das probl. das mein ftp nicht richtig läuft, muss da noch dieses VPZ zeugs machen lassen vom hoster...
 

Till

Administrator
#17
komisch ist auch das bei ispconfig -> mail -> statistics -> mailtraffic alle mailboxen 0 kb anzeigen. diese sollten ja gefüllt werden (war bei mir bei einer früheren installation zumindest so)
Wenn Dein Mailserver nicht geht dann bleiben natürlich auch die Traffic Statistiken bei 0.

Schalte doch mal das Logging bei mysql an und schau dort mal nach was eigentlich fehl schlägt. Vielleicht kann sich courier ja garnicht erst an der mysql DB anmelden.
 
#18
sql logt bei mir nach /var/log/syslog

was rätst du ist am besten um den fehler zu lokalisieren?

hier ein auszug aus syslog:

Code:
Apr 28 14:37:35 server1 postfix/qmgr[1362]: 192F0128204: to=<meine@email.com>, relay=none, delay=1.1, delays=1.1/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)
Apr 28 14:37:36 server1 postfix/smtpd[31973]: disconnect from amc218.neoplus.adsl.tpnet.pl[83.26.58.218]
Apr 28 14:37:36 server1 courierpop3login: Disconnected, ip=[::ffff:83.228.199.91]
Apr 28 14:37:36 server1 courierpop3login: Connection, ip=[::ffff:83.228.199.91]
Apr 28 14:37:36 server1 courierpop3login: LOGIN FAILED, user=meine@email.com, ip=[::ffff:83.228.199.91]
Apr 28 14:37:41 server1 courierpop3login: Disconnected, ip=[::ffff:83.228.199.91]
Apr 28 14:37:41 server1 courierpop3login: Connection, ip=[::ffff:83.228.199.91]
Apr 28 14:37:41 server1 courierpop3login: LOGIN FAILED, user=meine@email.com, ip=[::ffff:83.228.199.91]
Apr 28 14:37:46 server1 courierpop3login: Disconnected, ip=[::ffff:83.228.199.91]
Apr 28 14:37:46 server1 courierpop3login: Connection, ip=[::ffff:83.228.199.91]
Apr 28 14:37:46 server1 courierpop3login: LOGIN FAILED, user=meine@email.com, ip=[::ffff:83.228.199.91]
Apr 28 14:37:51 server1 courierpop3login: Disconnected, ip=[::ffff:83.228.199.91]
Apr 28 14:38:01 server1 /USR/SBIN/CRON[25846]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
meine main.cf von postfix:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server1.meinedomain.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = server1.meinedomain.com, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destinatio
n
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_authenticated_header = yes
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $rel
ay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
meine master.cf

Code:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#submission inet n       -       -       -       -       smtpd
#  -o smtpd_enforce_tls=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps     inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}


amavis unix - - - - 2 smtp
        -o smtp_data_done_timeout=1200
        -o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks=127.0.0.0/8
        -o strict_rfc821_envelopes=yes
        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
        -o smtpd_bind_address=127.0.0.1
 
#19
keiner eine antwort darauf?
ich finds halt nur ein wenig schade das es doch so problematisch ist das ganze zum laufen zu bringen, obwohl es ja anscheinend problemlos laufen soll wenn man das gemäss howto macht...

ich weiss grad echt nicht wie weiter. ich weiss einfach grad nicht wo ich den fehler suchen soll, oder wie

was ich festgestellt habe, unter /var/mail/... sind nur nobody und www-data drin, also keine mailboxen wie in der mysql db von ispconfig drin steht von den einzelnen usern.

wenn die obigen fehler entstehen, liegt das an courier oder an postfix?
 
Zuletzt bearbeitet:
#20
okay jungs, gibt es hier jemanden der sich mit der materie auskennt und einen blick auf dem server werfen kann, bitte echt dringend, auch gegen bares

pn an mich bitte
 

Werbung

Top