phpmyadmin bei Zugriff download ?!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von daniel.weber, 20. Aug. 2014.

  1. daniel.weber

    daniel.weber New Member

    Hallo zusammen,

    früher konnte ich immer auf phpmyadmin zugreifen, in dem ich domain.tdl/phpmyadmin aufrufe, das klappte von allen Domains.

    Wenn ich das nun versuche, dann wird nur ein Download der index.php (aus der phpmyadmin Installation) gestartet. Für den vhost scheint also kein PHP aktiv zu sein.

    Was kann ich tun, um das Problem zu lösen?

    Vielen Dank.
     
  2. simplemodus

    simplemodus Member

    ich hab genau das selbe problem ...

    ... dürfte aufgetreten sein nachdem ich einige domains dazugenommen habe und den apache restartet habe.

    Sprich bei mir will er auch die index.php bei phpmyadmin und bei squirrelmail runterladen !

    Ich kann das irgendwie nicht nachvollziehen was da passiert ist :-//
     
    Zuletzt bearbeitet: 27. Aug. 2014
  3. simplemodus

    simplemodus Member

    /etc/apache2/conf.d/php5.conf

    <IfModule mod_php5.c>
    <FilesMatch "\.ph(p[345]?|tml)$">
    SetHandler application/x-httpd-php
    </FilesMatch>
    <FilesMatch "\.php[345]?s$">
    SetHandler application/x-httpd-php-source
    </FilesMatch>
    DirectoryIndex index.php4
    DirectoryIndex index.php5
    DirectoryIndex index.php
    </IfModule>

    vorallem an den conf hat sich nichts geändert :-/

    /etc/apache2/conf.d # ls -ltr
    total 44
    -rw-r--r-- 1 root root 822 Jan 16 2007 mailman.conf
    -rw-r--r-- 1 root root 972 Oct 29 2011 nagios.conf
    -rw-r--r-- 1 root root 709 Oct 29 2011 mod_perl.conf
    -rw-r--r-- 1 root root 1417 Nov 19 2011 awstats.conf
    -rw-r--r-- 1 root root 1583 Feb 9 2012 squirrelmail.conf
    -rw-r--r-- 1 root root 646 Feb 16 2012 apache2-manual.conf
    -rw-r--r-- 1 root root 552 Aug 29 2012 mod_suphp.conf
    -rw-r--r-- 1 root root 3315 Sep 5 2012 mod_fcgid.conf
    -rw-r--r-- 1 root root 1441 Sep 5 2012 mod_fastcgi.conf
    -rw-r--r-- 1 root root 354 Nov 14 2012 php5.conf
    -rw-r--r-- 1 root root 1065 Nov 14 2012 phpMyAdmin.conf


    /etc/apache2/conf.d # a2enmod -l
    authz_host actions alias auth_basic authz_groupfile authn_file authz_user autoindex cgi dir include log_config mime negotiation setenvif status userdir asis imagemap ssl php5 perl python authz_default suexec rewrite dav dav_fs fcgid
     
  4. simplemodus

    simplemodus Member

    Kurze Frage dazu - wo stellt man ein das die index.php als erstes gelesen wird im ispconfig ?
     
  5. Till

    Till Administrator

    Das wird in ISPConfig garnicht eingestellt sondern es wird der Default der Linux Distribution verwendet.
     
  6. simplemodus

    simplemodus Member

    Okay danke - demnach in der /etc/apache2/httpd.conf ?
     
  7. Till

    Till Administrator

    grep -r -n DirectoryIndex /etc/apache2
     
  8. simplemodus

    simplemodus Member

    Danke

    Hier der Output

    /etc/apache2/conf.d # grep -r -n DirectoryIndex /etc/apache2

    /etc/apache2/conf.d/mod_suphp.conf:9: DirectoryIndex index.php
    /etc/apache2/conf.d/mod_suphp.conf:10: DirectoryIndex index.php3
    /etc/apache2/conf.d/mod_suphp.conf:11: DirectoryIndex index.php4
    /etc/apache2/conf.d/mod_suphp.conf:12: DirectoryIndex index.php5
    /etc/apache2/conf.d/php5.conf:8: DirectoryIndex index.php
    /etc/apache2/conf.d/php5.conf:9: DirectoryIndex index.php4
    /etc/apache2/conf.d/php5.conf:10: DirectoryIndex index.php5
    /etc/apache2/httpd.conf:167:DirectoryIndex index.php index.html index.html.var


    http://www.i-i.at/squirrelmail bzw. http://www.i-i.at/phpmyadmin
    bietet er dir an die index.php zum downloaden.
     
  9. Till

    Till Administrator

    Das hat aber nichts mit dem DirectoryIndex zu tun sondern damit dass php für das Verzeichnis n dem phpmyadmin installiert ist nicht aktib ist und daher die PHP datei nicht ausgeführt wird.
     
  10. simplemodus

    simplemodus Member

    Danke - und kann man sagen wodurch das auftritt ? bzw.
    wie kann ich php sagen das es dort hingreifen soll ?

    Code:
     
    /etc/apache2 # grep -r -n '/srv/www/htdocs' /etc/apache2
     
    /etc/apache2/conf.d/mod_fastcgi.conf:39:        #FastCgiServer /srv/www/htdocs/some/path/echo.fcgi
    /etc/apache2/conf.d/phpMyAdmin.conf:1:Alias /phpMyAdmin /srv/www/htdocs/phpMyAdmin
    /etc/apache2/conf.d/phpMyAdmin.conf:2:Alias /phpmyadmin /srv/www/htdocs/phpMyAdmin
    /etc/apache2/conf.d/phpMyAdmin.conf:3:<Directory /srv/www/htdocs/phpMyAdmin>
    /etc/apache2/conf.d/phpMyAdmin.conf:13:    php_admin_value open_basedir "/srv/www/htdocs/phpMyAdmin:/var/lib/php5:/tmp:/usr/share/doc/packages/phpMyAdmin:/etc/phpMyAdmin"
    /etc/apache2/conf.d/phpMyAdmin.conf:23:<Directory /srv/www/htdocs/phpMyAdmin/libraries>
    /etc/apache2/conf.d/squirrelmail.conf:1:Alias /squirrelmail /srv/www/htdocs/squirrelmail
    /etc/apache2/conf.d/squirrelmail.conf:2:Alias /webmail /srv/www/htdocs/squirrelmail
    /etc/apache2/conf.d/squirrelmail.conf:3:<Directory "/srv/www/htdocs/squirrelmail">
    /etc/apache2/conf.d/squirrelmail.conf:10:php_admin_value open_basedir "/srv/www/htdocs/squirrelmail:/var/lib/squirrelmail:/usr/share/php5/PEAR:/tmp"
    /etc/apache2/conf.d/squirrelmail.conf:12:<Directory "/srv/www/htdocs/squirrelmail/class">
    /etc/apache2/conf.d/squirrelmail.conf:16:<Directory "/srv/www/htdocs/squirrelmail/config">
    /etc/apache2/conf.d/squirrelmail.conf:20:<Directory "/srv/www/htdocs/squirrelmail/data">
    /etc/apache2/conf.d/squirrelmail.conf:24:<Directory "/srv/www/htdocs/squirrelmail/doc">
    /etc/apache2/conf.d/squirrelmail.conf:30:<Directory "/srv/www/htdocs/squirrelmail/functions">
    /etc/apache2/conf.d/squirrelmail.conf:34:<Directory "/srv/www/htdocs/squirrelmail/help">
    /etc/apache2/conf.d/squirrelmail.conf:38:<Directory "/srv/www/htdocs/squirrelmail/include">
    /etc/apache2/conf.d/squirrelmail.conf:42:<Directory "/srv/www/htdocs/squirrelmail/locale">
    /etc/apache2/conf.d/squirrelmail.conf:46:<Directory "/srv/www/htdocs/squirrelmail/po">
    /etc/apache2/conf.d/squirrelmail.conf:50:<Directory "/srv/www/htdocs/squirrelmail/themes">
    /etc/apache2/conf.d/squirrelmail.conf:54:<Directory "/srv/www/htdocs/squirrelmail/themes/cs">
    
    denn es wurde aktiv am system nicht herumgeschraubt ausser der apache restartet da er das "FcgidMaxRequestLen 40000000" bei den Apache Direktiven im ISPCOnfig nicht nehmen wollte (trotz 15min warten) - er hats mit dem restart dann genommen.
     
  11. simplemodus

    simplemodus Member

    Code:
    /etc/apache2 # grep -r -n DocumentRoot /etc/apache2/
    /etc/apache2/sites-enabled/900-schafspelz.com.vhost:8:                                  DocumentRoot /srv/www/schafspelz.com/web
    /etc/apache2/sites-enabled/000-apps.vhost:15:    DocumentRoot /srv/www/apps
    /etc/apache2/sites-enabled/000-apps.vhost:28:    DocumentRoot /srv/www/apps
    /etc/apache2/sites-enabled/000-ispconfig.vhost:18:    DocumentRoot /srv/www/ispconfig/
    /etc/apache2/sites-enabled/000-ispconfig.vhost:33:    DocumentRoot /usr/local/ispconfig/interface/web/
    /etc/apache2/sites-enabled/100-i-i.at.vhost:8:                                  DocumentRoot /srv/www/i-i.at/web
    /etc/apache2/sites-enabled/100-kraeuter-salz.at.vhost:8:                                        DocumentRoot /srv/www/kraeuter-salz.at/web
    /etc/apache2/sites-enabled/100-neunzehn77.com.vhost:8:                                  DocumentRoot /srv/www/neunzehn77.com/web
    /etc/apache2/conf.d/apache2-manual.conf:4:# The alias provides the manual, even if you choose to move your DocumentRoot.
    /etc/apache2/sites-available/ispconfig.vhost:18:    DocumentRoot /srv/www/ispconfig/
    /etc/apache2/sites-available/ispconfig.vhost:33:    DocumentRoot /usr/local/ispconfig/interface/web/
    /etc/apache2/sites-available/i-i.at.vhost:8:                                    DocumentRoot /srv/www/i-i.at/web
    /etc/apache2/sites-available/schafspelz.com.vhost:8:                                    DocumentRoot /srv/www/schafspelz.com/web
    /etc/apache2/sites-available/neunzehn77.com.vhost:8:                                    DocumentRoot /srv/www/neunzehn77.com/web
    /etc/apache2/sites-available/apps.vhost:15:    DocumentRoot /srv/www/apps
    /etc/apache2/sites-available/apps.vhost:28:    DocumentRoot /srv/www/apps
    /etc/apache2/sites-available/kraeuter-salz.at.vhost:8:                                  DocumentRoot /srv/www/kraeuter-salz.at/web
    /etc/apache2/default-server.conf:6:[B]DocumentRoot "/srv/www/htdocs"[/B]
    /etc/apache2/default-server.conf:9:# Configure the DocumentRoot
    /etc/apache2/vhosts.d/vhost.template:19:    # DocumentRoot: The directory out of which you will serve your
    /etc/apache2/vhosts.d/vhost.template:22:    DocumentRoot /srv/www/vhosts/dummy-host.example.com
    /etc/apache2/vhosts.d/vhost.template:91:    # This should be changed to whatever you set DocumentRoot to.
    /etc/apache2/vhosts.d/vhost-ssl.template:31:    [B]DocumentRoot "/srv/www/htdocs"[/B]
    ist das mit den hochkomma so okay ?
     
  12. daben

    daben Member

    Hallo,
    ist ja schon eine weile her. Konntest du die Ursache finden? Wenn ja, weißt du noch was die Ursache war?
    Habe vermutlich ein ähnliches Problem.
    Danke!
     

Diese Seite empfehlen