phpmyadmin kein Zugriff, per Console geht?!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von chrisi99, 24. Mai 2011.

  1. chrisi99

    chrisi99 New Member

    Hallo Leute!

    ich hab nach meinem Problem mit dem Anlegen der Webverzeichnisse (dank Till schnell behoben) noch ein kleines Problem mit meinem phpmyadmin...

    vorweg: mysql läuft, per Console können auch alle angelegten User einloggen und neu angelegte Datenbanken erscheinen sofort. Ebenso funktioniert das Zugriff von auf dem Server liegende Websites, nur das Login im phpmyadmin scheitert mit der Meldung:

    Code:
    #1045 - Access denied for user [EMAIL="'xxx'@'localhost'"]'xxx'@'localhost'[/EMAIL] (using password: YES)
    In der /usr/local/ispconfig/server/lib/mysql_clientdb.conf steht das korrekte Passwort für root, ebenso habe ich der /etc/phpmyadmin/config.inc.php


    den auth_type auf cookie und die Zeilen

    Code:
    $cfg['Servers'][$i]['AllowRoot'] = TRUE;
    $cfg['Servers'][$i]['AllowNoPassword'] = FALSE;
    
    hinzugefügt... leider lässt mich pma noch immer nicht hinein :/

    weiß jemand Rat?

    LG
    Chris
     
  2. Till

    Till Administrator

    Welche Optionen hast Du beim Erstellen der Datenbank in ISPConfig ausgewählt?
     
  3. chrisi99

    chrisi99 New Member

    Type: MySQL
    Database charset: DB-Default
    Remote Access: ja
    Remote Access IPs [blank]
    Active: ja

    Die Namen habe ich sicherheitshalber ohne Unterstriche, Punkte etc gewählt!
     
  4. Till

    Till Administrator

    Das sollte ok sein. Checke mal die /etc/hosts Datei, ob dort als IP für localhost auch wirklcih die 127.0.0.1 drin steht.
     
  5. chrisi99

    chrisi99 New Member

    ja, da ist die 127.0.0.1 als localhost imho korrekt eingetragen...

    danke für deine Hilfe!

    LG
     
  6. Till

    Till Administrator

    Kannst Du Dich denn als root User in phpmyadmin einloggen?
     
  7. chrisi99

    chrisi99 New Member

    nein, nur in der Konsole, Phpmyadmin nimmt gar keinen der Logins!

    LG
     
  8. Till

    Till Administrator

    Ok, das ist schonmal gut zu wissen, denn dann ist es kein problem von ISPConfig oder den von ispconfig angelegten Datenbanken.

    Poste bitte mal die Config Datei von phpmyadmin.
     
  9. chrisi99

    chrisi99 New Member

    Nein, an sich läuft alles bisher großartig!

    Code:
     * Server(s) configuration
     */
    $i = 0;
    // The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use $cfg['Servers'][0].
    // You can disable a server config entry by setting host to ''.
    $i++;
    /* Authentication type */
    //$cfg['Servers'][$i]['auth_type'] = 'cookie';
    /* Server parameters */
    //$cfg['Servers'][$i]['host'] = 'localhost';
    //$cfg['Servers'][$i]['connect_type'] = 'tcp';
    //$cfg['Servers'][$i]['compress'] = false;
    /* Select mysqli if your server has it */
    //$cfg['Servers'][$i]['extension'] = 'mysql';
    /* Optional: User for advanced features */
    // $cfg['Servers'][$i]['controluser'] = 'pma';
    // $cfg['Servers'][$i]['controlpass'] = 'pmapass';
    /* Optional: Advanced phpMyAdmin features */
    // $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
    // $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
    // $cfg['Servers'][$i]['relation'] = 'pma_relation';
    // $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
    // $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
    // $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
    // $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
    // $cfg['Servers'][$i]['history'] = 'pma_history';
    // $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
    /*
     * End of servers configuration
     */
    /*
     * Directories for saving/loading files from server
     */
    $cfg['UploadDir'] = '';
    $cfg['SaveDir'] = '';
    
    $cfg['SuhosinDisableWarning'] = true;
    $cfg['PmaNoRelation_DisableWarning'] = true;
    $cfg['Servers'][$i]['AllowRoot'] = TRUE;
    $cfg['Servers'][$i]['AllowNoPassword'] = FALSE;
    
    Danke für deine Hilfe!

    LG
     
  10. Till

    Till Administrator

    Sieht ok aus. Ich hab bei mir nur die folgenden zeilen nicht drin:

    $cfg['SuhosinDisableWarning'] = true;
    $cfg['PmaNoRelation_DisableWarning'] = true;
    $cfg['Servers'][$i]['AllowRoot'] = TRUE;
    $cfg['Servers'][$i]['AllowNoPassword'] = FALSE;

    Kannst sie ja testweise mal auskommentieren und dann erneut versuchen Dich als root mysql user einzuloggen.

    Wenn das nichts bringt, versuch mal:

    $cfg['Servers'][$i]['host'] = 'localhost';

    zu setzen. Vielleicht ist virgendwo ein falscher host gesetzt.
     
  11. chrisi99

    chrisi99 New Member

    habs jetzt auch ohne versucht, keine Änderung...

    wirklich seltsam dieser Fehler...
     
  12. Till

    Till Administrator

    Versuch mal einen anderen Browser bzw. deaktivier Ad und Cookie Blocker in Deinem Browser, falls Du sowas verwendest. Es kann sein dass Der Browser die cookie basierten Sessions von phpmyadmin irgendwie blockt.
     
  13. chrisi99

    chrisi99 New Member

    ich habe jetzt IE, FF und Chrome versucht, da ich die gerade zur Hand habe. Cookies sind aktiviert und Popup-Blocker sicherheitshalber ausgeschaltet... aber es hilft nicht... :/

    ein sehr seltsamer Fehler, und auch scheinbar nur auf meinem Server..

    LG und ein schönes Wochenende!
     
  14. Till

    Till Administrator

    Haben andere PHP Applikationen auf dem Server ähnliche Probleme?
     

Diese Seite empfehlen