phpMyAdmin Login aus ISPConfig

#1
Moin!

Ich habe leider ein Problem.

Mein Multiserver-Setup besteht aus:

- Mainserver (CP) (Server 1)
- Mail-Server (Server 2)
- Webserver & DB (MySQL) (Server 3)

phpMyAdmin ist auf dem Server 3 installiert und erreichbar.

Im ISPConfig habe ich als phpMyAdmin URL dies eingetragen:
http://[SERVERNAME]:8081/phpMyAdmin/

Soweit ich es verstanden habe, müsste nun neben der Datenbank im CP wenn ich auf den Link klicke, sich die jeweilige phpMyAdmin Instanz auf dem Server öffnen.

Leider kommt ein Fehler:

Es öffnet sich ein neuer TAB mit der URL: https://cp.xxxxxx.de/sites/database_phpmyadmin.php?id=1

und dort steht "No DB-Server found!"

Woran könnte das liegen?

Habe schon alles durchgecheckt.. der Server 3 ist auch als Datenbankserver aktiv und dort befinden sich auch Datenbanken.

Ich hoffe ihr habt Hilfe für mich! :)

MfG Jan
 

Till

Administrator
#2
Ruf mal folgende sql query mit phpmyadmin in der ispconfig db auf dem master und poste das Ergebnis:

SELECT server_id, database_name FROM web_database WHERE database_id = 1;
 
#3
Das ist die Ausgabe:
Code:
mysql> SELECT server_id, database_name FROM web_database WHERE database_id = 1;
+-----------+---------------+
| server_id | database_name |
+-----------+---------------+
|         0 | c1_shop       |
+-----------+---------------+
1 row in set (0.00 sec)

mysql>
Vielen Dank für deine Hilfe!
 

Till

Administrator
#4
Ok. Die Datenbank hast Du über das ISPConfg Interface angelegt, oder über irgendein script z.B. per remote API? Das Problem ist dass der DB Record so nicht gültig ist und an sich auch nicht funktionieren kann, denn der Wert 0 ist nicht gültig als server_id, daher auch dre Fehler bei der phpmyadmin Umleitung.
 
#6
Habe nun als der "jeweilige Endbenutzer" die Datenbank angelegt.
Nun geht es. :)

Sehr komisch... die erste Datenbank hatte ich als Admin angelegt im Namen des Users...
 

Werbung

Top