pop3-Authentifizierung funktioniert nicht.

#1
Hallo,
nach nunmehr stundenlangem Fehler suchen und Netz durchstöbern bin ich wohl etwas betriebsblind geworden und seh gar nich mehr durch. Hier mein Problem:

Mein Server (Debian Etch, Postfix, sasl, courier-pop) musste neu aufgesetzt werden doch jetzt funktioniert die pop-Authentifizierung nicht mehr. Soweit ich das überblicken kann, stimmt die Konfiguration mit dem alten System überein (bzw. finde ich den Unterschied einfach nicht).
Mails versenden geht problemlos, bloß abrufen nicht (Meldung beim Mailclient: -ERR login failed).

Auszug aus Log:
Code:
May 22 16:22:12 serverfabrik courierpop3login: Connection, ip=[::ffff:87.171.175.197]
May 22 16:22:12 serverfabrik courierpop3login: LOGIN FAILED, user=web0p6, ip=[::ffff:87.171.175.197]
postconf -n:
Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
message_size_limit = 20480000
mydestination = localhost, $myhostname, localhost.$mydomain, $mydomain
myhostname = serverfabrik.net
mynetworks = 85.25.147.209/32, 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter =
relayhost =
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
master.cf
Code:
smtp      inet  n       -       -       -       -       smtpd
#submission inet n      -       -       -       -       smtpd
#       -o smtpd_etrn_restrictions=reject
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       -       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
relay     unix  -       -       -       -       -       smtp
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -d -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}

# only used by postfix-tls
#tlsmgr   fifo  -       -       n       300     1       tlsmgr
#smtps    inet  n       -       n       -       -       smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#587      inet  n       -       n       -       -       smtpd -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
scache    unix  -       -       -       -       1       scache
discard   unix  -       -       -       -       -       discard
smtpd.conf
Code:
saslauthd_path: /var/run/saslauthd/mux
pwcheck_method: saslauthd
mech_list: plain login
/var/run/saslauthd zeigt auf /var/spool/postfix/var/run/saslauthd

saslauthd läuft auch - getestet mit:
Code:
testsaslauthd -u user -p password -f /var/spool/postfix/var/run/saslauthd/mux
0: OK "Success."
Ich hab auch postfix schon komplett entfernt und nach dem tutorial http://www.howtoforge.de/howto/das-perfekte-setup-debian-etch-40/5/ neu aufgesetzt... Das Ergebnis bleibt das selbe.

Jetzt weiß ich nicht mehr weiter und hoffe, dass mir hier jemand den richtigen Tipp geben kann...

Grüße,
Unique
 
Zuletzt bearbeitet:

Till

Administrator
#2
Postfix und die von Dir gesposteten Config Dateien sind für (smtp) und haben mit pop3 und courier erstmal nichts zu tun. Schau Doch mal in ads Verzeichnis /etc/courier, dort findest Du die Courier Konfigurationsdateien.
 
#3
hab das Problem gefunden.
Auf dem alten server lief qpopper mit mailbox - courier-pop hat allerdings maildir erwartet.
Nachdem ich das Loglevel von courier-pop hochgeschraubt hatte, stand dann auch ein Hinweis in den Logs, den man deuten kann (Fehler beim Verzeichniswechsel).
Confixx liefert ein Tool mit, um die Konvertierung vorzunehmen (~/confixx/admin/contrib/convert_mb2md.pl) - man muss nur erstmal wissen, dass man es benutzen muss ;)
 

Werbung

Top