pop3 dienst offline

#1
Hallo erstmal...
Bei meiner isp Installation ist (und bleibt) der POP3 Dienst offline
System ist nen Suse 10.2 installiert nach anleitung.Weiß echt nicht weiter...
bin aber auf E-Mail und webmail angewiesen.Danke für hilfe!!
Schnorres
 
#3
Dienst ist online :)

also es läuft .... hab die email dienste per ssh nochmal gestartet
webmail läuft auch jetzt habe ich nur noch das prob das versenden fehlgeschlagen ist hier doch noch mal netstat -tap


tcp 0 0 *:mysql *:* LISTEN 26705/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 2778/portmap
tcp 0 0 localhost:novell-zen *:* LISTEN 3038/zmd
tcp 0 0 *:hosts2-ns *:* LISTEN 5016/ispconfig_http
tcp 0 0 heiko345.heiko-k:domain *:* LISTEN 15378/named
tcp 0 0 localhost:domain *:* LISTEN 15378/named
tcp 0 0 *:ftp *:* LISTEN 5871/proftpd: (acce
tcp 0 0 localhost:ipp *:* LISTEN 2841/cupsd
tcp 0 0 localhost:953 *:* LISTEN 15378/named
tcp 0 0 *:smtp *:* LISTEN 15280/master
tcp 1 0 localhost:novell-zen localhost:22377 CLOSE_WAIT -
tcp 1 0 localhost:novell-zen localhost:24872 CLOSE_WAIT -
tcp 0 0 heiko345.heik:hosts2-ns 195.135.149.138:56363 TIME_WAIT -
tcp 0 0 localhost:7602 localhost:imap TIME_WAIT -
tcp 1 0 localhost:novell-zen localhost:23163 CLOSE_WAIT -
tcp 0 0 *:imaps *:* LISTEN 6320/couriertcpd
tcp 0 0 *:pop3s *:* LISTEN 6295/couriertcpd
tcp 0 0 *:pop3 *:* LISTEN 8057/couriertcpd
tcp 0 0 *:imap *:* LISTEN 8072/couriertcpd
tcp 0 0 *:www-http *:* LISTEN 5125/httpd2-prefork
tcp 0 0 *:ssh *:* LISTEN 3268/sshd
tcp 0 0 localhost:ipp *:* LISTEN 2841/cupsd
tcp 0 0 localhost:953 *:* LISTEN 15378/named
tcp 0 0 *:smtp *:* LISTEN 15280/master
tcp 0 0 *:https *:* LISTEN 5125/httpd2-prefork

Sieht mir aber nach zu vielen offenen ports aus??
Danke Schnorres
 
#4
Kann jetzt aber nichts empfangen....

bekomme wen ich was an einen angelegten user senden will folgende meldung:550 5.1.1 <*****@*******.de>: Recipient address rejected: User unknown in local recipient table
Habe user angelegt im ispconfig ....
ach ja senden geht auch noch nicht ...
Danke für eure hilfe ....
schnorres
 

Till

Administrator
#5
Hat die Webseite eine co-domain mit der selben haupt-domain wie die websiete aber leerem hostnamen? Wenn nicht, dann lege sie an.

Poste bitte mal die exakten Fehlermeldungen aus dem Mail log, da pop3 und smtp bei Dir laufen. Oder aber, Du hast Due Firewall von SuSE aus Versehen eingeschaltet.
 
#6
co-domain

Morgen Till
co-domain ist vorhanden.
Auszug aus der /var/log/mail:

Feb 13 10:05:06 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 13 10:05:06 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 13 10:05:06 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time
=0
habe diesen fehler gefunden

Feb 13 10:04:00 heiko345 postfix/postmap[28161]: fatal: open database /etc/postfix/virtusertable.db: No such file or direc
tory

und diesen:
Feb 13 09:51:45 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 13 09:51:45 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 13 09:51:46 heiko345 imapd: Failed to create cache file: maildirwatch (web1_heiko)
Feb 13 09:51:46 heiko345 imapd: Error: Input/output error
Feb 13 09:51:46 heiko345 imapd: Check for proper operation and configuration
Feb 13 09:51:46 heiko345 imapd: of the File Access Monitor daemon (famd).
Feb 13 09:51:46 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=429, sent=228, ti
me=1

Die Firewall ist offen kann auch mit nem telet auf 25 mit dem postfix von außen reden..
und das senden intern untereinander funktioniert auch nicht..
schnorres
 
#7
Bringt es was Perfect Setup nochmal auszuführen???

Guten Morgen ......
Wenn Ich so viele Probs habe ist es sinvoll einfach das perfect setup nochmal auszuführen ?
Meinte mit bestehender Suse Installation da Rechner im Rechenzentrum steht
Oder besser komplette Neuinstallation??
Danke für Anregungen
Schnorres
 
#9
Keine Fehler

servus Till

Ich habe keine Fehler Gefunden nur einen Warn (Warnung) die aber auf mein Prob passen könnte:
13.02.2008 - 18:46:03 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable

Den habe ich einige male.


Schnorres
 

Till

Administrator
#10
Ok, probier bitte mal Folgendes:

1) Lösche den User web1_heiko, warte eine Minute und lösche ihn dann aus dem Papierkorb.
2) Lösch die Datei ispconfig.log
3) Lege den User web1_heiko neu an. Wenn das Postfach dann immer noch nicht geht, poste den Inhalt der Datei ispconfig.log
 
#11
ispconfig.log

Danke erstmal für deine Hilfe
So Hier mal das log:

14.02.2008 - 10:37:57 => INFO - USER:
web1_heiko:x:10003:10001:heiko kanitz:/srv/www/web1:/bin/bash
14.02.2008 - 10:37:57 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 661: cp -fr /root/ispconfig/isp/user_standard_index.html_de /srv/www/we
b1/user/web1_heiko/web/index.html
14.02.2008 - 10:37:57 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 717: setquota -u web1_heiko 0 0 0 0 -a &> /dev/null
14.02.2008 - 10:37:57 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 718: setquota -T -u web1_heiko 604800 604800 -a &> /dev/null
14.02.2008 - 10:37:57 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 57: cp -f /root/ispconfig/isp/conf/forward.master /
srv/www/web1/.forward
14.02.2008 - 10:37:57 => INFO - maildirmake /srv/www/web1/user/web1_heiko/Maildir &> /dev/null, Line 106: maildirmake /srv/www/web1/user/web1_heiko/Mail
dir &> /dev/null
14.02.2008 - 10:37:57 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 113: symlink /srv/www/web1/Maildir
14.02.2008 - 10:37:58 => INFO - chown web1_heiko:web1 /srv/www/web1/user/web1_heiko/.spamassassin
14.02.2008 - 10:37:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postf
ix/local-host-names~
14.02.2008 - 10:37:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/
virtusertable~
14.02.2008 - 10:37:59 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/vi
rtusertable
14.02.2008 - 10:37:59 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1259: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vho
sts/Vhosts_ispconfig.conf~
14.02.2008 - 10:37:59 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
14.02.2008 - 10:37:59 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
14.02.2008 - 10:37:59 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1984: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
 

Till

Administrator
#13
Poste mal den Inhalt von /etc/postfix/virtusertable und /etc/posfix/local-host-names sowie die aktuellen Zeieln von Deinem letzten Sendeversuch aus dem mail log file.
 
#14
postfix

Erstmal die Postfix/virtusertable
###################################
#
# ISPConfig virtusertable Configuration File
# Version 1.0
#
###################################
heiko@www.heiko-kanitz.de web1_heiko
web1_heiko@www.heiko-kanitz.de web1_heiko
heiko@heiko-kanitz.de web1_heiko
web1_heiko@heiko-kanitz.de web1_heiko
heiko@heiko345.heiko-kanitz.de web1_heiko
web1_heiko@heiko345.heiko-kanitz.de web1_heiko
heiko@www.cdt-kanitz.de web3_heiko
web3_heiko@www.cdt-kanitz.de web3_heiko
heiko@mail.cdt-kanitz.de web3_heiko
web3_heiko@mail.cdt-kanitz.de web3_heiko
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

dann
###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
heiko345.heiko-kanitz.de
localhost.heiko345.heiko-kanitz.de
localhost.heiko-kanitz.de
localhost.localdomain
www.heiko-kanitz.de
www.martina-oed.de
www.cdt-kanitz.de
www.frankensupport24.de
heiko-kanitz.de
martina-oed.de
mail.cdt-kanitz.de
frankensupport24.de
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
und was langes ...

Feb 14 10:46:47 heiko345 postfix/smtpd[30976]: NOQUEUE: reject: RCPT from unknown[189.17.79.141]: 550 5.1.1 <info@heiko-kanitz.de>: Recipient address re
jected: User unknown in local recipient table; from=<Ahlstichvjyd@fastmail.fm> to=<info@heiko-kanitz.de> proto=SMTP helo=<fastmail.fm>
Feb 14 10:46:47 heiko345 postfix/smtpd[30976]: lost connection after RCPT from unknown[189.17.79.141]
Feb 14 10:46:47 heiko345 postfix/smtpd[30976]: disconnect from unknown[189.17.79.141]
Feb 14 10:47:25 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 14 10:47:25 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 14 10:47:25 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time=0
Feb 14 10:48:25 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 14 10:48:25 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 14 10:48:25 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time=0
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: warning: cannot get certificate from file /etc/postfix/ssl/smtpd.crt
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: warning: TLS library problem: 31030:error:02001002:system library:fopen:No such file or directory:bss_fil
e.c:352:fopen('/etc/postfix/ssl/smtpd.crt','r'):
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: warning: TLS library problem: 31030:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:354:
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: warning: TLS library problem: 31030:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system
lib:ssl_rsa.c:720:
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: cannot load RSA certificate and key data
Feb 14 10:49:46 heiko345 postfix/smtpd[31030]: connect from dslb-082-083-037-231.pools.arcor-ip.net[82.83.37.231]
Feb 14 10:49:48 heiko345 postfix/smtpd[31030]: warning: support for restriction "check_relay_domains" will be removed from Postfix; use "reject_unauth_d
estination" instead
Feb 14 10:49:48 heiko345 postfix/smtpd[31030]: NOQUEUE: reject: RCPT from dslb-082-083-037-231.pools.arcor-ip.net[82.83.37.231]: 550 5.1.1 <heiko@heiko-
kanitz.de>: Recipient address rejected: User unknown in local recipient table; from=<unukalhaii85@hendricks-family.de> to=<heiko@heiko-kanitz.de> proto=
ESMTP helo=<micha-7fef63828>
Feb 14 10:49:49 heiko345 postfix/smtpd[31030]: disconnect from dslb-082-083-037-231.pools.arcor-ip.net[82.83.37.231]
Feb 14 10:51:25 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 14 10:51:25 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 14 10:51:25 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time=0
Feb 14 10:52:25 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 14 10:52:25 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 14 10:52:25 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time=0
Feb 14 10:53:09 heiko345 postfix/anvil[30978]: statistics: max connection rate 1/60s for (smtp:189.17.79.141) at Feb 14 10:46:45
Feb 14 10:53:09 heiko345 postfix/anvil[30978]: statistics: max connection count 1 for (smtp:189.17.79.141) at Feb 14 10:46:45
Feb 14 10:53:09 heiko345 postfix/anvil[30978]: statistics: max cache size 1 at Feb 14 10:46:45
Feb 14 10:53:25 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 14 10:53:25 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 14 10:53:25 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time=0
Feb 14 10:54:25 heiko345 imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 14 10:54:25 heiko345 imapd: LOGIN, user=web1_heiko, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 14 10:54:25 heiko345 imapd: LOGOUT, user=web1_heiko, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=25, sent=180, time=0
/var/log/mail lines 1045-1078/1078 (END)
danke!!!!!!!!!!!!!!!!!!
 

Till

Administrator
#15
Das ist soweit alles ok. Sie bitte mal nach, ob Du die Folgenden beiden Zeilen in der datei /etc/postfix/main.cf hast.

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

Wenn nicht, füge sie hinzu und starte Postfix neu.
 
#16
Waren beide Zeilen drin...

Also beide Zeilen vorhanden

hier doch mal die komplette datei:
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
mynetworks_style = subnet
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = example.com
mynetworks = 127.0.0.0/8
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Schnorres
PShab postfix mal neu gestartet hat nichts gebracht :
geht immer noch nicht
 
#19
Netstat -tap

Guten Morgen

Die Probs die ich habe kann das irgendetwas mit der hardware zu tun haben?
Ist ein IBM 345 xserver

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 2382/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 2798/portmap
tcp 0 0 localhost:novell-zen *:* LISTEN 3191/zmd
tcp 0 0 *:hosts2-ns *:* LISTEN 3306/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 17426/proftpd: (acc
tcp 0 0 heiko345.heiko-k:domain *:* LISTEN 4932/named
tcp 0 0 localhost:domain *:* LISTEN 4932/named
tcp 0 0 localhost:ipp *:* LISTEN 3268/cupsd
tcp 0 0 localhost:951 *:* LISTEN 3319/famd
tcp 0 0 *:smtp *:* LISTEN 27534/master
tcp 0 0 localhost:953 *:* LISTEN 4932/named
tcp 0 0 localhost:smtp localhost:corelccam TIME_WAIT -
tcp 0 0 *:imaps *:* LISTEN 2928/couriertcpd
tcp 0 0 *:pop3s *:* LISTEN 3141/couriertcpd
tcp 0 0 *:pop3 *:* LISTEN 14481/couriertcpd
tcp 0 0 *:imap *:* LISTEN 14464/couriertcpd
tcp 0 0 *:www-http *:* LISTEN 3611/httpd2-prefork
tcp 0 0 *:ssh *:* LISTEN 3254/sshd
tcp 0 0 localhost:ipp *:* LISTEN 3268/cupsd
tcp 0 0 *:smtp *:* LISTEN 27534/master
tcp 0 0 localhost:953 *:* LISTEN 4932/named
tcp 0 0 *:https *:* LISTEN 3611/httpd2-prefork
tcp 0 2816 heiko345.heiko-kani:ssh pd95b44dd.dip0.t-i:4337 ESTABLISHED 27423/0
heiko345:~ #

Schnorres
 

Till

Administrator
#20
Mit der Hardware hat das vermutlich nichts zu tun und die Audgaben und Config dateien sind soweit ok. Möglicherweise ist eine Neuinstallation doch der schnellste Weg, das Problem zu lösen. Du solltest bei Deinem Hoster wenn Möglich ein minimal Linux image als Ausgangspunkt nehmen und kein lamp image. Außerdem würde ich Dir zu Debian anstatt SuSE raten, falls Dein Hoster das anbietet. Debian ist im Allgemeinen unproblematischer bei der Installation und im Betrieb als OpenSuSE.
 

Werbung

Top