Postfix, Courier, MySQL And SquirrelMail (Debian Wheezy)

#1
Schönen Guten Tag,

und zwar bin ich nach langem suchen auf diese Seite gestoßen in der ich das HowTo -> Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Wheezy). Und die Installation lief bisher ohne Probleme soweit durch....

Nun zu meinem Problem... Zum schluss wurde SquirrelMail nach dem Tutorial installiert. Und zuerst konnte ich mich nicht einloggen und fand heraus wenn keine Mail vorliegt zumindest beim ersten Login dann setzt der IMAP die Anfrage zurück. Soweit so gut... Habe unten demnach im Code eine Mail gesendet und sie kam zumindest auch nicht zurück zum Ursprung...

Code:
Jul  7 23:14:19 vmd3286 postfix/smtpd[29122]: connect from mail-la0-f41.google.com[209.85.215.41]
Jul  7 23:14:20 vmd3286 postfix/smtpd[29122]: 498C03C0BB1: client=mail-la0-f41.google.com[209.85.215.41]
Jul  7 23:14:20 vmd3286 postfix/cleanup[29129]: 498C03C0BB1: message-id=<CAB3=6ZdxiBpPEhMTMfFcLLRfUgLcDqQLcWWCp3-+2iwwZWpYAw@mail.gmail.com>
Jul  7 23:14:20 vmd3286 postfix/qmgr[28018]: 498C03C0BB1: from=<Adresse_des_Absenders@gmail.com>, size=1788, nrcpt=1 (queue active)
Jul  7 23:14:20 vmd3286 postfix/smtpd[29122]: disconnect from mail-la0-f41.google.com[209.85.215.41]
Jul  7 23:14:25 vmd3286 postfix/smtpd[29134]: connect from localhost[127.0.0.1]
Jul  7 23:14:25 vmd3286 postfix/smtpd[29134]: 02F5B3C0BB3: client=localhost[127.0.0.1]
Jul  7 23:14:25 vmd3286 postfix/cleanup[29129]: 02F5B3C0BB3: message-id=<CAB3=6ZdxiBpPEhMTMfFcLLRfUgLcDqQLcWWCp3-+2iwwZWpYAw@mail.gmail.com>
Jul  7 23:14:25 vmd3286 postfix/qmgr[28018]: 02F5B3C0BB3: from=<Adresse_des_Absenders@gmail.com>, size=2313, nrcpt=1 (queue active)
Jul  7 23:14:25 vmd3286 postfix/smtpd[29134]: disconnect from localhost[127.0.0.1]
Jul  7 23:14:25 vmd3286 amavis[21075]: (21075-02) Passed CLEAN {RelayedInbound}, [209.85.215.41]:60359 [209.85.215.41] <Adresse_des_Absenders@gmail.com> -> <Empfänger@domain.de>, Queue-ID: 498C03C0BB1, Message-ID: <CAB3=6ZdxiBpPEhMTMfFcLLRfUgLcDqQLcWWCp3-+2iwwZWpYAw@mail.gmail.com>, mail_id: iSCBnHDdrbTN, Hits: -0.689, size: 1788, queued_as: 02F5B3C0BB3, 4629 ms
Jul  7 23:14:25 vmd3286 postfix/smtp[29130]: 498C03C0BB1: to=<Empfänger@domain.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=4.8, delays=0.15/0/0.01/4.6, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 02F5B3C0BB3)
Jul  7 23:14:25 vmd3286 postfix/qmgr[28018]: 498C03C0BB1: removed
Jul  7 23:14:25 vmd3286 postfix/virtual[29137]: 02F5B3C0BB3: to=<Empfänger@domain.de>, relay=virtual, delay=0.04, delays=0.01/0.02/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)
Jul  7 23:14:25 vmd3286 postfix/qmgr[28018]: 02F5B3C0BB3: removed
Wenn ich nun tippen würde...ist sie angekommen. Aber woran es nun hapert... ich will mich in SquirrelMail einloggen und dann kommt in der Mail.log dies...

Code:
Jul  7 23:19:35 vmd3286 imapd: Connection, ip=[::1]
Jul  7 23:19:35 vmd3286 imapd: LOGIN, user=Empfänger@domain.de, ip=[::1], port=[39230], protocol=IMAP
Jul  7 23:19:35 vmd3286 imapd: LOGOUT, user=Empfänger@domain.de, ip=[::1], headers=0, body=0, rcvd=30, sent=392, time=0
Und im Browser kommt dies...

Code:
Serverfehler
Beim Abrufen von http://domain.de/squirrelmail/src/webmail.php ist auf der Website ein Fehler aufgetreten. Möglicherweise wird sie gerade gewartet oder ist falsch konfiguriert.
Vorschläge:
Laden Sie diese Webseite später erneut.
HTTP-Fehler 500 (Internal Server Error): Beim Versuch des Servers, die Anforderung zu verarbeiten, ist eine unerwartete Bedingung aufgetreten.
Ich bin nun nochmal extra das ganze durch gegangen... ob ich vllt. irgendwo einen Schritt vergessen habe... aber bisher keine Ahnung...

Hängt es damit zusammen wie ich im Forum fand "Wenn SquirrelMail" nicht im "/var/www/" ordner liegt das es nicht funktioniert? Aber im Tutorial wurde dies nicht erwähnt...?!?

Bin nicht wirklich ein Pro in Linux... aber ich kämpf mich nach und nach durch...

Wäre schön wenn mir vllt. jemand helfen kann?

mfg sorgente ;)

PS: was ich noch anhängen kann.... wenn ich configtest aufrufen will...dann kommt nur "kein access"...
 
Zuletzt bearbeitet:
#3
access.log
Code:
ip - - [08/Jul/2013:21:00:49 +0200] "GET /squirrelmail/src/login.php HTTP/1.1" 200 1994 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.4.0.0 Safari/537.11"
ip - - [08/Jul/2013:21:00:49 +0200] "GET /favicon.ico HTTP/1.1" 404 510 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.4.0.0 Safari/537.11"
ip - - [08/Jul/2013:21:07:20 +0200] "POST /squirrelmail/src/redirect.php HTTP/1.1" 302 2228 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.4.0.0 Safari/537.11"
ip - - [08/Jul/2013:21:07:20 +0200] "GET /squirrelmail/src/webmail.php HTTP/1.1" 500 705 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.4.0.0 Safari/537.11"
error.log
Code:
[Mon Jul 08 21:24:45 2013] [notice] Graceful restart requested, doing restart
[Mon Jul 08 21:24:45 2013] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u2 configured -- resuming normal operations
[Mon Jul 08 21:25:41 2013] [notice] caught SIGTERM, shutting down
[Mon Jul 08 21:25:42 2013] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u2 configured -- resuming normal operations
[Mon Jul 08 21:25:50 2013] [notice] caught SIGTERM, shutting down
[Mon Jul 08 21:25:52 2013] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u2 configured -- resuming normal operations
[Mon Jul 08 21:25:58 2013] [error] [client ip] client denied by server configuration: /usr/share/squirrelmail/src/configtest.php
[Mon Jul 08 21:25:58 2013] [error] [client ip] File does not exist: /var/www/favicon.ico
[Mon Jul 08 21:26:01 2013] [error] [client ip] File does not exist: /var/www/favicon.ico
[Mon Jul 08 21:26:02 2013] [error] [client ip] File does not exist: /var/www/favicon.ico
[Mon Jul 08 21:26:04 2013] [error] [client ip] File does not exist: /var/www/favicon.ico
das ist was drin steht... Irgendwelche Ideen?
 
#5
das problem ist da steht nix zur selben zeit... kann es an dem change_sql liegen? hab nur manche gelesen die damit probleme haben das es nach dem Login klick eine weisse seite gibt...

mfg
 
#6
Hallo sorgente,

Schau mal bitte in /usr/share/squirrelmail/plugins/change_sqlpass/config.php.

Überprüfen einmal ob da nicht eine Klammer, ein Semikolon oder sonstiges zuviel oder zuwenig ist.

Hatte das gleiche Problem und aufgrund obigem den Fehler in dieser Datei gefunden.

MFG
 

Werbung

Top