Postfix / Dovecot kein senden und Empfangen

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von bobbln, 7. Dez. 2012.

  1. bobbln

    bobbln New Member

    Hallo,

    ich bekomme den Mailserver nicht zum laufen.

    Aus der Mail.log:
    Code:
    Dec  7 08:30:01 SERVERNAME dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Dec  7 08:30:01 SERVERNAME dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Dec  7 08:30:01 SERVERNAME postfix/smtpd[30768]: connect from localhost[127.0.0.1]
    Dec  7 08:30:01 SERVERNAME postfix/smtpd[30768]: lost connection after CONNECT from localhost[127.0.0.1]
    Dec  7 08:30:01 SERVERNAME postfix/smtpd[30768]: disconnect from localhost[127.0.0.1]
    
    Der SERVERNAME steht auch so drin und nicht SERVERNAME.DOMAIN.TLD

    Weiter oben in der Mail.log

    Code:
    Dec  7 08:28:30 SERVERNAME dovecot: lda(root): Error: chdir(/root) failed: Permission denied
    Dec  7 08:28:30 SERVERNAME dovecot: lda(root): Error: user root:  Initialization failed: Initializing mail storage from mail_location  setting failed: stat(/root/Maildir) failed: Permission denied  (euid=65534(nobody) egid=65534(nogroup) missing +x perm: /root, dir  owned by 0:0 mode=0700)
    Dec  7 08:28:30 SERVERNAME dovecot: lda(root): Fatal: Invalid user settings. Refer to server log for more information.
    Dec  7 08:28:30 SERVERNAME dovecot: lda(root): Error: chdir(/root/)  failed: Permission denied (euid=65534(nobody) egid=65534(nogroup)  missing +x perm: /root, dir owned by 0:0 mode=0700)
    
    System:
    Ubuntu 12.04 LTS
    MySQL
    Nginx
    Pure-FTP
    Postfix
    Dovecot
    Getmail
    ISPConfig 3.0.4
    Quota

    Alles frisch installiert. Es läuft auch alles (Web,FTP), bis auf der Mailserver. Die Anmeldedaten sind in der MySQL DB gespeichert und stehen auch drin.
    Ich habe schon mehrmals neuinstalliert und sämtliche Forum durchwühlt, aber kein Lösungsansatz gefunden.

    Die Ports 143 und 993 sind von aussen ereichbar. Port 25 nicht.
    In der Postfix.conf sind die entsprechenden Stellen auskommentiert.

    Ich denke das die Verbindung Dovecot, Postfix, MySQL gestört ist.

    Als grobe Anleitung habe ich das hier benutzt:
    Der Perfekte Server - Ubuntu 11.10 mit nginx

    Amavis, Clamav etc habe ich jetzt erstmal weggelassen.

    Schön Gruß

    Bob
     
  2. Till

    Till Administrator

    Dann wird Dein Mailsystem auch nicht funktionieren, denn amavis und clamav sind Systemvoraussetzunfen von ispconfig und sie müssen vor der ISPConfig Installation installiert werden.
     
  3. bobbln

    bobbln New Member

    Das Mailsystem funktioniert jetzt. Das Problem war das; Der Apt-Get Befehl sich irgendwie verschluckt hat. Der hier.
    Code:
    apt-get install postfix postfix-mysql postfix-doc mysql-client  mysql-server openssl getmail4 rkhunter binutils dovecot-imapd  dovecot-pop3d dovecot-mysql dovecot-sieve sudo
    Danach sollte das ROOT Passwort eingeben werden und dann,
    Code:
    General type of mail configuration: <-- Internet Site
    System mail name: <-- server1.example.com
    Und genau diese beiden Fragen wurden nicht gestellt. Scheint aber an meinen Rooti zu liegen.

    Ein
    Code:
    dpkg-reconfigure postfix 
    und das mailsystem läuft erstmal.

    Wo steht das? Das habe ich nur für Jailkit gelesen, das es auf jeden Fall vor der ISPConfig Installtion gemacht werden soll.

    Kann man nun Amavis und clamav weglassen oder nicht? Amavis soll ja ein wenig Leistungshungrig sein.

    Jetzt kämpfe ich nur noch mit diesem Problem
    Code:
    Dec 14 12:03:57 MEIN_SERVER dovecot: lda(root): Error: chdir(/root) failed: Permission denied
    Dec 14 12:03:57 MEIN_SERVER dovecot: lda(root): Error: user root: Initialization failed: Initializing mail storage from mail_location setting failed: stat(/root/Maildir) failed: Permission denied (euid=65534(nobody) egid=65534(nogroup) missing +x perm: /root, dir owned by 0:0 mode=0700)
    Dec 14 12:03:57 MEIN_SERVER dovecot: lda(root): Fatal: Invalid user settings. Refer to server log for more information.
    Ist ein Rechte Problem, nur weiß ich gerade nicht wo ich ansetzen soll. Also wo ich einstelle, das die Emails an root, in ein beliebes meiner Postfächer geschickt wird.

    Schön Gruß

    Bob
     

Diese Seite empfehlen