Postfix Fragen/Probleme

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von MHK, 2. Apr. 2009.

  1. MHK

    MHK New Member

    Hallo,

    erstmal großes Lob an das ISPConfig Projekt ;)
    Ich habe einen vServer mit Debian Lenny und ISPConfig2 (Version 2.2.30) eingerichtet.
    Eigentlich funktioniert soweit alles, nur sind mir ein paar *schönheitsfehler* aufgefallen welche aber auch durch mich verursacht sein könnten.

    1) eMail Adressen
    in der Datei /etc/postfix/virtusertable stehen ja alle konfigurierten email-Adressen drin. jedoch steht jede Adresse bei mir dort 4 mal drin.
    Bsp:
    Adrssse lautet: postmaster@mydomain.de
    und geht an User: web1
    Dann steht die 4 mal drin:
    postmaster@www.mydomain.de web1
    web1@www.mydomain.de web1
    postmatser@mydomain.de web1
    web1@mydomain.de web1
    Mir würde es reichen wenn Sie einmal drin steht, stören tuen mich aber eigentlich nur die *@www.* Sachen welche da immer mit angelegt werden. Kann man das irgendwo einstellen das das unterbunden wird?

    2)Umschreibung der Empfänger
    Ich weiß nicht warum, also ob ich etwas falsch gemacht habe aber alle ankommenden eMails werden umgeschrieben. Das Zeigt sich folgendermaßen: an postmaster@mydomain.de wird eine email geschickt, der Postfix wandelt aber den Empfänger um in web1@myhostname.de und schreibt das ursprüngliche To in orig_to. Im Postfix Log steht dann das folgende:
    Code:
    Apr  2 13:38:27 myname postfix/local[9734]: 4556FA86800C: to=<web1@myhostname.de>, orig_to=<postmaster@mydomain.de>, relay=local, delay=7.6, delays=0.14/0.01/0/7.5, dsn=2.0.0, status
    
    anbei mal die postfix Konfiguration (Ausgabe von postconf -n):
    Code:
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    home_mailbox = Maildir/
    inet_interfaces = all
    inet_protocols = ipv4
    mailbox_command =
    mailbox_size_limit = 0
    message_size_limit = 102400000
    mydestination = /etc/postfix/local-host-names
    myhostname = myhostname.de
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    myorigin = /etc/mailname
    readme_directory = no
    recipient_delimiter = +
    relayhost =
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    
    Ich hätte es schon gern das dann auch beim Empfänger im Postfach/eMail Programm bei To sein richtiger name angezeigt wird.
    Ich dachte erst das es an dem "mydestination" Parameter liegt und habe diesen aktuell Deaktiviert, aber da hat sich auch nix gebessert. Vielleicht hat noch jemand eine Idee was ich falsch gemacht habe?

    MfG MHK
     
  2. Feanwulf

    Feanwulf Member

    Zu 1)
    In deinen Webs und Co-Domains überall EXTERNER MAILSERVER eintragen, wenn keine E-Mails angenommen werden sollen.
     
  3. MHK

    MHK New Member

    @Feanwulf
    vielen Dank!
    Das hat ja jetzt schon mal geholfen ;)
    Ich habe das jetzt eingestellt und es funktioniert so wie ich es mir vorstelle.

    Bleibt nur noch das andere Problemchen bestehen...

    MfG MHK
     
  4. Till

    Till Administrator

    zu 2) Hast Du einen Eintrag in der /etc/aliases Datei für Postmaster?
     
  5. MHK

    MHK New Member

    Ich bin mir da nicht ganz sicher was da drin stehen muss.
    Bei mir sieht es wie folgt aus:

    Code:
    mailer-daemon: postmaster
    postmaster: root
    nobody: root
    hostmaster: root
    usenet: root
    news: root
    webmaster: root
    www: root
    ftp: root
    abuse: root
    noc: root
    security: root
    
    prinzipiell hat das aber meiner bescheidenen Meinung nach nix mit Postmaster direkt zu tuen, das betrifft eigentlich ale eMails, z.B. auch herr.mustermann@mydomain.de welche dann z.B. in web9p2@myhostname.de umgewandelt wird.

    MfG MHK
     
    Zuletzt bearbeitet: 6. Apr. 2009
  6. Till

    Till Administrator

    Erstmal zum Postmaster. Wenn Du separate postmaster@ Adressen anlegen willst dann musst Du die Zeile

    postmaster: root

    in der /etc/aliases löschen und dann das Kommando newaliases aufrufen.

    Emails werden bei ISPConfig 2 an Syste,muser zugestellt. Du scheinst hier die Emailadressen mit den Systemusersn zu verwechseln. da wird nichts umgeschrieben sondern wenn postfix im Log schreibt dass eine Email an web1@myhostname.de zugestellt wurde dann bedeutet das dass die Email an den benutzer web1 des Servers myhostname.de zugestellt wurde was absolut korrekt ist.
     

Diese Seite empfehlen