Postfix Port 587

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von relo, 2. Apr. 2012.

  1. relo

    relo New Member

    Hallo,

    ich versuche schon seit Stunden, den Port 587 freizugeben um nicht nur vom Port 25 E-Mails versenden zu können.
    Ich hab ISPConfig 3.0.4.3 und Postfix.

    Folgendes habe ich schon alles versucht:
    - Port 587 in ISPConfig Firewall freigegeben
    - submission in Master.cf auskommentiert
    - Configs versucht anzupassen, jedoch bisher mit wenig erfolg

    Es scheint so, dass wenigstens mal die Nachricht zum Server durch geht, aber dann abgelehnt wird:

    Apr 2 15:28:38 server postfix/smtpd[28561]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Apr 2 15:28:38 server postfix/smtpd[28561]: warning: i59F790E4.versanet.de[xx.xxx.xxx.xxx]: SASL LOGIN authentication failed: generic failure

    SASL ist aktiviert und auch alles gestartet:
    /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n

    Hier nun noch die jeweiligen relevanten Configs:

    Master.cf:
    smtp inet n - n - - smtpd
    submission inet n - n - - smtpd
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject

    /etc/default/saslauthd
    START=yes
    DESC="SASL Authentication Daemon"
    NAME="saslauthd"
    MECHANISMS="pam"
    MECH_OPTIONS=""
    THREADS=5
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"

    /etc/pam.d/smtp (Werte anonymisiert)
    auth required pam_mysql.so user=ispconfig passwd=password host=127.0.0.1 db=db table=table usercolumn=login passwdcolumn=password crypt=1
    account sufficient pam_mysql.so user=user passwd=mypassword host=127.0.0.1 db=db table=table usercolumn=login passwdcolumn=password crypt=1

    /etc/postfix/sasl/smtpd.conf
    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    auxprop_plugin: mysql
    sql_hostnames: 127.0.0.1
    sql_user: user
    sql_passwd: password
    sql_database: db
    sql_select: select password from mail_user where login = '%u'


    Vielleicht weiß ja von euch jemand, was ich noch falsch mache, denn über Port 25 funktioniert es wie es soll. Die Daten der E-Mails stehen natürlich in der Datenbank und die Passwörter sind verschlüsselt. Es besteht wirklich nur das Problem, dass ich nicht über Port 587 senden kann, obwohl ich Ihn freigeschaltet habe.

    Vielen Dank schon im Voraus.

    Mit freundlichen Grüßen

    relo
     
  2. relo

    relo New Member

    Hallo,

    ich habe mein Problem schon selber gelöst.

    Ich habe in einigen Beiträgen gelesen, dass man die smtp und submission nicht als root laufen lassen soll. Und das war "mein" Fehler. Ich musste es nur als root laufen lassen und dann ging es. In der Master.cf also folgende Änderungen:

    smtp inet n - - - - smtpd
    submission inet n - - - - smtpd
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticate d,reject

    Ich hoffe es hilft auch jemanden.

    Mit freundlichen Grüßen

    relo
     
  3. r_s

    r_s New Member

    Hallo, nur für's Protokoll, falls noch jemand, so wie ich, stundenlang nach einer Lösung gesucht hat: ;)
    Ja, hat es, vielen Dank!
     
  4. Brainfood

    Brainfood Member

    job, hab bei mir auch nur folgende Sachen geändert:

    vi /etc/postfix/master.cf

    Code:
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    ### ### ### PLITC ### ### ###
    submission inet n       -       -       -       -       smtpd
      -o syslog_name=postfix/submission
      -o smtpd_tls_security_level=encrypt
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    smtps     inet  n       -       -       -       -       smtpd
      -o syslog_name=postfix/smtps
      -o smtpd_tls_wrappermode=yes
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    ### ### ### PLITC ### ### ###
    #
    ISPConfig -> System -> Firewall
    - Port 465
    - Port 587

    freigeben.

    Ich benutze die ganzen letzten Jahre immer Submission, da in etlichen Internet-Cafés - SMTP über TCP 25 aus Prinzip gesperrt ist.

    Kleiner Tipp noch am Rande: Wer Postfix/Dovecot auf per IPv6 betreiben sollte, definiert einen klaren Reverse DNS (PTR) für eure IPv6-Adresse:

    vi /etc/postfix/main.cf

    Code:
    smtp_bind_address6 = 2a01:xxxx::x
    vi /etc/dovecot/dovecot.conf

    Code:
    ## IMAP specific settings
    protocol imap {
      mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/imap
      mail_plugins = quota imap_quota
      mail_max_userip_connections = 99
      listen = *,[::]
    }
    
    ## POP3 specific settings
    protocol pop3 {
      mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/pop3
      pop3_uidl_format = %08Xu%08Xv
      mail_plugins = quota
      mail_max_userip_connections = 99
      listen = *,[::]
    }
    Und eben TCP 465/587 in ip6tables freischalten.
     

Diese Seite empfehlen