Postfix und SASL-Auth

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von neinet, 31. Mai 2015.

  1. neinet

    neinet New Member

    Hi zusammen,

    nach tagelangen Versuchen mein Problem zu lösen, Hilfesuchen in Foren und auch diversen google-Suchen ( hier bin ich unter anderem auf dieses Forum gestossen ), muss ich leider gestehen - ich komme bei meinem Problem nicht weiter. Hier im Forum sind auch bereits das eine oder andere ähnliche Thema eröffnet, aber keines passt so richtig auf mein Problem, daher meine Schilderung mit der Hoffnung auf Hilfe ...

    Ich habe meinen Ubuntu 14.04 ( 64-Bit ) Server mit Postfix als Mailserver. Zur Authentifizierung hatte ich nun SASL ( via IMAP ) aktiviert und bei einem lokalen Test klappt das soweit auch einwandfrei:

    Code:
    root@server:/var/run/saslauthd# testsaslauthd -u info@********.de -p ******
    0: OK "Success."
    Sobald ich allerdings ein externes Mailprogramme zum versenden von Mails nutzen will ( getestet mit Outlook und Thunderbird ) renne ich in eine Authentifizierungs-Fehlermeldung und habe folgenden Log-Eintrag:

    Code:
    server postfix/smtpd[25797]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Ich hatte dazu nun, wie bereits erwähnt Dr. google befragt und stoße lediglich immer wieder auf Hinweise, dass ein Sym-Link ( /var/run/saslauthd ) nicht richtig gesetzt wäre, was aber bei mir nicht der Fall ist, denn das ist korrekt. Auch sind in diesem Verzeichnis die erwarteten Files vorhanden:

    Code:
    root@server:/var/run/saslauthd# ls -al
    total 968
    drwx--x---  2 root sasl    140 May 19 00:36 .
    drwxr-xr-x 15 root root    820 May 22 08:04 ..
    -rw-------  1 root root      0 May 19 00:36 cache.flock
    -rw-------  1 root root 986112 May 19 00:36 cache.mmap
    srwxrwxrwx  1 root root      0 May 19 00:36 mux
    -rw-------  1 root root      0 May 19 00:36 mux.accept
    -rw-------  1 root root      5 May 19 00:36 saslauthd.pid
    Da der Abruf der Mails ja einwandfrei klappt, schliesse ich auch eine "pauschale Fehlkonfiguration" aus, denn es hängt wirklich nur an der Authentifizierung sobald ich von einem externen Client Mails versenden will.

    Ach ja, der saslauthd läuft:

    Code:
    root@server:~# ps faux |grep sasl
    root      5530  0.0  0.0   8812   776 pts/1    S+   19:47   0:00                          \_ grep --color=auto sasl
    root      8677  0.0  0.0  85652  1164 ?        Ss   May19   0:00 /usr/sbin/saslauthd -a rimap -O 127.0.0.1 -c -m /var/run/saslauthd -r -n 5
    root      8678  0.0  0.0  85652   884 ?        S    May19   0:00  \_ /usr/sbin/saslauthd -a rimap -O 127.0.0.1 -c -m /var/run/saslauthd -r -n 5
    root      8679  0.0  0.0  85652   884 ?        S    May19   0:00  \_ /usr/sbin/saslauthd -a rimap -O 127.0.0.1 -c -m /var/run/saslauthd -r -n 5
    root      8681  0.0  0.0  85652   804 ?        S    May19   0:00  \_ /usr/sbin/saslauthd -a rimap -O 127.0.0.1 -c -m /var/run/saslauthd -r -n 5
    root      8682  0.0  0.0  85652  1028 ?        S    May19   0:00  \_ /usr/sbin/saslauthd -a rimap -O 127.0.0.1 -c -m /var/run/saslauthd -r -n 5
    Auch meine Postfix main.cf bin ich nun diverse male durch gegangen und kann keinen Dreher oder Fehler finden. Auszug:

    Code:
    smtpd_sasl_auth_enable          = yes
    broken_sasl_auth_clients        = yes
    ...
    smtpd_client_restrictions =
            sleep 5,
            reject_unknown_reverse_client_hostname,
            permit_mynetworks,
            permit_auth_destination,
            permit_sasl_authenticated
    ...
    smtpd_sender_restrictions =
            reject_unknown_sender_domain,
            reject_non_fqdn_sender,
            permit_sasl_authenticated,
            permit_mynetworks
    Ich hoffe, hier hat jemand eine glorreiche Idee :)
     

Diese Seite empfehlen