Problem beim Update....

#1
Hallo ....

bei dem Update von meinem Standard ISP-Config
Version: 2.2.19
auf
Version: 2.2.21

Tritt folgender Fehler auf:
########## g++ ##########
ERROR: g++ not found!

Hat jemand eine Idee?

Gruß

Olli
 
#2
Eigentlich sagt das nur, daß du den Compiler nicht richtig installiert hast auf deinem System.

Laut Perfect Setup würde ich unter DEBIAN nochmal:

Code:
apt-get install binutils cpp fetchmail flex gcc libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev g++
ausführen.
 

Till

Administrator
#3
Installiere bitte wie Feanwulf gesagt hat die Pakete g++ und cpp (also den c++ Compiler). Bevor Du dann das Update nochmal startest, musst Du unbedingt den Folgenden Befehl ausführen:

mkdir /root/ispconfig
 
#4
Ok...
noch mal genaue Infos für Euch:

- Debian Installation nach Anleitung http://www.howtoforge.de/howto/das-perfekte-setup-debian-etch-40/3/

- Alle Pakete auf aktuellem Stand.

- keine weiteren Änderungen im System.

- die letzten ISP-Config Updates (bis Version 2.2.19) liefen ohne Probleme durch

Nach dem Ausführen Eurer Anleitung kommt dann aber diese Fehlermeldung:

www-server:/# apt-get install binutils cpp fetchmail flex gcc libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev g++
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
binutils ist schon die neueste Version.
cpp ist schon die neueste Version.
fetchmail ist schon die neueste Version.
flex ist schon die neueste Version.
gcc ist schon die neueste Version.
libarchive-zip-perl ist schon die neueste Version.
libcompress-zlib-perl ist schon die neueste Version.
libdb4.3-dev ist schon die neueste Version.
libpcre3 ist schon die neueste Version.
lynx ist schon die neueste Version.
m4 ist schon die neueste Version.
make ist schon die neueste Version.
ncftp ist schon die neueste Version.
nmap ist schon die neueste Version.
openssl ist schon die neueste Version.
perl ist schon die neueste Version.
perl-modules ist schon die neueste Version.
unzip ist schon die neueste Version.
zip ist schon die neueste Version.
autoconf ist schon die neueste Version.
automake1.9 ist schon die neueste Version.
bison ist schon die neueste Version.
autotools-dev ist schon die neueste Version.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
libc6-dev: Hängt ab: libc6 (= 2.3.6.ds1-13etch4) aber 2.7-6 soll installiert werden
zlib1g-dev: Hängt ab: zlib1g (= 1:1.2.3-13) aber 1:1.2.3.3.dfsg-9 soll installiert werden
E: Kaputte Pakete


Wie kann ich dieses Problem nur lösen???
Warum lief alles vorher?
Die "Paketprobleme" müssen doch dann auch schon vor dem letzten funktionierenden Update bestanden haben?
 

Till

Administrator
#5
Das Paket g++ war auch schon für 2.2.19 notwendig, es muss also irgendwann nach der 2.2.19 Installation entfernt worden sein.

Ruf bitte mal auf:

apt-get update
apt-get upgrade

und danach nochmal den Befehl:

apt-get install binutils cpp fetchmail flex gcc libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev g++
 
#6
Jo...

leider wie zuvor beschrieben, alle installierten Pakete sind aktuell ...

www-server:/# apt-get update
Hole:1 http://ftp2.de.debian.org etch Release.gpg [378B]
OK http://ftp2.de.debian.org etch Release
Ign http://ftp2.de.debian.org etch/main Packages/DiffIndex
Ign http://ftp2.de.debian.org etch/main Sources/DiffIndex
OK http://ftp2.de.debian.org etch/main Packages
OK http://ftp2.de.debian.org etch/main Sources
Hole:2 http://security.debian.org etch/updates Release.gpg [189B]
OK http://security.debian.org etch/updates Release
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
OK http://security.debian.org etch/updates/main Packages
OK http://security.debian.org etch/updates/contrib Packages
OK http://security.debian.org etch/updates/main Sources
OK http://security.debian.org etch/updates/contrib Sources
Es wurden 2B in 2s geholt (1B/s)
Paketlisten werden gelesen... Fertig
www-server:/# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.


Der Fehler besteht immer noch :-/
 
#8
Das hatte ich schon vorher probiert.
Fehlermeldung:

www-server:~# apt-get install g++
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
g++: Hängt ab: g++-4.1 (>= 4.1.1-2) soll aber nicht installiert werden
E: Kaputte Pakete
 

Till

Administrator
#9
Du scheinst Irgendwie Dein apt Paketmanagement verstellt zu haben. Das hat mit ISPConfig erstmal nichts zu tun und muss gelöst werden, bevor Du ISPConfig installieren oder Updaten kannst. Poste mal den Inhalt der Datei /etc/apt/sources.list
 
#12
ich werde wahnsinning:

www-server:~# apt-get install g++-4.1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
g++-4.1: Hängt ab: libstdc++6-4.1-dev (= 4.1.1-21) soll aber nicht installier t werden
E: Kaputte Pakete
 
#14
Ich bin verzweifelt.....
Irgendwie beißt sich die Katze in den Schwanz:

www-server:~# apt-get install libstdc++6-4.1-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
libstdc++6-4.1-dev: Hängt ab: libc6-dev (>= 2.3.6-7) soll aber nicht installiert werden
E: Kaputte Pakete


www-server:~# apt-get install libc6-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.

Da Sie nur eine einzige Operation angefordert haben, ist es sehr wahrscheinlich,
dass das Paket einfach nicht installierbar ist und eine Fehlermeldung über
dieses Paket erfolgen sollte.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
libc6-dev: Hängt ab: libc6 (= 2.3.6.ds1-13etch4) aber 2.7-6 soll installiert werden
E: Kaputte Pakete


www-server:~# apt-get install libc6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
libc6 ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
www-server:~#
 
#15
Meine Sourcelist sieht wie folgt aus:

#
# deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 DVD Binary-1 20070819-11:33]/ etch contrib main

deb cdrom:[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 DVD Binary-1 20070819-11:33]/ etch contrib main

deb http://ftp2.de.debian.org/debian/ etch main non-free contrib
deb-src http://ftp2.de.debian.org/debian/ etch main non-free contrib

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

deb http://ftp.de.debian.org/debian-volatile/ etch/volatile main
deb http://volatile.debian.org/debian-volatile etch/volatile-sloppy main contrib non-free
Probier mal ein

apt-get dist-upgrade

damit werden dann teilweise Pakete installiert, die mit einem normalen upgrade nicht installiert würden.

Ansonsten was passiert bei einem:

apt-get build-dep libstdc++6-4.1-dev
 
#16
Moin....

leider immer noch das gleiche Problem.
Ich verstehe es nicht, eigentlich habe ich eine saubere Debian Installation??!!

Source-list wie beschrieben geändert.
(das cdrom nur auskommentiert)


www-server:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Berechne Upgrade...Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
www-server:~# apt-get build-dep libstdc++6-4.1-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
E: Build-Abhängigkeiten für libstdc++6-4.1-dev konnten nicht erfüllt werden.
 
#18
Ich würde mal bei google nach Paket Abhängigkeit suchen und vielleicht dort einen Ansatz finden!

Leider weiß ich nicht wie man weiterhelfen kann - mein Know-How ist ausgereizt!
 

Till

Administrator
#19
Sind sie auch :)

Das Problem, das Du hast habe ich eigentlich nur schon mal auf Systemen gesehen, die apt repopositoeris vom unstable Zweig drin hatten oder aber repositories mehrer Versionen gemischt haben. das ist alles bei Dir nicht der Fall, soweit ich es sehen kann.

Ich würde an Deiner Stelle mal auf der Debian Mailingliste nachfragen, was man da machen kann. Mir fällt da im Moment keine Lösung ein, wie man Deiner Paketdatenbank wieder auf die Beine helfen kann.
 

Werbung