Problem im Zusammenhang mit IPv6

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von csiebert, 22. Nov. 2011.

  1. csiebert

    csiebert Member

    Hallo zusammen,

    nach einem Update auf 3.0.4 habe ich im Interface eine IPv6 Adresse eingetragen und diese einigen Kunden zugeordnet. Nun weigert sich allerdings der Apache neu zu starten:

    Code:
    root@server:/etc/apache2# /etc/init.d/apache2 restart
    Restarting web server: apache2[Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost 2a01:xxx:xx:xxxx:::443 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost 78.47.xx.xx:80 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost 78.47.xx.xx:443 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost *:8080 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost 2a01:xxx:xx:xxx:::443 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost *:8080 has no VirtualHosts
    [Tue Nov 22 13:53:17 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:8080
    Deaktiviere ich ispconfig.vhost und ispconfig.conf im Apache, startet er einwandfrei. Interessant finde ich:

    Code:
    root@server:/etc/apache2# netstat -tulpn| grep :80
    tcp6       0      0 :::8080                 :::*                    LISTEN      31695/apache2
    tcp6       0      0 :::80                   :::*                    LISTEN      31695/apache2
    tcp6       0      0 :::8081                 :::*                    LISTEN      31695/apache2
    Wie kann das angehen? Wieso hört der Apache auf 8080/8081 über IPv6 obwohl ich die ipconfig.* dateien nicht mehr include?

    Setzt noch jemand IPv6 ein und kann das Problem nachvollziehen?

    Danke + Gruß, Chris
     
  2. Till

    Till Administrator

    Scheint so als ob irgendwo anders noch in Deiner Apache Konfiguration ein Listen Statmemet für IPv6 drin steht. Such doch mal mit grep in allen apache Config Dateien.
     
  3. csiebert

    csiebert Member

    Habe mal ein wenig recherchiert... Ein Kunde, der SSL verwendet, hat eine neue Subdomain angelegt, das scheint - zumindest zeitlich - irgendwie der Auslöser gewesen zu sein dafür, dass der Apache hing. Ein Kollege hat einen Neustart versucht und die Fehlermeldung erhalten. Er war dann schon mal so raffiniert, die Fehlermeldung zu notieren :)

    Im Endeffekt habe ich den Fehler offensichtlich selber produziert: als ich die Einträge der enabled-sites durchsah, vermisste ich den Eintrag für ispconfig und legte ihn neu an. Allerdings gab es schon einen, und zwar unter "000-ispconfig.conf". Gesehen habe ich das nicht, weil einige vhosts eine führende "000-" haben, andere nicht. Da das Problem nun behoben ist, bleibt mir nur noch die Frage, was es mit dem Präfix auf sich hat, den nur einige Hosts haben...?

    Gruß, Chris
     
  4. Till

    Till Administrator

    Apache list die vhosts in alphabetischer Reihenfolge ein, daher ist es notwendig dien dateien eine gewisse Zwangsreihenfolge zu geben:

    000- sind ispconfig vhost, Konfigurations und Defaultdateien des betriebssystems
    100- sind normale vhosts
    500- sind vhosts mit auto subdomain *
     
  5. csiebert

    csiebert Member

    okay, und was ist mit den vhosts, die keinen präfix haben? :)
     
  6. Till

    Till Administrator

    Die funktionieren weiter wie bisher. Der Präfix wird nach und nach bei vhost Updates automatisch übernommen.
     

Diese Seite empfehlen