[PROBLEM] Mail-Empfangen

#1
Hallo liebe Boardies,

ich als Neuling des HowToForge.de-Forums muss euch leider mit einem für mich leidigem Thema nerven und zwar gehts um das Problem, dass ich keine eMails empfangen kann auf den Mails, Senden ja!, aber Empfangen geht nicht.
Ich habe mein Debian 4 Etch System mit Hilfe des "Das Perfekte Debian-Setup HowTo" installiert mit ISPConfig! Soweit so gut, bislang läuft es auch sehr gut!

Nun habe ich es geschafft mich über Webmail einzuloggen und emails zu versenden! Aber eMails empfangen willer einfach nicht! Hier der Auszug aus einer Mail die zurückgekommen ist:

Reporting-MTA: dns; m2.goneo.de
X-Postfix-Queue-ID: 0A0B2130D4C
X-Postfix-Sender: rfc822; NaTzoR@my-unique.de
Arrival-Date: Thu, 13 Dec 2007 14:19:49 +0100 (CET)

Final-Recipient: rfc822; web4_admin@die-maniacs.de
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; host mx00.udag.de[62.146.106.39] said: 550 5.1.1
<web4_admin@die-maniacs.de>: Recipient address rejected: User unknown in
local recipient table (in reply to RCPT TO command)
Hier mal meine main.cf:

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server.die-maniacs.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = server.die-maniacs.de, localhost.die-maniacs.de, , localhost
relayhost = 
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = server.die-maniacs.de, localhost.die-maniacs.de, localhost.localdomain, localhost
und hier meine /var/log/mail.warn:

Dec 13 17:40:24 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 4924 exit status 1
Dec 13 17:40:24 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 13 17:41:24 server postfix/smtpd[4938]: warning: SASL per-process initialization failed: generic failure
Dec 13 17:41:24 server postfix/smtpd[4938]: fatal: SASL per-process initialization failed
Dec 13 17:41:25 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 4938 exit status 1
Dec 13 17:41:25 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 13 17:42:25 server postfix/smtpd[4952]: warning: SASL per-process initialization failed: generic failure
Dec 13 17:42:25 server postfix/smtpd[4952]: fatal: SASL per-process initialization failed
Dec 13 17:42:26 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 4952 exit status 1
Dec 13 17:42:26 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 13 17:43:26 server postfix/smtpd[4966]: warning: SASL per-process initialization failed: generic failure
Dec 13 17:43:26 server postfix/smtpd[4966]: fatal: SASL per-process initialization failed
Dec 13 17:43:27 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 4966 exit status 1
Dec 13 17:43:27 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 13 17:44:27 server postfix/smtpd[4982]: warning: SASL per-process initialization failed: generic failure
Dec 13 17:44:27 server postfix/smtpd[4982]: fatal: SASL per-process initialization failed
Dec 13 17:44:28 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 4982 exit status 1
Dec 13 17:44:28 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 13 17:45:28 server postfix/smtpd[4996]: warning: SASL per-process initialization failed: generic failure
Dec 13 17:45:28 server postfix/smtpd[4996]: fatal: SASL per-process initialization failed
Dec 13 17:45:29 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 4996 exit status 1
Dec 13 17:45:29 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Dec 13 17:46:29 server postfix/smtpd[5010]: warning: SASL per-process initialization failed: generic failure
Dec 13 17:46:29 server postfix/smtpd[5010]: fatal: SASL per-process initialization failed
Dec 13 17:46:30 server postfix/master[1218]: warning: process /usr/lib/postfix/smtpd pid 5010 exit status 1
Dec 13 17:46:30 server postfix/master[1218]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Hoffe, das hilft euch ein wenig weiter mir zu helfen! Wenn noch was fehlt bitte melden!

Gruß
NaTzoR
 
#2
Reporting-MTA: dns; m2.goneo.de
X-Postfix-Queue-ID: 0A0B2130D4C
X-Postfix-Sender: rfc822; NaTzoR@my-unique.de
Arrival-Date: Thu, 13 Dec 2007 14:19:49 +0100 (CET)

Final-Recipient: rfc822; web4_admin@die-maniacs.de
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; host mx00.udag.de[62.146.106.39] said: 550 5.1.1
<web4_admin@die-maniacs.de>: Recipient address rejected: User unknown in
local recipient table (in reply to RCPT TO command)
Das bedeutet der Server mx00.udag.de mag den Empfänger "web4_admin@die-maniacs.de" nicht.

Dein ISPConfig Server will also deine eMail extern zustellen und nicht local in das vorhandene postfach!


Stehen denn Einträge in deiner /etc/postfix/virtusertable drin? Und hast du bei deiner Domain unter Options auch "Lokaler Mailserver" ausgewählt?
 
#3
Hi,

meine virtuserstable sieht so aus:

Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
admin@www.die-maniacs.de    web4_admin
web4_admin@www.die-maniacs.de    web4_admin
admin@die-maniacs.de    web4_admin
web4_admin@die-maniacs.de    web4_admin
oli@www.oli.die-maniacs.de    web10_oli
web10_oli@www.oli.die-maniacs.de    web10_oli
oli@oli.die-maniacs.de    web10_oli
web10_oli@oli.die-maniacs.de    web10_oli
martin@www.marschsoft.de    web11_martin
web11_martin@www.marschsoft.de    web11_martin
martin@marschsoft.de    web11_martin
web11_martin@marschsoft.de    web11_martin
cd@www.tafel.marschsoft.de    web12_tafel
web12_tafel@www.tafel.marschsoft.de    web12_tafel
cd@tafel.marschsoft.de    web12_tafel
web12_tafel@tafel.marschsoft.de    web12_tafel
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Und die bei der Domain stehts auf: Lokaler Mailserver!

Gruß
NaTzoR
 
Zuletzt bearbeitet:
#4
Also habe mir nochmal deine eMail durchgelesen.

Aktuell zeigt der Mailserver für deine Domain "die-maniacs.de" nicht auf den ISP Config Server deshalb bekommst du die eMails auch nicht.

Versuch mal dir selbst über den Webmailer eMails zuzuschicken. Geht das denn? Wenn ja musst du deinem Provider mitteilen, daß der MX Record für die Domain die-maniacs.de auf deinen ISPConfigServer geändert werden muß

UND ganz wichtig, lass dir für deine IP-Adresse auch einen ReverseDNS Eintrag setzen, damit du eMails versenden kannst, ansonsten wirst du geblockt bei einigen Providern!
 

Werbung