Problem mit DRBD

Dieses Thema im Forum "Server Administration" wurde erstellt von Chr.Raible, 15. Mai 2009.

  1. Chr.Raible

    Chr.Raible New Member

    Hi @all,

    hier nochmal auf deutsch ^^ das liegt mir besser (hab im englischen Forum auch gepostet ;) )

    Ich hab ein Problem mit meiner DRBD-Apache-Cluster installation. Und zwar hab ich das Howto von verne.me verwendet. Leider habe ich das Howto nicht gespeichert und die Seite ist jetzt down.

    Und zwar ist mir folgendes passiert. Ich habe meine zwei produktiv server gestarte und hab dann nicht richtig aufgepasst und zusätzlich noch die beiden Backupserver, die die gleichen IP´s und gleiche DNS namen haben, ebenfalls gestartet.

    jetzt habe ich das Problem, dass sich meine beiden Produktivserver nicht mehr finden.

    Wenn Sie starten, gehen sie problemlos weiter, was ja eigentlich bedeutet, dass sie sich irgendwie doch finden.

    Wenn ich jetzt aber auf dem ersten Server "cat /proc/drbd" eingebe erhalte ich folgende ausgabe:

    Gebe ich nun "cat /proc/drbd" auf dem zweite Server ein kommt folgende ausgabe:


    Meine drbd.con sieht so aus:

    Hat da einer von euch eine Idee, wie ich das wieder hinbekomme, dass die sich gegenseitig wieder finden und spiegeln?

    Sollten Daten bei einer Lösung verloren gehen, ist das kein Problem, da ich nen backup hab und man das ja einfach wieder einspielen kann. Hauptsache ist das die Platten sich wieder gegenseitig spiegeln.

    Mfg
    Chr.Raible

    PS: Wenn noch jemand eine gute Anleitung kennt, wie ich das neu aufsetzen kann unter debian Lenny wäre das auch ok. Hab es aber schon mit ein paar Tutorials versuch und das hat nicht geklappt.
     
  2. dynosaur

    dynosaur New Member

Diese Seite empfehlen