Problem mit DRBD

#1
Hi @all,

hier nochmal auf deutsch ^^ das liegt mir besser (hab im englischen Forum auch gepostet ;) )

Ich hab ein Problem mit meiner DRBD-Apache-Cluster installation. Und zwar hab ich das Howto von verne.me verwendet. Leider habe ich das Howto nicht gespeichert und die Seite ist jetzt down.

Und zwar ist mir folgendes passiert. Ich habe meine zwei produktiv server gestarte und hab dann nicht richtig aufgepasst und zusätzlich noch die beiden Backupserver, die die gleichen IP´s und gleiche DNS namen haben, ebenfalls gestartet.

jetzt habe ich das Problem, dass sich meine beiden Produktivserver nicht mehr finden.

Wenn Sie starten, gehen sie problemlos weiter, was ja eigentlich bedeutet, dass sie sich irgendwie doch finden.

Wenn ich jetzt aber auf dem ersten Server "cat /proc/drbd" eingebe erhalte ich folgende ausgabe:

0: cs:StandAlone st:primary/Unknown ds:UpToDate/DUnknown r---
ns:0 nr:0 dw:4 dr:17 al:1 bm:13 lo:0 pe:0 ua:0 ap:0
resync: used:0/61 hits:0 misses:0 starving:0 dirty:0 changed:0
act_log: used:0/257 hits:0 misses:1 starving:0 dirty:0 changed:1
Gebe ich nun "cat /proc/drbd" auf dem zweite Server ein kommt folgende ausgabe:

0: cs:StandAlone st:Secondary/Unknown ds:UpToDate/DUnknown r---
ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
resync: used:0/61 hits:0 misses:0 starving:0 dirty:0 changed:0
act_log: used:0/257 hits:0 misses:0 starving:0 dirty:0 changed:0

Meine drbd.con sieht so aus:

#/etc/drbd.conf
global {
usage-count yes;
}
common {
syncer { rate 10M; }
}
resource r0 {
protocol C;
handlers {
pri-on-incon-degr "echo o > /proc/sysrq-trigger ; halt -f";
pri-lost-after-sb "echo o > /proc/sysrq-trigger ; halt -f";
local-io-error "echo o > /proc/sysrq-trigger ; halt -f";
outdate-peer "/usr/sbin/drbd-peer-outdater";
}
startup {
}
disk {
on-io-error detach;
}
net {
}
syncer {
rate 10M;
al-extents 257;
}
on drbd-web01 {
device /dev/drbd0;
disk /dev/sda8;
address 192.168.2.110:7788;
meta-disk /dev/sda7[0];
}
on drbd-web02 {
device /dev/drbd0;
disk /dev/sda8;
address 192.168.2.111:7788;
meta-disk /dev/sda7[0];
}
}
Hat da einer von euch eine Idee, wie ich das wieder hinbekomme, dass die sich gegenseitig wieder finden und spiegeln?

Sollten Daten bei einer Lösung verloren gehen, ist das kein Problem, da ich nen backup hab und man das ja einfach wieder einspielen kann. Hauptsache ist das die Platten sich wieder gegenseitig spiegeln.

Mfg
Chr.Raible

PS: Wenn noch jemand eine gute Anleitung kennt, wie ich das neu aufsetzen kann unter debian Lenny wäre das auch ok. Hab es aber schon mit ein paar Tutorials versuch und das hat nicht geklappt.
 

Werbung

Top