Problem mit FTP PFad und phpMyAdmin

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Dooboy, 23. Jan. 2008.

  1. Dooboy

    Dooboy New Member

    So, nachdem ich das "Perfekt Setup" durchgeführt habe, läuft da System.

    Allerdings, habe ich das Problem, wenn ich ein FTP User einrichte (komisch das es unter email zu finden ist), dann wird in der /etc/htpasswd der User auch angelegt, das einloggen mit meinen Clients wunderbar. Allerdings nicht da wo die Urls hinzeigen.

    Also der FTP Pfad sieht in so aus

    das ist doch mist oder soll die Url dahin?
    denke ich aber mal nicht

    Es müsste doch so aussehen

    Wenn ich die Url aufrufe bekomme ich ja auch zur passenden Domain den Index, aber halt nicht das vom FTP.

    So das ist das erste Problem.
    Das zweite:

    Ich habe mir das phpMyAdmin pgk geholt und installiert, als ich dann auf den Link klicke htaccess, wo kommt das her, wie sind die Daten?
    Ich habe schon alles was ich irgendwo eingegeben habe ausprobiert.

    Gruß
    Daniel
     
  2. Till

    Till Administrator

    Es ist unter "user & email" zu finden, user = FTP oder SSH User ;)

    Zu Deinem 1. Problem, Du hast vergessen die "Administrator" Checkbox des Users zu aktivieren.

    Das ist kein .htaccess. Er fragt Dich nach Deinem MySQL Usernamen und Passwort. Die solltest Du kennen, Du hast sie während des howtos selbst für den User root eingegenben.
     
  3. Dooboy

    Dooboy New Member

    Läuft.

    Ein Abtippfehler :(


    Naja, nun läuft ja alles hoffe ich ;)
     
  4. Dooboy

    Dooboy New Member

    Aber ich bekomme es nicht hin die DB extern zu haben, trotz der erlaubnis bei den User.

    Wie gesagt einstellungen sich exakt aus den Perfekt Setup

    Da jemand ne Idee, bitte nichts davon es ist unsicher. Dessen bin ich mir bewusst nur muss es ein paar Stunden so sein.
     
  5. Till

    Till Administrator

    Poste mal die Ausgabe von:

    netstat -tap

    und:

    iptables -L

    Wenn Dein Server hinter einem router ist, vergiss nicht Port 3306 im router auf Deinen Server umzuleiten.
     
  6. Dooboy

    Dooboy New Member

    netstat -tab



    iptables -L



    Dann ist mir aufgefallen das ich nur als root in phpMyAdmin reinkomme, ist das so richtig (auf ispconfig bezogen)?
     
  7. Till

    Till Administrator

    Ok, firewall ist nicht an und mysql läuft auf allen IP's. Stell bitte sicher, dass Du die Zeile:

    bind-address = 127.0.0.1
    in der Datei:

    /etc/mysql/my.cnf

    auskommentiert hast, wie es in dem ISPConfig Installationsanleitungen beschrieben ist.

    Ist Dein Server hinter einem Router?

    Wenn Du keine weiteren mysql datenbanken und zugehörigen user angelegt hast, dann ja.
     
  8. Dooboy

    Dooboy New Member

    Bind ist auskommentiert


    Ich denke mal das Hetzner ne Firewall hat ;)

    Ne, im ernst. Ich habe nichts eingestellt. Bin wie ein Dummer an die Anleitung gegangen, daher sind die Einstellungen aktuell.


    Die anderen User können sich nun auch einloggen, musste Irgendwas neu gestartet werden
     

Diese Seite empfehlen