Problem mit ISP Config und suphp

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hambuergaer, 15. Nov. 2008.

  1. hambuergaer

    hambuergaer New Member

    Hallo Leute,

    ich habe ISP Config 2.2.27 und suphp 0.6.2 installiert. ISP Config läuft auch soweit. Wenn ich nun aber PHP Seite in eine Web kopiere, dann bekomme ich einen Fehler 500 zurück.

    /var/log/suphp.log sagt folgendes: [Sat Nov 15 18:25:33 2008] [warn] Directory /var/www is not owned by web5_irgendeinuser

    Was mache ich falsch? Ich habe dieses Howto verwendet:

    http://www.howtoforge.org/suphp_debian_etch_ispconfig

    Danke und Gruß
     
  2. Till

    Till Administrator

  3. hambuergaer

    hambuergaer New Member

    Hallo Till,

    danke für den Link. So hat es geklappt :) Allerdings musste ich den urprünglichen Zustand von /etc/suphp.conf widerherstellen:

    Code:
    [global]
    ;Path to logfile
    logfile=/var/log/suphp.log
    
    ;Loglevel
    loglevel=warn
    
    ;User Apache is running as
    webserver_user=www-data
    
    ;Path all scripts have to be in
    docroot=/
    
    ;Path to chroot() to before executing script
    ;chroot=/mychroot
    
    ; Security options
    allow_file_group_writeable=true
    allow_file_others_writeable=false
    allow_directory_group_writeable=true
    allow_directory_others_writeable=false
    
    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true
    
    ;Send minor error messages to browser
    errors_to_browser=false
    
    ;PATH environment variable
    env_path=/bin:/usr/bin
    
    ;Umask to set, specify in octal notation
    umask=0022
    
    ; Minimum UID
    min_uid=100
    
    ; Minimum GID
    min_gid=100
    
    [handlers]
    ;Handler for php-scripts
    x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper
    
    ;Handler for CGI-scripts
    x-suphp-cgi=execute:!self
    
    
    So klappts dann auch mit suphp
     

Diese Seite empfehlen