Problem mit Login auf IMAP

#1
Problem mit Login auf IMAP / NTPD Fehler

Hallo,

ich habe ein Problem mit meinem Server, aus irgend einem Grund kann ich mich nicht mehr per IMAP einloggen, bzw werde nicht als Benutzer aktzeptiert.
Passwort und Benutzer stimmen ganz sicher.

Es funktioniert weder per Webmail "Keine Verbindung zum IMAP-Server"
oder per Thunderbird, der die Verbindung ja gespeichert hatte und erst seit heute Nacht keinen Login mehr zulässt.

Die mail.log sagt :
Code:
May 13 14:17:19 XXXXXXX imapd: Disconnected, ip=[::ffff:83.221.70.120], time=11, starttls=1
May 13 14:19:50 XXXXXX postfix/anvil[4402]: statistics: max connection rate 6/60s for (smtp:83.221.70.120) at May 13 14:16:30
May 13 14:19:50 XXXXXXX postfix/anvil[4402]: statistics: max connection count 4 for (smtp:83.221.70.120) at May 13 14:16:30
May 13 14:19:50 XXXXXXX postfix/anvil[4402]: statistics: max cache size 1 at May 13 14:16:30
May 13 14:20:02 XXXXXX pop3d: Connection, ip=[::ffff:127.0.0.1]
May 13 14:20:02 XXXXXX pop3d: Disconnected, ip=[::ffff:127.0.0.1]
May 13 14:20:02 XXXXXX imapd: Connection, ip=[::ffff:127.0.0.1]
May 13 14:20:02 XXXXXX imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
May 13 14:20:03 XXXXXX postfix/smtpd[4482]: connect from localhost.localdomain[127.0.0.1]
May 13 14:20:03 XXXXXXX postfix/smtpd[4482]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 13 14:20:03 XXXXXX postfix/smtpd[4482]: disconnect from localhost.localdomain[127.0.0.1]
May 13 14:23:23 XXXXXX imapd: Connection, ip=[::ffff:127.0.0.1]

May 14 01:28:46 XXXXXXXX imapd-ssl: LOGIN FAILED, method=PLAIN, ip=[::ffff:83.221.70.120]
May 14 01:28:51 XXXXXXXX imapd-ssl: LOGIN FAILED, user=info, ip=[::ffff:83.221.70.120]
May 14 01:28:56 XXXXXXXX imapd-ssl: Disconnected, ip=[::ffff:83.221.70.120], time=10, starttls=1
May 14 01:30:03 XXXXXXXX pop3d: Connection, ip=[::ffff:127.0.0.1]
May 14 01:30:03 XXXXXXXX pop3d: Disconnected, ip=[::ffff:127.0.0.1]
May 14 01:30:03 XXXXXXXX imapd: Connection, ip=[::ffff:127.0.0.1]
May 14 01:30:03 XXXXXXXX imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
May 14 01:30:03 XXXXXXXX postfix/smtpd[1632]: connect from localhost.localdomain[127.0.0.1]
May 14 01:30:03 XXXXXXXX postfix/smtpd[1632]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
May 14 01:30:03 XXXXXXXX postfix/smtpd[1632]: disconnect from localhost.localdomain[127.0.0.1]
die .err sagt nur eine meldung von heute die aber 7 mal:

Code:
May 13 14:16:28 XXXXXX pop3d-ssl: Maximum connection limit reached for ::ffff:83.221.70.120
aber netstat -tap | grep imap
sagt ganz normal :
Code:
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      1346/couriertcpd
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      4271/couriertcpd
weiß nicht woran es liegen kann.
Postfix hatte zwar ein Update, und ich hab versucht die Konfiguration mittels update von ISPConfig neu schreiben zu lassen, aber keine Änderung.

Die Tabelle mit den Mail-Benutzern funktioniert und hat alle Einträge .

weiß daher nicht woran es liegen kann.

Jemand eine Idee? :-/
 
Zuletzt bearbeitet:
#2
Also ich konnte es bisher nur auf die Authentifikation zurück führen.
Die authmysqlrc datei sieht aber auch richtig aus.

ISPConfig meldet das der IMAP läuft. Roundcube sagt er kann nicht zum IMAP verbinden (aber nur wenn das Passwort richtig ist)

und Thunderbird kann mit den Einstellungen :


imap.xxxxxx.de : 143 STARTTLS
smtp.xxxxxxx.de : 587 STARTTLS

Nicht verbinden weil er mir sagt das die Konfiguration so falsch ist
(Benutzer/Passwort)

Wirklich keiner der mir erstml weiterhelfen kann? :-/


Vielleicht wem das hie rnoch hilft ?!:
Code:
tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      579/spamd.pid   
tcp        0      0 *:http-alt              *:*                     LISTEN      1501/apache2    
tcp        0      0 *:www                   *:*                     LISTEN      1501/apache2    
tcp        0      0 *:tproxy                *:*                     LISTEN      1501/apache2    
tcp        0      0 *:ftp                   *:*                     LISTEN      1279/pure-ftpd (SER
tcp        0      0 xxxxxxxx:domain        *:*                     LISTEN      414/named       
tcp        0      0 localhost.locald:domain *:*                     LISTEN      414/named       
tcp        0      0 *:ssh                   *:*                     LISTEN      426/sshd        
tcp        0      0 *:smtp                  *:*                     LISTEN      1239/master     
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      414/named       
tcp        0      0 *:https                 *:*                     LISTEN      1501/apache2    
tcp        0      0 localhost.localdom:smtp localhost.localdo:56811 SYN_RECV    -               
tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      448/amavisd (master
tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      1239/master     
tcp        0      0 *:mysql                 *:*                     LISTEN      508/mysqld      
tcp        0    288 xxxxxxxx:ssh           83-221-70-120.dyn:59416 ESTABLISHED 1548/0          
tcp        0      0 xxxxxxx:www           hnvr-4dbb95f5.poo:27763 ESTABLISHED 1511/apache2    
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      963/couriertcpd 
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      945/couriertcpd 
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      1279/pure-ftpd (SER
tcp6       0      0 [::]:domain             [::]:*                  LISTEN      414/named       
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      426/sshd        
tcp6       0      0 ::1%25839536:953        [::]:*                  LISTEN      414/named       
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      957/couriertcpd 
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      975/couriertcpd
 
Zuletzt bearbeitet:
#4
also ich habs jetzt mit dem debug modus ein wenig besser aufschlüsseln können :


Code:
May 15 13:10:37 XXXXX authdaemond: received auth request, service=imap, authtype=login
May 15 13:10:37 XXXXX authdaemond: authmysql: trying this module
May 15 13:10:37 XXXXX authdaemond: SQL query: SELECT email, password, "", uid, gid, homedir, maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'info@XXXXX '
May 15 13:10:37 XXXXX authdaemond: password matches successfully
May 15 13:10:37 XXXXX authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=info@XXXXX , fullname=<null>, maildir=/var/vmail/xxxxxxx.de/info, quota=5242880000, options=disableimap=n,disablepop3=n
May 15 13:10:37 XXXXX authdaemond: authmysql: clearpasswd=<null>, passwd=$1$WmbZnDiO$DxAWTXp4TVwrT8XqqPQk80
May 15 13:10:37 XXXXX authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=info@XXXXX.de, fullname=<null>, maildir=/var/vmail/XXXXX .de/info, quota=5242880000, options=disableimap=n,disablepop3=n
May 15 13:10:37 XXXXX authdaemond: Authenticated: clearpasswd=YYYYYYYYYYYYYY !, passwd=$1$WmbZnDiO$DxAWTXp4TVwrT8XqqPQk80
May 15 13:10:38 XXXXX pop3d: Disconnected, ip=[::ffff:61.242.169.1]
May 15 13:10:39 XXXXX pop3d: Connection, ip=[::ffff:61.242.169.1]
May 15 13:10:40 XXXXX pop3d: LOGIN FAILED, user=louise, ip=[::ffff:61.242.169.1]
May 15 13:10:40 XXXXX authdaemond: received auth request, service=pop3, authtype=login
May 15 13:10:40 XXXXX authdaemond: authmysql: trying this module
May 15 13:10:40 XXXXX authdaemond: SQL query: SELECT email, password, "", uid, gid, homedir, maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'louise'
May 15 13:10:40 XXXXX authdaemond: zero rows returned
May 15 13:10:40 XXXXX authdaemond: no password available to compare
May 15 13:10:40 XXXXX authdaemond: authmysql: REJECT - try next module
May 15 13:10:40 XXXXX authdaemond: FAIL, all modules rejected
May 15 13:10:45 XXXXX pop3d: Disconnected, ip=[::ffff:61.242.169.1]
May 15 13:10:46 XXXXX pop3d: Connection, ip=[::ffff:61.242.169.1]
Also laut imap bin ich auchthetifiziert.Wenn ich das richtig sehe...oder?!



(Man ignoriere mal die Bots oder sonstwas die sich da per pop einloggen wollen ^^°)



// Wenn ich mich btw per telnet localhost 143 anmelde und eingebe
a login USER PW

bekomme ich den Fehler
* BYE Clock skew detected. Check the clock on the file server


Als ich danach gegooglelt habe, hab ich fehler gefunden die mit dem NTP zusammenhängen und tatsächlich:

XXXX :/etc/apache2/conf.d# date && touch test && stat test
Sun May 15 13:45:15 CEST 2011
File: `test'
Size: 0 Blocks: 0 IO Block: 262144 regular empty file
Device: 81h/129d Inode: 12861482 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2011-05-15 13:45:55.000000000 +0200
Modify: 2011-05-15 13:45:55.000000000 +0200
Change: 2011-05-15 13:45:55.000000000 +0200


Das sind mehr als 30 SEC unterschied, und daher kommt zumindest schonmal DER fehler.
Weiß jemand was mit dem ntp da nicht funktionieren könnte?
 
Zuletzt bearbeitet:
#5
Es scheint an diesem
Code:
* BYE Clock skew detected. Check the clock on the file server
zu liegen.

Wie gesagt läuft irgendwas mit dem NTPD falsch, also hab ich ntpdate und ntp mal deinstalliert, server neu gestartet und siehe da :

XXXXX :~# ps aux | grep ntpdate
root 1787 0.0 0.0 3880 596 pts/0 R+ 22:15 0:00 grep ntpdate
XXXXX :~# ps aux | grep ntpdate
root 1789 0.0 0.0 3880 600 pts/0 R+ 22:15 0:00 grep ntpdate
XXXXX :~# ps aux | grep ntpdate
root 1797 0.0 0.0 3880 596 pts/0 R+ 22:15 0:00 grep ntpdate
XXXXX :~# ps aux | grep ntpdate
root 1799 0.0 0.0 3880 600 pts/0 R+ 22:15 0:00 grep ntpdate
XXXXX :~# ps aux | grep ntpdate
root 1801 0.0 0.0 3880 596 pts/0 R+ 22:15 0:00 grep ntpdate
Dieser dämlich service startet sich immernoch immer wieder nue mit versch pids ?

wie geht das denn bitte?
Wie werde ich das ding los ? -.-

da kann ja irgendwas nicht stimmen :-7
 

Till

Administrator
#6
ntpd sollte auf dem Server schon laufen, und zwar auf allen beteiligten Servern. Ansonsten bekommst Du früher oder später ein problem, dass die Zeit auseinander läuft. Überprüf bitte auch ob alle beteiligten Server die gleiche Zeitzone haben.
 
#7
Puh, was für eine Qual.
ich hab meine Erkentnisse mal meinem vServer Provider mitgetteilt , und endlich endlich endlich ist das Problem gelöst.

Nachdem ich alles geschildert hatte stellt sich raus, das die Daten des vServers physisch getrennt vom System des vServers aufbewahrt werden.

Die Verzögerung entstand daher auf seiten des File-Servers des vServers selbst, also außerhalb meines Systems und meiner Zuständigkeit.

Der Provider hat das Problem dann lösen können. Es schien bisher keinem weiter aufzufallen, da auf der Maschiene ich zZ der einzige (noch) bin?! Wenn ich das alles richtig verstanden habe.

Der Hoster hat die Systeme nun wieder angeglichen und es funktioniert wieder.
Sehr schade finde ich allerdings das courier diesen "Fehler" der ja sicherlich seine Berechtigung hat, leider nicht aussagekräftig und auch nicht im DEBUG Modues, kenntlich machen kann.

Schließlich läuft die Authentifizierung glatt, aber danach beendet sich JEDE Session sofort wieder, wegen o.g. Fehlers.

Dies sollte wenigstens geloggt werden.
Nun gut, das fällt ja aber gottseidank nicht mehr in unseren/euren Aufgabenbereich.

Hat sich also jetzt erledigt.
Danke euch allen.
 

Werbung